Jump to content

Recommended Posts

Jeg vil meget gerne indsætte en iframe under en CMS-side i min webshop. 

Når jeg embedder koden, får jeg fint billedet frem og det ser godt ud. Når jeg så trykker gem, kommer denne fejlmeddelse.  Nogen, der kan hjælpe???

[PrestaShopException]

Property InfoBlock->text is not valid
at line 962 in file classes/ObjectModel.php

957.                 }
958. 
959.                 $message = $this->validateField($field, $value, $id_lang);
960.                 if ($message !== true) {
961.                     if ($die) {
962.                         throw new PrestaShopException($message);
963.                     }
964.                     return $error_return ? $message : false;
965.                 }
966.             }
967.         }

Share this post


Link to post
Share on other sites

<a href="http://www.soliditet.dk/lang/da_DK/RatingGuideline" target="_blank" style="text-decoration: none;"><img style="border:0px;" oncontextmenu="return false" title="Vi er en kreditv&aelig;rdig virksomhed baseret p&aring; Bisnodes kreditvurderingssystem. Vurderingen er foretaget ud fra en m&aelig;ngde forskellige beslutningsregler. Oplysningerne bliver opdateret dagligt via Bisnodes database. Kreditvurderingen af virksomheden er s&aring;ledes altid aktuel." alt="Vi er en kreditv&aelig;rdig virksomhed baseret p&aring; Bisnodes kreditvurderingssystem. Vurderingen er foretaget ud fra en m&aelig;ngde forskellige beslutningsregler. Oplysningerne bliver opdateret dagligt via Bisnodes database. Kreditvurderingen af virksomheden er s&aring;ledes altid aktuel." id="img_273_87_px" src="http://merit.soliditet.dk/merit/imageGenerator/display?lang=DK&country=DK&cId=bS3wlEjMokUHfgTVZQXBGw%3D%3D&cUid=0NvXLDHy8MY%3D&imgType=img_273_87_px" /></a>

Share this post


Link to post
Share on other sites

Ok! 

Jeg skal have sat det dynamiske billede i en CMS-side i Prestashop. Og jeg troede det skulle sættes ind som en iframe. 

Jeg har forsøgt med <iframe kommandoen. 

 

Ved I hvordan jeg får det integreret via den kode ovenfor? 

 

Det er et billede som linker til kreditvurderingsside. Så den ændrer sig hele tiden. 

Hvis jeg sætter det ind under video og integrer, kommer billedet fint frem under beskrivelsen. Men når jeg klikker gem, så kommer den fejlmeddelelse, som jeg beskrev øverst. 

Se vedhæftede billede

Skærmbillede 2017-11-16 kl. 12.53.21.png

Edited by Dennis Kristensen

Share this post


Link to post
Share on other sites

Det du prøver at indsætte er et billede, der linker til en hjemmeside. Så det kan du ikke blot indlejre på en side som iframe. Du må have fat i dem og spørge hvilken kode du skal bruge til at indlejre.

Kildekoden skal ligne noget ala dette:

<iframe width="560" height="315" src="https://www.youtube.com/embed/9DO9EDvlSc8" frameborder="0" allowfullscreen></iframe> (her et tilfældigt eksempel fra youtube)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×