Jump to content

[Résolu] Le transporteur Mondial Relay ne s'affiche pas


Go to solution Solved by Juke29,

Recommended Posts

Bonjour,

Je suis dans l'impasse et j'aurais bien besoin de l'avis de la communauté !

J'utilise Prestashop 1.6.1.16, avec le thème Classic un peu personnalisé. J'ai configuré le module Mondial Relay (v2.1.8) en suivant à la lettre la doc, inséré les paramètres de mon compte Mondial Relay (MR), créé les transporteurs dans le module puis terminé la config des tranches, logo etc de chacun des transporteurs MR (France, Europe). Lorsque je vais dans le panier, Mondial Relay n'est pas proposé. Il y a juste retrait en magasin et Colissimo. Mon compte client est bien en France, donc le transporteur Mondial Relay France que j'ai configuré devrait s'afficher...

J'ai tenté avec la présentation en mode widget et normal, mais aucun ne s'affiche. Je vois bien dans le code de la page panier (one page "commande-rapide") que la CSS du module est bien chargée, et je vois également les commentaires suivants avec du vide en dessous de chacun :

<link href="/modules/mondialrelay/views/css/style.css" rel="stylesheet" type="text/css" media="all" />


	<!--On charge Google Map API-->  
	


<!--On charge le widget mondial relay depuis leurs serveurs-->

On trouve ces commentaires dans les fichiers du module mondialrelay/views/templates/front/header.tpl et header_widget.tpl, actuellement j'ai laissé le mode "normal" (version liste sans widget carte)  donc c'est actuellement header.tpl qui est chargé en front.

J'avais une erreur me demandant d'ajouter une API Key pour google maps dans la console de Chrome, donc j'ai suivi les étapes proposées ici et je n'ai plus l'erreur mais rien de plus. Toujours pas de Mondial Relay. Et pas d'autres erreurs dans ma console (à part le warning "Google Maps API warning: SensorNotRequired" mais ce n'est pas bloquant).

J'ai activé dans "Paramètres avancés" puis "Performances" : "Déplacer le code Javascript à la fin" mais rien n'y fait. Je vois bien le code JS de Mondial Relay en bas du code de la page pourtant.

J'ai vérifié les positions du module, il est bien présent (de toute façon on voit bien que ça le charge partiellement vu les commentaires présents !)

Si vous avez la moindre piste, la moindre idée pour afficher le transporteur Mondial relay dans mon panier, je prend ! Je vous remercie d'avance !

Edited by Juke29 (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More