Jump to content
MT Studio

Logo founrisseurs

Recommended Posts

Bonjour,

J'aimerais afficher les différents fournisseurs disponible sur la page d'accueil.
J'ai ajouter ce code :

{if $suppliers}
    {assign var='option_tpl' value=OvicLayoutControl::getTemplateFile('brandsslider.tpl','brandsslider')}
    {if  $option_tpl!== null}
        {include file=$option_tpl}
    {else}
        <div class="section-brand-slide">
            <div class="brands-slide owl-carousel nav-center-center nav-style7" data-nav="true" data-dots="false" {if $suppliers|count >1}data-loop="true"{else}data-loop="false"{/if} data-margin="60" data-responsive='{ldelim}"0":{ldelim}"items":1{rdelim},"600":{ldelim}"items":3{rdelim},"1000":{ldelim}"items":5{rdelim}{rdelim}'>
                {foreach from=$suppliers item=supplier name=supplier_list}
                    <a href="{$link->getsupplierLink($supplier.id_supplier, $supplier.link_rewrite)|escape:'html'}">
                        <img src="{$img_sup_dir}{$supplier.image}" alt="{$supplier.name}"/></a>
                {/foreach}
            </div>
        </div>
    {/if}
{/if}

J'ai bien mon carrousel qui s'affiche, mais les logos correspondant à chaque fournisseurs ne s'affiche pas. Le lien est bon.
Avez-vous une solution ? J'ai du me planter sur une ligne de code, mais laquelle ?
Merci d'avance !

Share this post


Link to post
Share on other sites

Tu as bien set la variable $img_sup_dir à smarty ?

Tu as une url sinon donne nous quand même l'url de l'image même si elle est pas bonne.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More