Jump to content

PS 1.6.1 Move JavaScript to the end Problems


ewinch
 Share

Recommended Posts

Hello,

 

I am having some issues with The positioning of the JavaScript in the code and i need some assistance.

 

It seems that no matter which way I have it there seems to be JavaScript problems. I would think that turning "Move JavaScript to the end" would make everything work as it is supposed to but it is not.

 

Here are some of my issues on each setting:

 

Move JavaScript to the end - ON

 

  1. Shopping Cart Summary page - The + and - to update product quantity doesn't refresh and therefore doesn't work
  2. Product Area Packs Calculator - I have a Length & Width Calculator Module to help the customer determine how much flooring is needed to purchase. But with JavaScript at the end all the variables are missing.

 

I have tried using {literal} tags but it has had no effect.

 

 

Move JavaScript to the end - OFF

 

  1. BlockLayered Left Nav Filter - Does not refresh and therefore when you click on a filter option the page doesn't change
  2. Product-listing Page - View by Grid/List doesn't work. I think this has to do with the page not refreshing
  3. Home Page Featured Products - Are missing altogether.
  4. The <select> tags alignment is off site wide

 

So because there were less errors with it switched "ON", I turned it back on for the time being.

 

This is my question.

Can I reset PrestaShop somehow so all the JavaScript will work as its supposed to?

or

Is there another way to fix these problems so the page will refresh? Like using the {literal} tags but something that will work.

 

Here is a link to the product page on my site. https://goo.gl/5quQ1f

 

I should probably explaining that I am a web designer/web developer.

I am proficient in HTML, CSS

As far as other programming languages. I can modify existing code to a point but I cannot write fresh code.

That may help in knowing how to respond to this post.  :D:)

 

Eric

post-1422020-0-61384900-1507309656_thumb.png

Edited by ewinch (see edit history)

Share this post


Link to post
Share on other sites

I'm pretty sure most people wont have the same issue as me. I fixed the issue though and figured I'd share just in case someone else reads this looking for answers.

 

I used the product.tpl page from the default theme so I could keep the default 3 column layout in my theme. However these two pages were coded differently so it was requesting different information. I copied most of my theme files into this new product.tpl page and only kept the primary block on the product page. After i did this and uploaded I was able to enable the non working modules.

 

Not the most technical answer but its all i have and it worked. So Problems solved. :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More