Jump to content

[LØST] Hjælp til sprogfiler


Prestafan1234
 Share

Recommended Posts

Hej

Jeg har en masse problemer med at få opdateret min danske sprogfil. Jeg har nu i timevis forsøgt alverdens ting...

Jeg har hentet et nyt tema, og i dette er der ændret i nogle af modulerne således, at disse bruges en bjælke i toppen med ekstra navigation. Modulerne der skulle overskrives da jeg tilføjede det nye tema var: blocksearch og blockvariouslinks. Problemet er, at der nu er nye tomme felter i min sprogfil - og disse repræsenterer mine menupunkter. Men når jeg retter i dem, så slettes alle andre oversættelser der står efter disse felter.

Jeg har så lavet en eksport af sprogfilen, og når jeg kigger i dk.php filen til themet, så er mine tekster oversat. Men hvorfor pokker bliver de ikke vist??? Jeg har også prøvet at lave oversættelsen i den fil man normalt importerer (gzip?) og importeret denne: Samme resultat: Felterne er der, men de er tomme, og retter jeg i dem, slettes alle de andre oversættelser igen nedenunder.

Efter nu at have lavet ca. 20 imports/eksports googlet og søgt i forummet, kunne jeg godt bruge noget hjælp:-)

Ekstra oplysninger
Rettigheder på dk.php filen er sat til 777. Jeg har prøvet alt ovenstående ved først at skifte tilbage til standard Prestashop theme, importere, kopiere til det nye theme. Ved at importere direkte på det nye theme - og ja, stort set alle mulige ting. Jeg har oplevet samme problemer i min shop med standardtemaet - altså at sprogfiler overskrives. Jeg har også rettet en værdi i php.ini opsætningen til 2048, som nogen skriver om - i min liveshop må jeg rette sprogfiler i en testshop og så eksportere denne fil og importere den i liveshoppen. Ikke optimalt, men det virker....

Share this post


Link to post
Share on other sites

Hej Kjeld

Jeg var så arrig over de gentagne imports/eksports/overskrivninger, at jeg ikke engang gad slå op, hvad det var, jeg havde ændret - undskyld:-( Men ja, det er suhosin jeg har ændret på - og værdien er ændret til de 2048 for suhosin.post.max_vars og suhosin.request.max_vars

Men i tråden du linker til, ser jeg lige, at du anbefaler php_value register_globals off - det er min ikke, så det skal jeg lige have prøvet af. Vender tilbage....

Share this post


Link to post
Share on other sites

Det er ikke register_globals, der driller.

Når du installerer et theme er der mulighed for, at visse modulers .tpl-filer ligger i en ændret version under themes/xxx/modules. Det betyder, at der også her skal være dk.php-filer (da.php i 1.3). Når du oversætter i back office, vil modulernes tekster optræde 2 gange. 1. gang er de originale modultekster, 2. gang er de tekster, der hører til dit theme. Måske du mangler skriverettigheder i katalogerne under themes/xxx/modules?

/Kjeld

Share this post


Link to post
Share on other sites

Hej Kjeld

Har fået det til at virke - min sushusin setting var hoveddomænet og ikke mit subdomæne - grrr. Hvorom alting er, ændrede jeg både sushusin og register globals til off på mit subdomæne, og nu virker det. Oversættelsen fremgik jo også af min php fil - så måske var det blot fordi den ikke kunne gemme den, at den blankede de nye felter og alt efterfølgende af. Det vigtigste er, det virker - eftersom det jo er en del af min navigation, hvor det ikke duer blot at have den på engelsk. :-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More