Jump to content
jocade

Mon fichier d'import csv de fonctionne plus

Recommended Posts

Bonjour,

Depuis quelques jours, je ne peut plus faire d'import.
LA dernière fois que j'en ai fait un (le 9 aout), tout c'est très bien passé, je ne comprend pas ce qui se passe.
Voici le message d'erreur qui m'est donné : 

 

2 erreurs 
  1. STICKY CHAMELEONS (ID: 16915) ne peut pas être enregistré
  2. Property Product->name is empty
×
  • Le lien réécrit pour (ID : 16915) a été réécrit en tant que friendly-url-autogeneration-failed.

Et c'st valable aussi si je mets en ID automatique (ce que je fait d'habitude).

Est-ce que vous auriez une idée ?
Merci !

Share this post


Link to post
Share on other sites

Bonjour,

 

Cela veut dire que dans le fichier d'import il ya un article qui n'a pas de nom. Vérifier la colonne où se trouve les noms d'article

 

Espérant t'avoir aidé

Serge

Share this post


Link to post
Share on other sites

La colonne semble bonne. J'ai essayé avec une seule ligne, en mettant les informations les plus simples possibles, et çà ne passe pas non plus.

J'ai d'ailleurs retenté de reprendre mon fichier d'import du 9 aout (la dernière fois où cela à fonctionner), et il me donne le même message d'erreur.
Y-a-t il eu une mise à jour récemment ?

Share this post


Link to post
Share on other sites

Bonjour,

 

Depuis quelques jours, je ne peut plus faire d'import.

LA dernière fois que j'en ai fait un (le 9 aout), tout c'est très bien passé, je ne comprend pas ce qui se passe.

Voici le message d'erreur qui m'est donné : 

 

2 erreurs 

  1. STICKY CHAMELEONS (ID: 16915) ne peut pas être enregistré
  2. Property Product->name is empty
×
  • Le lien réécrit pour (ID : 16915) a été réécrit en tant que friendly-url-autogeneration-failed.

Et c'st valable aussi si je mets en ID automatique (ce que je fait d'habitude).

 

Est-ce que vous auriez une idée ?

Merci !

Salut, souvent ça arrive avec les séparateur , ou ; donc à vérifier si ton fichier était avec un séparateur de base comme comme ce que je viens de citer précédemment.

 

Et vérifier dans la partie du bas après avoir importer ton fichier si le séparateur est bien celui qui faut. Exemple charge ton fichier du 9 en dessous ou il y a l'intitulé séparateur si c'est un ,  dans la case comme séparateur dans ce cas met un ; à la place ou inversement tu verras bien ce que cela te donne.

Edited by najtema (see edit history)

Share this post


Link to post
Share on other sites

En ce qui concerne le ID de l'article, le N° 16915 n'existe pas. Et j'ai essayé avec un ID auto, çà ne passe pas non plus.

En ce qui concerne les ; et les ,    mon fichier de test n'en contient pas, j'avais mis les informations les plus simples possibles.

Cela fait 5 ans qu'on utilise l'import avec csv, on connait déjà tout ces petits écueils ^^ C'est d'ailleurs pour çà que je viens vous voir, car je ne trouve aucune explication ...

Share this post


Link to post
Share on other sites

En ce qui concerne le ID de l'article, le N° 16915 n'existe pas. Et j'ai essayé avec un ID auto, çà ne passe pas non plus.

 

En ce qui concerne les ; et les ,    mon fichier de test n'en contient pas, j'avais mis les informations les plus simples possibles.

 

Cela fait 5 ans qu'on utilise l'import avec csv, on connait déjà tout ces petits écueils ^^ C'est d'ailleurs pour çà que je viens vous voir, car je ne trouve aucune explication ...

Peut être un début de réponse à tester https://forum.c4.cz/prestashop-1-6-csv-import-property-product-name-is-empty-t6405.html

Edited by najtema (see edit history)

Share this post


Link to post
Share on other sites

Ah oui, merci, c'est exactement le même problème que moi.
IL semble que ce soit un problême de caractère invisible dans la description. Je regarde çà et je vous dit ce qu'il en est, car çà pourrait servir à quelqu'un !

Share this post


Link to post
Share on other sites

Et bien non, toujours rien ...

Voici mon message d'erreur : 

2 erreurs 
  1. JEUTEST (ID: No ID) ne peut pas être enregistré
  2. Property Product->name is empty
×
  • Le lien réécrit pour (ID : null) a été réécrit en tant que friendly-url-autogeneration-failed.
  •  

Et voici le fichier csv que j'utilise, il est tout riquiqui du minimum possible pour pas faire d'erreur ...

 

Edited by jocade (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,
J'ai le même problème et je ne trouve pas la solution. J'ai procédé à de multiples essais en reprenant tout mon fichier d'import products. J'ai exactement les mêmes messages d'erreur. Je ne trouve pas d'où le problème peut venir. J'ai un prestashop 1.6.1.5
Cela fait des années que j'utlise des fichiers CSV et je n'ai jamais vu un tel problème.
Quelqu'un aurait-il trouvé la réponse ? Je ne sais plus où chercher.

Share this post


Link to post
Share on other sites

Avec prestashop 1.6.1.5 il faut rester ou revenir à la version 5.6 de php.
Je suis revenue à 5.6 et les fichiers d'import CSV fonctionnent à nouveau.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More