Jump to content
Alexandre 001

Super problème incomprehensible Boutique HS

Recommended Posts

Bonjour à tous. 

 

Il y a 2 jours, je suis passé de la version 1.6.1.16 à 1.6.1.17.

 

Tout ce passait, bien mais en regardant mon tableau de bord, j'avais des valeurs folles. 

 

Du coup j'ai fais un retour en arrière via le module en 1clic to upgrade. 

La plus rien ne fonctionne. 

Du coup je relance une restoration depuis uns sauvegarde directement sur OVH.

Depuis, impossible de faire quoi que ce soit. 

 

Mon front office est en erreur 500.

Mon back office m'indique que mon mot de passe n'est pas valable. 

Je clique sur "mot de passe perdu" en espérant le changer, et ca me rebalance sur la page de connection classique. 

 

J'ai testé de renvoyé plusieurs sauvegardes et j'ai toujours les memes messages. 

 

Pouvez vous m'indiqué d'ou ca peut venir et comment y remédier?

 

"ps j'ai deja vidé mon cash et j'ai les memes messages sur safari et Firefox"

 

Merci. 

 

 

Share this post


Link to post
Share on other sites

Bonjour,

 

on va le répéter toute modification importante doit faire l'objet d'une sauvegarde personnelle complète et maitrisée avec un premier test sur une copie du site.

 

Dans votre cas, lorsque vous avez une erreur 500 ou page blanche il faut activer les messages d'erreurs de PrestaShop afin de connaitre la provenance du soucis.

Share this post


Link to post
Share on other sites

Merci pour votre réponse. 

 

Le message d'erreur 500 n'est en sois pas un problème. 

Le problème c'est que nous n'arrivons plus à nous connecter à notre interface back office. 

Si je modifie la table pour voire la provenance de l'erreur, je ne pourrais de toute façon pas la voire car notre mot de passe n'est plus valide. Et ca c'est un mystère.

 

Nous avons deja fait des restaurations sans que cela pose de problème et nous avons bien sur une sauvegarde. Mais pour quelle raison cela fonctionnait avant et en encrassant le contenu pour le remplacer par la sauvegarde, ca ne marche pas????

 

Merci 

Share this post


Link to post
Share on other sites

Bonjour,

 

Activez les erreurs comme proposé par Mediacom87, il faut lire le lien qui vous a été donné. Puis faites une copie de la page d'erreur, le message pourra nous donner des informations sur l'origine du problème et du coup vous aider.

Il y a les fichiers et la bdd avez vous une copie des deux ?

 

Bonne journée

Share this post


Link to post
Share on other sites

Bonjour. 

 

Donc j'ai bien une sauvegarde du site et une de la bdd.

 

En me rendant sur mon back office, j'ai ma page de connection et j'ai beau y rentré mes identifiants et mdp je reste bloquer dessus. 

Cela c'était deja produit, j'ai cliqué sur "mot de passe perdu" et tout été revenu dans l'ordre. 

Mais la, il ne se passe rien. 

 

J'ai bien sur essayé de la méthode de Mediacom87 en modifiant mon fichier config.inc.php, mais il s'avère que dans celui ci, je n'ai aucune trace de :

define('_PS_MODE_DEV_', false);

ou 

define('_PS_MODE_DEV_', true);

 

En me rendant sur ma page de connection admin, je suis sur 1.6.1.16.

Mais si (pour une raison mystérieuse, mon site c'est sauvegarder sur 1.6.1.17, il faut que je me connecte sur mon back office pour aller dans le mode debug. 

Et c'es la que ca pose problème. Je ne peux pas me connecter au back office. 

J'ai bien la page classique avec id + mdp, mais il n'en veut pas......

Share this post


Link to post
Share on other sites

Bien joué, je tournais en rond car j'ai lu trop vite. 

 

Bon le message d'erreur s'affiche bien. 

Il me dit que ma table n'existe pas. 

Je suis en cours de restauration de la base de données, mais c'est sur que ca va fonctionner....

 

(restauration de la bdd ok entre temps, donc je donne la solution). 

En faisant la migration vers 1.6.1.17 les tables ont du être modifiées et en ne restaurant que le site sans la bdd, les données n'étaient plus cohérentes. 

 

Bon, maintenant mon gros pb, c'est de voire comment je récupère les infos clients que j'ai eu entre temps.... :'-(

 

 

Merci à Mediacom87 & Ariane Plus pour votre aide et votre patience :-)

Edited by aldpiot (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More