Jump to content

SOLVED: New products no image


helldog2004
 Share

Recommended Posts

Hi all,

 

I just upgraded my Prestashop from 1.6.0.11 to version 1.6.1.16 to make sure some of the crucial bugs I previously had is fixed. This, of course, just comes back with a couple of other bugs I would like to have solved.

 

All images of products I had uploaded on version 1.6.0.11 has no problems at all, but products I want to add since I have the upgraded version does just show up an 'no image available' thumbnail.

But if I click on the product itself, it does show a big picture.

I will attach images to this post to show what I mean.

 

I did try to following before posting this forum topic:

1. Regenerate thumbnails.

2. Disable friendly url's (enabled it after it showed no results).

3. Gave the img folder in FTP a 777 permission (changed it back to the standard 755 after no results).

4. Turned off redirect to canonical URL together with the disabling friendly URL (enabled after no results).

5. Changed the 'home' to 'home_default' in the files product-list.tpl and product-comparion.tpl (I am using the theme SweetLingerie).

6. regenerated the .htaccess file.

7. created tools.php within override/classes with the following code:

<?php
class Tools extends ToolsCore<br>
  {
  public static function apacheModExists($name)
  {
  return true;
  }
  }

Everything to no avail.

What could be the cause here?

 

backend.pngproduct.pnglist.pngsidebar-list.png

Edited by helldog2004 (see edit history)

Share this post


Link to post
Share on other sites

I just figured out that by renaming the img/p folder to something like img/p_old and recreate a new p folder the new products work perfectly.

The old images aren't of course not showing up.

 

Also figured that if I use the older folder I can't ADD images to already existing products. But with the new img/p folder I can..

What the hell is going on.... <_<

Share this post


Link to post
Share on other sites

I have no idea why this is happening, but I made sure the older img/p folder has been changed to p_old and created a newer folder with the img/p name.

Copied all images from the older folder inside the newer folder, and for some reason the bug dissapeard.

 

Anyway, problem solved..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More