Jump to content
OlivFC

Mise à jour 1.7.0.3 => 1.7.2.2 via module 1-click upgrade

Recommended Posts

Bonjour,

 

J'ai une boutique actuellement en version 1.7.0.3 que je souhaiterais mettre à jour vers la dernière version stable, 1.7.2.2.

Quand je lance la mise à jour depuis le module 1-click Upgrade, la dernière version se télécharge bien comme il faut. J'ai toutefois une erreur qui me dit que le nom du backup n'a pas été renseigné. N'ayant pas trouvé où renseigner cette information, j'ai désactivé l'option "Back up my files and database" et relancé la mise à jour (j'ai fait une sauvegarde manuelle de tout ça).

 

Ça m'annonce que 17152 fichiers doivent être modifiés, alors que la comparaison de version ne mentionne que 5157 fichiers à modifier et 895 à supprimer. De plus, la mise à jour reste bloquée à 17152 fichiers indéfiniment, jusqu'à ce que j'ai la fameuse erreur [Ajax / Server Error for action upgradeFiles] textStatus: "error " errorThrown:" " jqXHR: " "

 

En cherchant une solution, j'ai voulu passer par l'installation via le répertoire local, en changeant cette option dans le mode expert du module 1-click Upgrade. Seulement, quand je sauvegarde mon choix, celui-ci n'est pas pris en compte et quand je lance la mise à jour, ça télécharge à nouveau la dernière version depuis Prestashop au lieu de se baser sur le répertoire local (l'option dans le mode expert reste sur "version majeure", même cas de figure quand je passe sur "version mineure").

 

Avez-vous une idée de la nature du problème ?

 

Merci d'avance !

Share this post


Link to post
Share on other sites

Bonjour,

 

Non, le problème persiste et je n'ai aucune idée de son origine, malheureusement.

Share this post


Link to post
Share on other sites

Bonjour

 

J'ai eu aussi cette erreur mais j'ai réessayé 4-5 fois l'upgrade via  ClickandUpgrae et c'est passé finalement.... incompréhensible mais ça a bien mis à jour la version.

J'ai un probleme de thème et d'urls en front mais la miseà jour 1.7.2.2 s'est bien faite dans le backoffice.

 

Je sais, ça n'aide pas trop à ton souci mais peut-être faut-il réssayer plusieurs  fois l'upgrade ?...

 

Bonne chance !

Share this post


Link to post
Share on other sites

Bonjour,

 

Si ça a marché pour toi, tant mieux :) mais en ce qui me concerne je l'ai lancée plusieurs fois sans meilleur résultat. Qui plus est, ça prend un temps fou avant de me dire que ça n'a pas marché.

 

Je me suis un peu plongé dans le code pour comprendre comment ça marchait, et j'ai l'impression que c'est la fonction ajaxProcessUpgradeFiles du fichier AdminSelfUpgrade.php qui bloque. Si j'ai bien compris, cette fonction boucle sur la liste des fichiers à modifier (qui se trouve dans le fichier filesToUpgrade.list), mais sans progresser.

 

Et je suis bloqué là...

Share this post


Link to post
Share on other sites

Hello,

 

Top pour l'investigation :)

 

J'ai finalement fait un rollback et tente depuis hier de refaire la mise à jour , mais j'ai maintenant aussi toujours la même erreur :)

 [Ajax / Server Error for action upgradeFiles] textStatus: "error " errorThrown:" " jqXHR: " "

 

Je suis sur OVH et toi ?

Je leur ai fait un mail d'assistance on va voir si eux ont une solution ...

Share this post


Link to post
Share on other sites

Bonjour,
Pour ma part je souhaite passer de la version 1.7.2.0 vers 1.7.2.2 et impossible de lancer la mise à jour en cliquant sur le bouton "mettre à jour prestashop maintenance", cela me renvoie en haut de page.
Tous les voyants sont au vert, j'ai même testé en mettant me dossier version 1.7.2.2 dans /autoupgrade/download/ rien n'y fait.

Des pistes? Avez-vous déjà eu ce soucis?

Merci

Share this post


Link to post
Share on other sites

Salut

Est ce que la comparaison de fichiers se fait bien ?

Qu'as tu sous  la phrase  :

 

 

COMPARAISON DES VERSIONS

version non modifiée de PrestaShop:

Share this post


Link to post
Share on other sites

Salut Loupiloop,

En fait ça mouline toujours, je n'ai rien qui s'affiche! Je suis pourtant en php max execution time illimité sur un hébergeur mutu 1&1

Edited by optim56 (see edit history)

Share this post


Link to post
Share on other sites

Tu n'as même pas quelque chose de ce genre ?

 

 

COMPARAISON DES VERSIONS

version non modifiée de PrestaShop:
warning.gif 368 file modifications have been detected, including 304 from core and native modules: Afficher / masquer la liste

Differences between versions:
warning.gif 5137 fichiers seront modifiés, 894 fichiers seront supprimés (s'ils existent). Afficher / masquer la liste

 

Ton  module est bien à jour ?

Est-ce que les droits sur tes répertoires sont ok ?

J'ai vu ça dans un post , et ça ma aidé à débloquer MA situation. Peut-être que ça fera quelque chose our toi ?

I concur, if you have the 1-click upgrade and are having the "MD5 file" problem then just go to your files in C-Panel if you use C-Panel and do the following;

 

 Go to  > admin(xxxxxxxxx) > autoupgrade and in that folder change all folders to 0755 and all files to 0644

 

It will then work fine.

 

C'est dans ce post : 

https://www.prestashop.com/forums/topic/575178-ps-1702-one-click-upgrade-error-unable-to-check-md5-files/page-2

 

 

Quelle chance d'être arrivé à être déjà en 1.7.2.0 ..... Moi je galère toujours avec une erreur chez OVH apparement

Share this post


Link to post
Share on other sites

Non c'est pareil, toujours rien même avec les droits modifiés.

Enfin pour moi c'est pas un choix, car c'est le site d'un client ou je n'arrive pas à intégrer correctement les déclinaisons, d'ou la mise à jour qui pourrait corriger cela.

La 1.7 pour le moment je n'en veux pas, je préfère garder les anciennes stables.

Share this post


Link to post
Share on other sites

Non c'est pareil, toujours rien même avec les droits modifiés.

Enfin pour moi c'est pas un choix, car c'est le site d'un client ou je n'arrive pas à intégrer correctement les déclinaisons, d'ou la mise à jour qui pourrait corriger cela.

La 1.7 pour le moment je n'en veux pas, je préfère garder les anciennes stables.

 

Tu n'en veux pas ? Mais juste au-dessus tu disais "Pour ma part je souhaite passer de la version 1.7.2.0 vers 1.7.2.2"; donc tu es déjà en 1.7... non ?  :)

Share this post


Link to post
Share on other sites

Oui le client est en 1.7.2.0 et il faut le passer en 1.7.2.2, mais moi lorsque je propose des boutiques, je les installe en 1.6, plus stable. 

Share this post


Link to post
Share on other sites

Salut,

 

Finalement, pour ma boutique qui était encore plutôt en "construction", j'ai pris le choix de tout recréer de zéro avec un zip de la 1.7.2.2 et une nouvelle BDD.

 

Bon courage pour ton souci, perso je ne suis pas assez calée pour pouvoir t'aider sur le moulinage. As-tu essayer t'appeler 1&1 ?

Moi hier OVH m'a débloqué un truc sur le PHP et le CDN...

 

Après le mieux serait peut -etre d'exporter les donner nécessaire, installer la version en local et réimporter les données.

Le module ClickUpgrade fait tellement de dégats ...

Share this post


Link to post
Share on other sites

Même problème que optim56 de mon côté, en cliquant le bouton qui est censé lancer la mise à jour, ça me renvoie en haut de page et il ne se passe rien...

Share this post


Link to post
Share on other sites

Bonjour,

 

j'ai le même problème pour passer de 1.7.1.0 à 1.7.2 stable - (1.7.2.3). J'ai envoyé un message au développeur mais pas de réponse...

erreur : [Ajax / Server Error for action unzip] textStatus: "error " errorThrown:"Service Unavailable " jqXHR: "

tous les voyants sont au vert... 

La version 1.7 a plein de bugs, et personne ne répond... super ! pas de chance OVH l'installe par défaut...

 

Share this post


Link to post
Share on other sites

Salut,

Sur ton FTP, dans le dossier admin, tu as un dossier qui s'appelle "autoupgrade" et qui doit avoir des dossiers avec des droits d'accès en 0777 et des fichiers en droits d'accès 0666.

Tu mets les dossiers en en 0755 et les fichiers en 0644 et ça devrait fonctionner, ça a marché pour moi.

++

Share this post


Link to post
Share on other sites

Vérifiez bien que le module 1-click-upgrade est à jour.
ça peut résoudre le blocage.

Share this post


Link to post
Share on other sites

Salut OlivFC

De par mon expérience sur Prestashop, depuis la PS1.6 le module click upgrade ne fonctionne pas chez moi tout du moins.

Le CMS enlève petit à petit notamment sur la PS 1.7.5.1 SMARTY et remet du Symfony donc pas mal de tables et champs ont été rajouté, modifié ...

Je te conseille le seul Addon sur le marché qui te permet en partie de faire la migration (et non l'upgrade) en réinstallant un Prestashop dernière version et en migrant tes données de l'ancien sur le nouveau.

Je dois noter leur addon car il ne fait pas Upgrade contrairement à ce qu'il est indiqué et attends toi à des changements dans thon thème - perso j'utilise un child-theme mais quand même - et surtout ils ont un gros problème pour migrer l'ensemble des photos donc tu seras sans doutes obligé de remettre les anciennes de ta sauvegarde.

Il n'y en a pas d'autre à ma connaissance et sinon pour le reste il fait le job notamment pour le seo afin de tout récupérer comme IDs de catégories, produits, clients ...

C'est Prestashop qui change des mises en pages donc il faut adapter ton thème. Mais le thème enfant quel bonheur tu récupères tout nickel ;-)

Leur support est assez réactif mais il faut faire tout ça sur un site test et changer quand tout est ok :)

Bon courage !

@kolorslab

Share this post


Link to post
Share on other sites

j'ai supprimé les fichiers dev et prod  dans le répertoire  var/cache

et cela fonctionne

Share this post


Link to post
Share on other sites

Bonjour,

toujours pas régler?

 

Désactivé tout les caches -> Désactivé les modules non natif puis tester.

Share this post


Link to post
Share on other sites

avez vous  éffacer les fichier dev  et prod

Share this post


Link to post
Share on other sites
16 hours ago, Esh-Network said:

Désactivé les modules non natif puis tester.

Pour info Cette option ne fonctionne plus depuis la 1.7, elle est basée sur une liste de modules sauf que depuis la 1.7, la majorité ont changés de nom et la liste n’a pas été mise à jour.

Share this post


Link to post
Share on other sites

Elle existe toujours mais contrairement à la 1.6, elle est inefficace pour la raison que j’ai évoqué plus haut. Autrement dit, elle ne sert à rien ;)

Les modules natifs ont pour la plupart changés de nom entre la 1.6 et la 1.7

Share this post


Link to post
Share on other sites

Janett je sais bien que le module d'upgrade ne fonctionne pas j'ai pour cela parlé de la seule solution à ma connaissance bien qu'imparfaite.

il me semble qu'on peut désactiver les autres modules (non natifs)

 

bon courage

Share this post


Link to post
Share on other sites

@kolorslab pour le coup ma remarque ne t’étais pas destinée et n’a rien à voir avec le processus de mise à jour ou celui de migration proposé par ce module.

Les 2 méthodes donnent de bons résultats selon les cas. Une mise à jour est plus simple sur de petits magasins, la migration mieux adaptée à des gros magasins ou des magasins anciens avec un historique technique.

Par historique technique, je parle d’un magasin initialement installé sur une ancienne version 1.3 ou 1.4, voir 1.5 qui ont reçus des processus de mise à jour pas toujours au point à l’époque. Donc avec une base de données parfois inconsistante voir incohérente. Les modules pas toujours de qualité ajoutant leur dose d’incoherences avec le temps... ainsi que parfois des modifications sauvages réalisés dans les fichiers de Prestashop sans passer par des overrides ou des hooks.

Bref une mise à jour c’est bien pour une 1.6 qui n’a pas trop vécu, pour les autres une migration bien mieux adaptée pour repartir sur de bonnes bases.

A noter que faire une migration en se reposant sur un module générique n’est pas forcément une bonne idée même si ça simplifie les choses. Par exemple, pour les gens qui ont des modifications spécifiques ou des modules spécialisés, il y aura des données supplémentaires à migrer pour conserver une cohérence (données de fidélisation etc...)

Pour finir, dans tous les cas, prenez conseils auprès de professionnels, testez sur des versions de tests etc...

Share this post


Link to post
Share on other sites

Janett

Désolé si je me suis trompé

C'est un client depuis 2008 donc tu vois on est passé par OsCommerce, Prestashop 1.5.4, 1.6, et depuis la 1.7 comme tout a changé je m'adpate aussi :(

là je tente de remettre mes colonnes "left" sur les pages cms ça a été supprimé et c'est dès que tu es dans "shop/xxx" là on a plus le côté gauche malgré les positions bien renseignées.

Idem je ne vois plus les pages liées au produit dans mon "child-theme" j'espère qu'ils vont se stabiliser un peu car je veux mon thème perso sous flexbox opérationnel et éployable rapidement.

pour ceux qui m'ont parlé de désactivation dans d'anciennes versions cela existe toujours sur la 1.7.5.1

bon courage et si tu as une idée sur mon souci de pages cms et meilleures ventes, nouveautés ...

best

 

Capture d’écran 2019-05-15 à 14.19.13.png

Share this post


Link to post
Share on other sites

Effectivement dans le cas de ton client, une migration est fortement recommandée pour nettoyer un peu le foutoir que doit être la base de données.

Pour le soucis avec tes pages cms, je n’ai pas d’ordinateur sous la main pour vérifier, je suis sur mon téléphone dans un train Thalys actuellement... de mémoire c’est dans les paramètres du thème ou des positions qu’on peut activer ou non des colonnes selon le type de page. Mais ce n’est pas très frais dans ma tête, donc je ne peux pas te guider.

Enfin pour clôturer la discussion sur l’option de désactivation des modules non développés par Prestashop, cette option ne fonctionne pas du tout comme précédemment sur 1.4, 1.5 et 1.6 car elle n’a pas été mise à jour pour corriger la liste des modules natifs qui ont changés de nom avec la 1.7 et par conséquent elle est pour le moment presque totalement inutile.

Share this post


Link to post
Share on other sites

Merci de. Ton retour c'est clair que ma base est passée de 900Mo à126Mo entre la ps 1.6 et la 1.7.

 

Je dois voir en recette si le 'cleaner' de PS fonctionne. 

 

La structure des tables a tellement changé avec symphony c'était ingérable même si le module bug sur certains points. 

 

M9mon souci là sur mon thème enfant soitdes pages produits dans 'positons' n'apparaissent pas soit les hook j'ai du les rajouter à la main ça fonctionne sauf pour les pages cms qui ont 'content' devant :(

Bon voyage 😎

 

Share this post


Link to post
Share on other sites

Hello

J'ai une "bizarrerie" avec la PS1.7.5.1 la page promotions et nouveaux produits ne s'affiche pas correctement aucun résultat pourtant les modules fonctionnent bizarre non ?

 

Même url, mais elles n'apparaissent plus dans la gestion des positions des pages non ?

 

si qq1 a déjà eu ce cas ?

 

Merci !

 

 

Share this post


Link to post
Share on other sites

Merci Esh-Network

j'ai l'impression qu'il y a un souci avec les child-themes en fait mais je vais tenter ça je dois finir l'installation de mon nouveau site de recette pour pas faire ça en prod.

:)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More