Jump to content

Website unable to show images after turning on friendly URL


crixus5678
 Share

Recommended Posts

Hi all,

I know there are guys out there facing the same issue as me but i have tried using some of the solutions but unfortunately, my website do not show the product image after turning on the friendly URL option. And don't turn on friendly url is not an option for me.

I have tried to do the delete .htaccess method by following the instruction here (https://www.template...ccess-file.html) but it doesn't work. I do see the htaccess file but if i delete it i won't be able to access the page to turn on and off the friendly url option. It shows internal server error

If anyone has any solution, please help me, i am using prestashop 1.6.1.15, bluehost server. Theme used is pos tuoring layout 1 version 1.

Edited by crixus5678 (see edit history)

Share this post


Link to post
Share on other sites

Your newsletter box pops up on every single start page reload => very annoying.

 

At the moment we don't know for sure if it is the themes problem.

Your image path looks ok like this:

http://mydailysc.com/28-large_default/pore-clean-h2o.jpg

Can you turn friendly URLs off for a moment?

Edited by Scully (see edit history)

Share this post


Link to post
Share on other sites

Ok, the non friendly URI looks like this:

http://mydailysc.com/img/p/2/8/28-large_default.jpg

which is also good. So we can say directory structure is correct, files exist at the correct locations.

Have you the default theme still installed on your shop?

If yes, can you activate the prestashop default theme?

 

If this theme shows images with friendly URL enabled, it's definitively a  bug in your theme or eventually a module which is overriding some default behavior.

Edited by Scully (see edit history)

Share this post


Link to post
Share on other sites

May i know if this is the correct way to clear prestashop cache

 

1)Advance Parameter -> Performace -> Top right corner click clear cache

 

I can't follow the instruction here (https://www.templatemonster.com/help/prestashop-1-6-x-how-to-clear-smarty-cache.html) which say click force compliation then click cache no. because mine is already no in the first place 

 

Added: The friendly url is still on. But i still can't see the image of products.

Edited by crixus5678 (see edit history)

Share this post


Link to post
Share on other sites

I on the cache and selected Recompile templates if the files have been updated. As for the caching type do I select file system of mysql ? and the last option clear cache, never clear cache file or clear cache everytime something has been modified ?

 

Right now it is file system and clear cache everytime something has been modified

Share this post


Link to post
Share on other sites

Hi all,

 

1. You have to check with your web hosting provider if provide mod_rewrite in your web hosting package.

 

2. If provided, please go to your web hosting control panel & check in your public_html folder (usually it has became a hidden file) so go to setting 1st & show your hidden file also.

 

3. Then, please rename your hidden file ".htaccess" to "htaccess.txt" after that should solve your friendly URL issue & your lost image also restored after that.

 

It has happen to me & my site, it is really time-consuming for a beginner like me to solve this issue like a day or two but I hope it will help you ya.

 

Thanks a lot.

 

Go PrestaShop Go!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More