Jump to content
Marco Fischer

Falscher Preis bei Artikelvarianten in Ansicht Produktdetails

Recommended Posts

Hallo,

folgendes Problem mit Prestashop-Version: 1.6.1.16 und aktiver EU-Rechtssicherheit:

Bei Artikeln ohne Varianten wird der Preis in allen Ansichten korrekt angezeigt. Dies klappt bei Artikeln mit Varianten auch, leider nicht in der Produktansicht. Dort wird ein für mich nicht nachvollziehbarer Preis ausgegeben:

Beispiel:

 

post-1392332-0-62039300-1504031540_thumb.png

post-1392332-0-44993200-1504031553_thumb.png

post-1392332-0-51347600-1504031560_thumb.png

post-1392332-0-56277200-1504031568_thumb.png

post-1392332-0-09548800-1504031580_thumb.png

post-1392332-0-57194700-1504031589_thumb.png

 

Es handelt sich um fiktive Preise mit hinterlegtem ermäßigten Steuersatz für Lebensmittel vom 7%.

Der Artikel ist ohne Verkaufspreis erfasst, bei den Varianten wurde Erhöhung 10€ bzw. 20€ inkl. MwSt. eingetragen

 

Wer kann mir hier auf die Sprünge helfen?

 

Vielen Dank für jede Hilfe, bin langsam am Verzweifeln.

 

Mit freundlichen Grüßen

 

Marco

Edited by Marco Fischer (see edit history)

Share this post


Link to post
Share on other sites

Da müßtest du mal deine Einstellungen posten. Lösche auch mal alle Caches, nicht daß da alte und neue Einstellungen kombiniert werden.

 

Erstelle auch mal einen komplett neuen Artikel, um sicherzugehen, daß nicht irgendwelche Reste alter Einstellungen vorhanden sind.

Share this post


Link to post
Share on other sites

Hallo Christian,

 

vielen dank für die Hinweise, leider beides ohne Erfolg, Aktivierung/Deaktivierung EU-Rechtssicherheit ebenso.

 

Welche Einstellungen genau soll ich posten? Ich hänge mal die Preiseinstellungen des Artikels und der Varianten an.

post-1392332-0-53457200-1504193676_thumb.png

post-1392332-0-13749500-1504193686_thumb.png

post-1392332-0-26957500-1504193696_thumb.png

post-1392332-0-72995100-1504193704_thumb.png

Share this post


Link to post
Share on other sites

Bei den Einstellungen fällt mir nichts auf. Und bei einem neu erstellten Artikel ist das genauso?

 

Tritt das Problem auch auf, wenn du als Artikelpreis nicht 0, sondern den Preis des billigsten Artikels einträgst und bei anderen Varianten die Differenz?

 

Stelle mal unter Erw. Einst. / Leistungs / Debug-Modus die beiden Optionen auf JA.

Share this post


Link to post
Share on other sites

Hallo,

 

vielen Dank für die Rückmeldungen.

 

Preisregeln sind keine definiert, weder Warenkorb, Artikel, etc.

 

Bei Artikelpreis 10€ und Auswirkungen auf den Preis "keine" für V1 und  Auswirkungen auf den Preis "Erhöhung" um 10€ für V2 ergibt sich folgendes in der Artikelsicht:

 

V1 10,00€ inkl. MwSt. (dies ist korrekt)

V2 18,96€ inkl. MwSt. (dies ist falsch)

 

Bei Artikelpreis 20€ und Auswirkungen auf den Preis "Reduzierung" um 10€ für V1 und  Auswirkungen auf den Preis "keine" für V2 ergibt sich folgendes in der Artikelsicht:

 

V1 11,04€ inkl. MwSt. (dies ist falsch)

V2 20,00€ inkl. MwSt. (dies ist korrekt)

 

Es wird immer dann falsch gerechnet, wenn es um Reduzierung bzw. Erhöhung geht.

 

Ich möchte nochmals bemerken, die Preise stimmen NUR in der Detailansicht nicht, ansonsten passt der Preis überall (Kategoriesicht, Warenkorb, Rechnung, etc.).

Share this post


Link to post
Share on other sites

Ich meine, dieses Problem hatten wir vor nicht allzu lange Zeit hier im Forum bereits mal vorliegen. Evtl. die Suchfunktion anwerfen.

Share this post


Link to post
Share on other sites

Ich meine, dieses Problem hatten wir vor nicht allzu lange Zeit hier im Forum bereits mal vorliegen. Evtl. die Suchfunktion anwerfen.

 

Manche Foren zeigen unten verwandte oder ähnliche Themen an ,ist hilfreich.

Edited by SliderFlash (see edit history)

Share this post


Link to post
Share on other sites

Hallo,

 

mittlerweile bin ich in einem englischen Forum fündig geworden, dort ging es um die gleiche Problematik. Es scheint eine Fehlberechnung in einer Javascript-Routine zu geben.

 

Als Lösungsvorschlag wurde geschrieben:

 

nevermind, i've fixed it with : #PSCSX-4326 if someone has the same problem.

 

Mal sehen, obs hilft

 

Vielen Dank.

Edited by Marco Fischer (see edit history)

Share this post


Link to post
Share on other sites

Berichte weiter, ich verfolge dieses Thema gerne. Was mich aber irritiert. Du hattest doch PS 1.6.1.16 eingangs erwähnt.

Der Forge hier ....

 

http://forge.prestashop.com/browse/PSCSX-4326

 

Sollte aber bereits im April 2015 erledigt gewesen sein. Das müsste in Deiner Version also eigentlich korrigiert sein, wenn es diesen Fix wirklich betrifft.

Share this post


Link to post
Share on other sites

Hallo,

 

nach einigem Probieren mit der product.js hat sich ergeben, dass der verwendete Wert combination.price nicht dem Wert in der Tabelle "attribute_impact" entspricht.

Es geht speziell um den Codeblock ab Zeile 682 in der product.js:

 

// Apply combination price impact (only if there is no specific price)
// 0 by default, +x if price is inscreased, -x if price is decreased
basePriceWithoutTax = basePriceWithoutTax + +combination.price;
basePriceWithTax = basePriceWithTax + +combination.price * (taxRate/100 + 1);
 
Hier ist die rote Zeile interessant. Der Wert von basePricewithTax wird in der Produktansicht angezeigt. Setze ich hier manuell einen Wert (z.B. basePriceWithTax = 100), dann wird 100 € inkl. MwSt. angezeigt, d.h., dass auch keine weitere Berechnung stattfindet.
 
Der Wert von combination.price entspricht bei der Variante Grundpreis (10€ brutto)+Erhöhung (10€ brutto) dem Wert 8,96€. Richtig wäre hier der Wert 9,35€, wie dieser auch in der Tabelle "attribute_impact" steht. Würde man 9,35€ in der Formel in der roten Zeile einsetzen, stimmt der Preis (20,00€) exakt.
 
Leider habe ich noch nicht herausgefunden, wie combination.price aus der Datenbank ermittelt wird und ob dieser Wert vor Verwendung in product.js noch verändert wird.
 
 

 

post-1392332-0-42983100-1504338435_thumb.png

Share this post


Link to post
Share on other sites

Hallo,

folgendes Problem mit Prestashop-Version: 1.6.1.16 und aktiver EU-Rechtssicherheit:

Bei Artikeln ohne Varianten wird der Preis in allen Ansichten korrekt angezeigt. Dies klappt bei Artikeln mit Varianten auch, leider nicht in der Produktansicht. Dort wird ein für mich nicht nachvollziehbarer Preis ausgegeben:

Beispiel:

 

attachicon.gif0.PNG

attachicon.gif1.PNG

attachicon.gif2.PNG

attachicon.gif3.PNG

attachicon.gif4.PNG

attachicon.gif5.PNG

 

Es handelt sich um fiktive Preise mit hinterlegtem ermäßigten Steuersatz für Lebensmittel vom 7%.

Der Artikel ist ohne Verkaufspreis erfasst, bei den Varianten wurde Erhöhung 10€ bzw. 20€ inkl. MwSt. eingetragen

 

Wer kann mir hier auf die Sprünge helfen?

 

Vielen Dank für jede Hilfe, bin langsam am Verzweifeln.

 

Mit freundlichen Grüßen

 

Marco

 

Da ist kein Fehler , du hast ein Denkfehler die angaben auf den Bildern stimmen oder du musst die Einstellungen ändern vor allem Auswirkungen auf Preis und Gewicht.

https://www.prestashop.com/forums/topic/159453-falscher-preis-bei-varianten/?p=776123

Share this post


Link to post
Share on other sites

Hallo,

falls ich einen Denkfehler haben sollte, warum stimmen dann die Preise in allen anderen Ansichten, außer eben in der Produktansicht? Ich gehe deshalb davon aus, dass alle Einstellungen passen, wurde auch bereits für die hier im Post gezeigten Einstellungen bestätigt.

Share this post


Link to post
Share on other sites

hi Marco, ich Vermute das es an den Einstellungen liegt ,ich kann mir nicht vorstellen das der Rechner etwas falsches rechnet 2+2= 4

 

vielleicht hilft dir das weiter https://www.templatemonster.com/help/de/prestashop-1-6-x-how-to-set-up-attributes-that-impact-on-products-price.html#prettyPhoto

 

aber ich bin der Meinung das du falsch Eingestellt hast.

Share this post


Link to post
Share on other sites

Hallo Sliderflash,

ich glaube auch nicht, dass falsch gerechnet wird, sondern das bei Javascript falsch ermittelt wird (passt auch zu Posts zur Problematik bei deaktiviertem Javascript). Das Problem tritt im Zusammenhang mit Bruttopreisen auf. Bei der Definition der Varianten steht auch immer der korrekte endgültige Preis da (siehe obere Screenshots). Müssten bei falschen Einstellungen in allen anderen Ansichten (Katalogsicht, Warenkorb, Rechnung) nicht auch falsche Preise stehen, dies ist aber nicht der Fall, außer in der Produktansicht stimmen alle Preise. 

Share this post


Link to post
Share on other sites

Deswegen solltest du suchen,. wo die Werte verbogen werden....

 

Wenn du jetzt da die (so absolut korrekte) Formel änderst, um einen irgendwo anders eingeschleppten Rechen- oder eventuell Konfigurationsfehler zu kompensieren, fliegt dir das irgendwann um die Ohren.

Share this post


Link to post
Share on other sites

Hallo Claudiocool,

ich möchte ja dort nichts ändern, habe ja nur zum Tracen dort mal einen absoluten Wert eingegeben, nur um zu sehen, ob danach noch irgendwas mit dem Wert gemacht wird.

Die Formel ist ja inhaltlich und logisch richtig, aber der Basiswert für die Bruttoberechnung ist IMHO nicht richtig.

Share this post


Link to post
Share on other sites

Ja, aber ich vermute dennoch, dass irgendwo ein Setting beim Artikel nicht richtig ist, und der Fehler daraus entstanden ist. Da muss sich nur irgendein Steuersatz reinmogeln, weil man das in den Grundeinstellungen übersehen hat, schon ist der Bock fett.

 

Beispielsweise wird hier gerne bei den Ländereinstellungen irgendwas unnötiges gesetzt, obwohl der Shop i.d.R. einen einzigen Standort hat, da muss man dann keine weiteren Sätze wie die des eigenen Landes nehmen, das geht dann weiter bei den Steuerzonen usw.... Da reicht ein klitzekleiner falscher Parameter und der Shop bringt die unglaublichsten Ergebnisse zutage.

 

Dummerweise ist die Programmiererlogik hier andere Wege gegangen als die Anwenderlogik, hier muss man gleichzeitig mehrere Bereiche im Auge behalten, die funktional zusammenhängen aber in den Settings regelrecht auseinandergerissen wurden. Mag sein, dass das in anderen ländern oder mit einer internationalen Multishopausrichtung besser ist, aber selbst da habe ich Zweifel.

 

Als Umsteiger von OSCommerce habe ich da auch so meine Probleme gehabt, vor allem, weil der alte Shop von mir komplett überarbeitet war, da sind in 10 Jahren viele Features eingeflossen, die allesamt auf dem eigenen Mist entstanden sind, zum Schluss war das Teil genial, aber leider immer unsicherer, weil das Grundgerüst eben mittlerweile sehr veraltet war.

Share this post


Link to post
Share on other sites

Oh je, mittlerweile geht's ja ziemlich durcheinander hier ...

 

Ich hatte einen Vorschlag gemacht und weiß nicht, ob du das probiert hast:

 

"Stelle mal unter Erw. Einst. / Leistungs / Debug-Modus die beiden Optionen auf JA."

 

Nicht vergessen, danach Caches (vor allem Browser-Cache) zu löschen!

 

Es geht darum, auszuschließen, daß ein Fremdmodul oder ein Override schuld ist.

 

Du verwendest das Standard-Template?

 

Ist der Shop neu oder besteht er schon länger? Bestand das Problem von Anfang an?

 

Wurde mal an der product.tpl etwas geändert? Evtl. kannst du mal die product.tpl durch ein Original aus einem Installations-ZIP ersetzen.

Share this post


Link to post
Share on other sites

Wir haben das EU-Rechtemodul nicht im Einsatz und 1.6.1.15 statt .1.6.1.16.

Da werden alle Preisänderungen von Varianten korrekt angezeigt, egal ob Erhöhung oder Reduktion.

Da hat bsp. ein Produkt einen VP Grundpreis von CHF 1000 inkl MwSt, Variante 1 eine Erhöhung von 25 und Variante 2 eine Reduktion von 15 jeweils inkl. MwSt.

Wir alles und überall korrekt angezeigt und ebenso gerechnet.

Share this post


Link to post
Share on other sites

Hallo,

 

vielen Dank für alle Reaktionen, es freut mich sehr, dass ihr mir behilflich sein wollt.

 

Generell noch folgende Informationen:

Der Shop befindet sich aktuell im Aufbau, d.h., ich habe bisher kein anderes Verhalten gehabt bzw. festgestellt. Im Einsatz ist nur die Grundinstallation 1.6.1.16 mit Standard-Template ohne jegliche Drittkomponenten. Wenn überhaupt, sind Standardmodule zusätzlich installiert und aktiviert, z.B. EU-Rechtssicherheit.

 

@rictools:

Antwort bin ich schuldig geblieben, die beiden Optionen hatte ich gesetzt. Es wurden keinerlei Änderungen an irgendwelchen Dateien vorgenommen, so auch nicht an der product.tpl.

 

@Claudiocool:

Hier bin ich weiterhin der Meinung, dass sich eine oder mehrere falsche Einstellungen grundsätzlich so auswirken müssten, dass immer ein falscher Preis angezeigt wird, bei mir handelt es sich aber ausnahmslos nur in der Produktansicht um einen falschen Preis, füge ich von dort den Artikel dem Warenkorb hinzu, wird der korrekte Preis angezeigt. Hier nochmals entsprechende Screenshots:

Variante 1: Grundpreis und keine Erhöhung, korrekter Preis

post-1392332-0-94099500-1504429559_thumb.png
Variante 2: Grundpreis und Erhöhung 10€ brutto, falscher Preis, hier müsste IMHO 20,00€ inkl. MwSt. stehen
post-1392332-0-75044600-1504429589_thumb.png
Variante 2 in Warenkorb übernommen, Preis 20,00€ korrekt
post-1392332-0-15721400-1504429603_thumb.png
 
@scully,
Danke für die Informationen. Wie beschrieben, zwei Unterschiede zu meiner Installation 1.6.1.16 und aktive EU-Rechtssicherheit.
 
@Alle:
Wer hat 1.6.1.16 mit Varianten, aktivierter EU-Rechtssicherheit und Brutto-Preisen im Einsatz?
Wer könnte sich meinen Shop bzgl. Einstellungen mal ansehen, ich würde entsprechenden Zugang einrichten?
Edited by Marco Fischer (see edit history)

Share this post


Link to post
Share on other sites

Darauf wird es ohnehin hinauslaufen, dass man sich das mal im Backoffice ansehen muss, um gleich die Auswirkungen testen zu können. Lieber danach die Lösung dann hier schildern als noch 100 Beiträge zu setzen, bei denen man sich ohnehin nur im Kreis dreht :)

 

Wenn man lange genug mit Presta gearbeitet hat, lernet man, dass da auch augenscheinlich unabhängig voneinander gemachte Settings an irgendwelchen dritten Stellen dann doch "wirken"...

Share this post


Link to post
Share on other sites

180g - 10.00€ + Versand 6,90 + 0,65 MwSt  (inklusive) = 16,90 EUR

 

Variante 2

 

380g - 20.00€ + Versand 6,90 + 1,31 MwSt (inklusive) = 26,90 EUR

Share this post


Link to post
Share on other sites

Hallo,

 

@Claudiocool:

Gerne, darf ich Dir einen Zugang einrichten?

 

@Sliderflash:

Alles korrekt, so wird es auch angezeigt, aber warum steht dann in der Produktansicht für Variante2 18,96€ inklusive MwSt?

Share this post


Link to post
Share on other sites

ich habe nur gesehen das in Variante 2 ,im Bild, die Versandkosten Nicht drin stehen

 

20€ minus 1,31 MwSt = 18,69

 

 

Alles korrekt, so wird es auch angezeigt, aber warum steht dann in der Produktansicht für Variante2 18,96€ inklusive MwSt?

 

ich vermute das ist der Grundpreis 18,96 ohne MwSt , ich denke du hast irgendwo bei MwSt. was Falsch eingestelt so das er schon bei Grundpreis inklusive MwSt anzeigt

Edited by SliderFlash (see edit history)

Share this post


Link to post
Share on other sites

Hallo Sliderflash,

bei 18,69€ könnte dies irgendwie nahe liegen, aber er zeigt ja 18,96€ (???) an, ein Wert, der sich bei keinerlei Berechnung für mich ergibt. 

Share this post


Link to post
Share on other sites

ja habe ich auch bemerkt ,deshalb die idee mit MwSt. mehr weis ich auch nicht musst suchen wo der Fehler liegt.....!

 

oben im Bild steht ja schon bei Grundpreis 18,96 inklusive MwSt. berechnest du zweimal MwSt ?

Edited by SliderFlash (see edit history)

Share this post


Link to post
Share on other sites

Es wurden keinerlei Änderungen an irgendwelchen Dateien vorgenommen, so auch nicht an der product.tpl.

 

Es wurden keinerlei Änderungen an irgendwelchen Dateien vorgenommen, so auch nicht an der product.tpl.

 

Trotzdem würde ich mal testweise die product.tpl durch ein Original aus dem Installations-ZIP (vielleicht auch mal der Vorversion) ersetzen.

 

Du könntest auch eine zweite Shopinstallation machen (evtl. auch der Vorversion), um zu testen, ob das Problem da auch auftritt.

 

Bevor ich jetzt lange suche, hattest du deine PHP-Version erwähnt?

Share this post


Link to post
Share on other sites

Hallo rictools,

 

Serverdaten Linux #1 SMP Fri Mar 3 00:04:05 UTC 2017 x86_64

Version der Server-Software Apache

PHP-Version 5.6.31

Speichergrenze 1024M

max_execution_time 300

 

Die product.tpl werde ich morgen mal austauschen. 

Share this post


Link to post
Share on other sites

Sodele....

 

die Lösung war einfach:

Im Shop sind 2 Währungen am Start, einmal der US-Dollar und dann noch der EURO. Allerdings waren die Wechselkurse falsch gesetzt, so dass der Dollar auf 1 Stand und der EURO bei 0,896. Richtig ist in dem Fall, die Standardwährung im Shop auf 1 zu setzen und alle anderen Währungen auf den entsprechenden Wechselkursfaktor.

 

Interessant war hier dann aber, dass die Preise der normalen Artikel mit dem einegebenen EURO-Betrag angezeigt und gerechnet werden, bei den Varianten holte er sich dann den über den Wechselkurs verrechneten Betrag, in dem Fall also dann 8,96 EUR anstatt 10, fatalerweise zeigt er das aber in den Varianten selbst so nicht an, sondern den ganz normalen Preis, so dass man da erstmal ganz schön suchen darf.

 

@Marco:

Wenn der Shop fertig ist, lösche doch alle nicht benötigten Sachen, wie z.B. Steuersätze für -zig Länder, wenn du vermutlich ohnehin nicht vorhast, dort Dependencen zu eröffnen, Mit der Währung ist es im Prinzip dasselbe, ich denke nicht, dass du Lebensmittel viel weiter wie innerhalb der EU versenden kannst, da werden vermutlich viele Bestimmungen greifen, die das nicht ohne weiteres möglich machen. Ansonsten sieht soweit alles gut aus, jetzt kannst du den Shop mal weitermachen.

  • Like 1

Share this post


Link to post
Share on other sites

Hallo,

mittlerweile konnte dank Claudiocool die Ursache gefunden werden, vielen Dank für die Hilfe.

 

Mit freundlichen Grüßen

 

Marco

Share this post


Link to post
Share on other sites

Wir sind natürlich daran interessiert, etwas über die Ursache bzw. Lösung zu erfahren.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More