Jump to content
stefanmitf

[gelöst] Modul Rechtssicherheit nicht vorhanden

Recommended Posts

Hallo an alle,

 

 

ich habe ein etwas seltsames Problem und hoffe wirklich auf Hilfe. Ich bin gerade dabei meinen ersten Prestashop zum laufen zu bringen und bin da bei der Anpassung an das deutsche Recht auf eine seltsame Hürde gestoßen.
Laut vieler Quellen soll ja das Modul Europäische Rechtssicherheit seit Version 1.6.1 enthalten sein und muss nur noch aktiviert und angepasst werden. Ich benutze 1.6.1.15 und ich finde dieses Modul bei mir nicht.
Nicht nur dass es in der Modulliste nicht dabei ist, ich habe mir die Version auf Github geladen und versucht zu installieren - nichts - es kam nur die grüne Bestätigung "Modul download" (warum auch immer).

Auch habe ich das Modul entpackt und in den /modules Ordner geladen - auch nichts...

Woran kann das liegen oder begehe ich hier einen fundamentalen Anfängerfehler???

 

Schonmal Danke für dringend benötigte Hilfe!!!!

Share this post


Link to post
Share on other sites

Also vorinstalliert hatte ich das Modul auch nie aber man sollte es in der ersten Übersicht der Module finden. Quasi bei den Empfehlungen.

Sonst dort mal nach "rechtssicherheit" oder "legalcompliance" suchen.

 

Mit der Version von Github kann ich jetzt nur schätzen das es evtl die falsche Version ist? Aber dann hätte beim installieren eigentlich eine Fehlermeldung kommen müssen.

Ging denn die Installation des Shops reibungslos?

Share this post


Link to post
Share on other sites

Leider ist das Modul nicht zu finden. Die Installation des Shops hat ohne Probleme funktioniert. Finde aber das Modul außer bei Github auch nirgends zum download...  :(

Share this post


Link to post
Share on other sites

Hallo Stefan,

 

das Modul ist nicht im Installationspaket enthalten, sondern wird während der Installation zugeladen. Wenn das nicht klappt, z.B. weil du offline arbeitest, dann ist das Modul nicht vorhanden.

Vermutlich hast du das Modul vom git nicht so ganz richtig richtig gepackt, so ohne master und so <_< , versuch es mal mit diesem da:

 

advancedeucompliance.zip

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Hallo :)

 

ich habe das gleiche Problem, dass bei mir nach dem Update auf 1.6.1.16 das Advanced EU Compliance Modul nicht zugeladen wurde und ich es nicht finden konnte. Jetzt habe ich die zur Verfügung gestellte Datei auch heruntergeladen. Aber man ne blöde Frage, gibt es eine Anleitung wie ich das Modul und in welchen Ordner einpflege ? 

Sorry ich habe das noch nie gemacht. 

 

Lieben Gruß, 

Eli

Share this post


Link to post
Share on other sites

Hallo Eli,

 

bei einem Update verschwindet eigentlich kein Modul?

 

anyway...

 

Im BO-->Module-->Module  oben rechts auf "+ Neues Modul hinzufügen" klicken, dann das zuvor heruntergeladene Modul auswählen, dann auf Modul laden klicken .. der Rest ergibt sich.

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Hallo Whiley, 

 

vielen Dank. 

Ne verschwunden war es nicht, ich hatte es bloß nie :/ es war so, dass nach irgendeinem Fehler das Prestashop Support Team das Temple für mich neu installiert hat und ich die Version 1.6.1.2 hatte, daraufhin wurde ich im Forum wegen einer Frage zum Versand darauf hingewiesen, dass ich ein Update machen muss und dann das Rechtssicherheitsmodul installieren soll, das Advanced Compliance wurde aber nicht zugeladen und ich konnte es nirgends finden. Auf Nachfrage beim Support Team haben die mir gesagt ich soll das European Union Cookie Law Modul installieren. Aber das ist ja nicht zu vergleichen mit dem Advanced Compliance. 

 

Viele Grüße, 

Eli

Share this post


Link to post
Share on other sites

Das sind dann in der Tat ein paar unterschiedliche Stiefel!

 

Während dich Advanced Compliance darin unterstützt wichtige rechtliche Anforderungen zu erfüllen, gibt es imo in Deuitschland keinen rechtlichen Zwang das European Union Cookie Law-Modul zu verwenden (das wird sich 2018 vermutlich ändern).

 

Aber ich denke mit der obigen Anleitung solltest du weiterkommen.

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Hallo Whiley, 

 

ich habe es nun installiert. Aber die Meldung bekommen:Ihr Template scheint mit diesem Modul nicht kompatibel zu sein; einige erforderliche Vorlagen fehlen. Möglicherweise werden sich einige Optionen nicht auswirken.

 

Bild im Anhang. 

Was kann ich da machen ? 

 

Also selbst das was scheinbar funktionieren sollte wie z.B. das Anzeigen der Preise bei Artikeln mit Varianten mit dem "ab" vor dem Preis oder der Einbindung der Widerrufsbelehrung mit den AGB wird nicht angezeigt. 

 

Ich habe bei Google eingegeben "europäische rechtssicherheit prestashop nicht kompatibel" und habe bei GitHub den Link hier gefunden, konnte aber nichts nachlesen wozu genau der ist :

 

https://github.com/PrestaShop/advancedeucompliance/blob/master/translations/de.php

 

Kann mir das eventuell helfen ? 

 

 

Vielen Dank im Voraus. 

Gruß, Eli

post-1411034-0-26269900-1504186269_thumb.png

post-1411034-0-12009700-1504188355_thumb.png

Edited by sauna4 (see edit history)

Share this post


Link to post
Share on other sites

Die Dateien scheinen beim Original-Template zu liegen, in einem ersten Schritt würde ich mal testen, ob es funktioniert, wenn man diese Dateien verwendet. Wie es dann optisch aussieht, ist eine andere Geschichte.

Share this post


Link to post
Share on other sites

Ja was für ein Template hast du denn? Wenn es nicht das default-bootstrap ist, kann es durchaus sein (vor allem bei Templates aus einem fernen Land), daß dieses nicht mit dem Europ. Rechtssicherheits-Modul zusammenarbeitet, das erfordert dann recht umfangreiche Anpassungsarbeiten durch den Template-Autor oder einen Profi.

Share this post


Link to post
Share on other sites

Das Theme nennt sich 22271 Wholesale und im System heißt es theme1217. Ja das Support Team hat mir heute geschrieben,dass die sich das anschauen. Ansonsten muss ich es an einen Profi geben. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More