Jump to content

Recommended Posts

Bonjour,

 

J'installe la dernière version de PS chez 1&1 pour la première fois et j'ai ces messages lors de la vérification de compatibilité au lancement du script d'installation:

 

Install and/or enable a PHP accelerator (highly recommended).
 
Set short_open_tag to off in php.ini

 

Comment résoudre ces deux problèmes ? Est-ce que je peux ignorer ces recommandations .

 

Merci pour votre aide

 

JP

Share this post


Link to post
Share on other sites

Bonjour,

 

Commencez par vérifier la version de PHP utilisée sur votre hébergement.

 

D'une manière générale si vous n'avez pas ou peu de notions techniques, contactez 1&1 pour qu'ils vous aident à résoudre le problème.

Share this post


Link to post
Share on other sites

J'ai fait le changement et ça ne change rien... Je pense qu'il faut toucher au php.ini mais il est introuvable sur cette version de Prestashop...

 

Merci

Share this post


Link to post
Share on other sites

Bonjour 

Ces messages ne gênent en rien l'install . Toutefois cette version 1.7 n'est pas stable 

Passez en 1.6.1.16 et vous serez tranquille.  Pour cela il faut passer en ftp et effacer les fichiers dans votre repertoire d'install  et ensuite y deposer les fichiers de la 1.6.1.16

Share this post


Link to post
Share on other sites

docmusicstation a raison, fondamentalement ces messages ne sont pas bloquants donc vous pouvez poursuivre l'installation.

 

Je le rejoins aussi concernant PS 1.7. Même si la situation s'améliore petit à petit, cette version est encore assez instable et pas encore véritablement finalisée. 

Share this post


Link to post
Share on other sites

Merci à vous deux pour vos avis éclairés.

Je suis en train de ré-installer le site avec la dernière version de Prestashop 1.6... évidament il faut tout refaire (BDD etc...) mais comme ce n'était que le début, pas de données à importer !!

 

Cdt

  • Like 1

Share this post


Link to post
Share on other sites

Re

Il vaut mieux laisser debugger cette version 1.7 pour le moment    et installer votre site avec la 1.6.1.16 qui sera pleinement fonctionnel des le debut 

Share this post


Link to post
Share on other sites

Re

Il vaut mieux laisser debugger cette version 1.7 pour le moment    et installer votre site avec la 1.6.1.16 qui sera pleinement fonctionnel des le debut 

 

La version 1.7.2.x dernièrement sortie peut-elle être considérée comme une avancée en matière de stabilité ?

Share this post


Link to post
Share on other sites

La version 1.7.2.x dernièrement sortie peut-elle être considérée comme une avancée en matière de stabilité ?

 

Oui, il y a du mieux.

Les bugs sont corrigés progressivement, les améliorations apportées,...

Mais ça reste encore en dessous de ce que peut offrir les dernières 1.6.1.x.

Les performances ne sont toujours pas au rdv, surtout dans le BO (la page Modules  <_< )

Share this post


Link to post
Share on other sites

Bonjour

 

Pff moi qui pensais passer le 1.7.0.4  à 1.7.2.2 .

Je  fais la mise à jour ou pas ? :(

 

Merci pour vos conseils

Share this post


Link to post
Share on other sites

Bonjour,

 

Si tu as déjà installé la 1.7.0.4 je pense que tu peux (doit) faire cette mise à jour.

J'ai installé une boutique (pas encore terminée) avec cette toute dernière version...

 

Cdt

Share this post


Link to post
Share on other sites

Merci beaucoup Chti56 pour ta réponse.

Je m'en occupe alors :) surtout que moi aussi la boutique n'est pas encore visible.

Share this post


Link to post
Share on other sites

Par contre, si tu as déjà entré des articles, fais une sauvegarde de la BDD et de tes fichiers... Une précaution n'est jamais de trop.

Le temps passé pour une sauvegarde est toujours plus court que celui à devoir tout refaire.

 

Cdt

Edited by chti56 (see edit history)

Share this post


Link to post
Share on other sites

Ouaih bon... je viens de faire la mise à jour et après plusieurs tentatives... tou est ok SAUF, que je n'accède plus à la page apparences > themes du backoffice

(ni à la page traduction)

 

J'ai cette erreur :

 

Whoops, looks like something went wrong. 1/1UndefinedMethodException in AdminThemesController.php line 775:Attempted to call an undefined method named "authorizationLevel" of class "AdminThemesController".
  1. in AdminThemesController.php line 775
  2. at AdminThemesControllerCore->isEditGranted() in AdminThemesController.php line 142
  3. at AdminThemesControllerCore->initPageHeaderToolbar() in AdminController.php line 2074
  4. at AdminControllerCore->initToolbarFlags() in AdminController.php line 2813
  5. at AdminControllerCore->init() in AdminThemesController.php line 67
  6. at AdminThemesControllerCore->init() in Controller.php line 182
  7. at ControllerCore->run() in Dispatcher.php line 379
  8. at DispatcherCore->dispatch() in index.php line 95
  9.  

et mon front affiche bien les textes et produits mais je n'ai plus aucunes mise en page correcte.

 

Je cherche en vain comment résoudre le souci  :(

 

Aurais-tu une idée ?

Share this post


Link to post
Share on other sites

La mise à jour s'est bien passée ?

Apparemment ce problème (ou similaire) ca déjà été rencontré. Voir ici: https://www.prestashop.com/forums/topic/628326-multiple-admin-pages-out/

 

Bonjour,

 

j'ai eu quand même 3 erreurs... :

 

File app/logs/dev.log (size: 19218957) has been skipped during backup.

File app/Resources/geoip/GeoLite2-City.mmdb (size: 50506639) has been skipped during backup.

File themes/new-theme.zip (size: 290113311) has been skipped during backup.

 

J"hésite du coup à tout réinstaller de zéro si je ne trouve pas de solution rapidement.

Share this post


Link to post
Share on other sites

Bonjour,

 

Je ne pense pas que ces fichiers non sauvegardé aient une grande importance.

Tu peux essayer de les sauvegarder quand même directement avec FTP.

Share this post


Link to post
Share on other sites

lol et maintenant j'ai cette erreur sur le BO et les pages de mon site :)

Je pense qu'OVH va m'entendre ....

504 Gateway Time-out

nginx

 

 


Et avant....j'ai fait un rollback  :)  qui s'est bien passé, et maintenant en essayant de recommencer la mise à jour , j'ai ces erreurs :

 

Analyzing the situation...Shop deactivated. Now downloading... (this can take a while)

Download complete. Now extracting...
[Ajax / Server Error for action unzip] textStatus: "error " errorThrown:" " jqXHR: "
 
 
Je pense que les bonnes énergies ne sont pas avec moi ce matin !!  :)

Share this post


Link to post
Share on other sites

Je viens aussi d'avoir l'erreur 504 lors de la mise à jour d'un thème fraîchement installé sur une boutique hébergée chez.... OVH ...

Share this post


Link to post
Share on other sites

Salut

 

Après 1h30 au tel avec ovh, j'ai réglé ces 2 soucis :

 

504 Gateway Time-out

nginx

 

Analyzing the situation...Shop deactivated. Now downloading... (this can take a while)

Download complete. Now extracting...
[Ajax / Server Error for action unzip] textStatus: "error " errorThrown:" " jqXHR: "
 
Sur l'hébergement on a désactivé les CDN et passé le PHPFM en PHPcgi
 
Là l'installation de la 1.7.2.2 s'est faite MAiiiiiiS  le site est complètement ok et lap age thmes du backoffice est inaccesible, j'ai ces erreurs :
 
En front, la mise en page ne ressemble à rien

 

 

et dans la page themes du BO :

UndefinedMethodException in AdminThemesController.php line 775:Attempted to call an undefined method named "authorizationLevel" of class "AdminThemesController".
  1. in AdminThemesController.php line 775
  2. at AdminThemesControllerCore->isEditGranted() in AdminThemesController.php line 142
  3. at AdminThemesControllerCore->initPageHeaderToolbar() in AdminController.php line 2074
  4. at AdminControllerCore->initToolbarFlags() in AdminController.php line 2813
  5. at AdminControllerCore->init() in AdminThemesController.php line 67
  6. at AdminThemesControllerCore->init() in Controller.php line 182
  7. at ControllerCore->run() in Dispatcher.php line 379
  8. at DispatcherCore->dispatch() in index.php line 95

 

Je pense réeesayer en ne mettant pas à jour le thème "Classic"  dans les options de mise à jour.

 

Je teste

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More