Jump to content
michalsX

Presta 1.6 nie wysyła maili

Recommended Posts

Presta nie wysyła maili.

Puszczając testowego maila dostaję komunikat o wysłanym mailu.

Klient może stworzyć konto, dokonać zakupu. Obsługa presty wszystko widzi, ale maili nie dostaje ani klient, ani obsługa. Wszystko jest, ale tylko przez dashboard.

Proszę o pomoc.

Share this post


Link to post
Share on other sites

Kiedy ustawienia są automatyczne, przy wysłaniu maila testowego, komunikat jest, że mail został wysłany, ale nic nie ma.

Przy ustawieniach ręcznych jest błąd:

Connection could not be established with host smtp.zoho.eu [Connection refused #111]

Poniżej zrzuty.

Maile są ustawione na zoho.eu we własnej domenie.

2.jpg

3.jpg

Share this post


Link to post
Share on other sites

Ustawienia wyglądają dobrze. Spróbuj jeszcze smtp.zoho.com, ewentualnie skasuj mail domain name.

Share this post


Link to post
Share on other sites

Wersja PHP 5.6.30

Może inaczej, w jakim pliku w prescie są zapisane ustawienia wysyłania maili przez php?

Może sprawdzę tam?

Share this post


Link to post
Share on other sites

A po co te zoho.eu?

Hosting masz w kylos, to skonfiguruj SMTP jak radzi hostingodawca:

https://panel.kylos.pl/knowledgebase/107/Uniwersalne-ustawienia-klienta-poczty-szyfrowane.html

 

Masz dwa języki w sklepie polski i szwedzki to sprawdź jeszcze czy masz wszystkie szablony maili w tych językach (w katalogu /mails/). W EN są wszystkie potrzebne szablony.

I musi działać :)

Share this post


Link to post
Share on other sites

Wszystkie szablony są w en, pl i sv.

Zmieniłem mx na kylos, propaguje się, zobaczymy czy zadziała.

Gdzie w preście jest skrypt php, za pomocą którego rozsyłane są maile? Szablony to jedno, ale skrypt, który jest wykonywany przy rozsyłaniu?

Share this post


Link to post
Share on other sites

Gdzie w preście jest skrypt php, za pomocą którego rozsyłane są maile?

 

Maile wysyła klasa Mail (/classes/Mail.php).

Jeśli za pomocą php to standardową funkcją mail(), jeśli protokołem SMTP to korzysta z klasy swiftmailer (/tools/swift/).

Share this post


Link to post
Share on other sites

Poczta przeszła na kylos

Jest ok, wysyła maile

Ale

Nie dochodzą maile na maile utrzymywane w google we własnej domenie a na maile .gmail dochodzą

Nie dochodzą maile na maile utrzymywane w zoho we własnej domenie

Dochodzą na .gazeta.pl, wp.pl

Dlaczego?

Czy chodzi może o certyfikat SSL domeny, w której jest presta?

Edited by michalsX (see edit history)

Share this post


Link to post
Share on other sites

Problem rozwiązany.

Problem dotyczył lokalnego serwera MX, na którym były hostowane obie domeny.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More