Jump to content
preisfischer

Layout wird nicht gespeichert

Recommended Posts

Hallo allerseits,

 

ich bastel gerade am Classic-Theme herum und habe nun mal das Layout der Index so geändert, dass links meine Kategorien angezeigt werden. Diese Einstellung ist allerdings nicht dauerhaft, denn jedesmal wenn ich den Cache leere (ich bastel gerade sehr viel), wird diese Änderung gelöscht und ich habe wieder die Einstellung "Full width" statt "Two columns, small left".

Ich hatte schon überlegt, den Cache zu deaktivieren, aber mein Shop ist doch etwas größer, daher würde ich gerne den Cache nutzen.

 

Falls das derzeit noch nicht anders zu lösen geht: Ab welcher Shopgröße sollte man den Cache aktivieren?

 

Viele Grüße

Michael

Share this post


Link to post
Share on other sites

Wo hast Du denn genau die Änderungen vorgenommen - Dateiname?

Share this post


Link to post
Share on other sites

Wo hast Du denn genau die Änderungen vorgenommen - Dateiname?

Ich denke doch mal, im BackOffice bei den Template-Einstellungen. Und wenn die nicht gespeichert werden, kommt wohl vor allem ein Browserproblem in Betracht.

Edited by rictools (see edit history)

Share this post


Link to post
Share on other sites

Ich habe noch nicht ganz verstanden, wo diese Einstellungen gemacht werden. Template - Configurator? Diese Werte würden ja wohl in der ps_configuration Tabelle gespeichert (Annahme). Das diese mit dem Cache löschen dann wege wären, wäre dann in der Tat nicht im Sinne des Erfinders.

 

Vielleicht hilft es, die PrestaShop Version zu benennen, die hier am Start steht.

 

Was die Frage der Cache-Nutzung betrifft: Ich würde immer Smarty Cache aktivieren, wenn das nicht so Problemen führt. Man liest aber immer mal wieder, dass es zB das Rechtssicherheitsmodul nicht schafft, ordentlich mit dem Cache zusammen zu werklen.

 

Was "Gross" ist in Bezug auf einen Shop ist relativ. Der Smarty Cache reduziert in jedem Fall die Ausführungszeit und damit die Antwortzeiten. Aber es hängt ja auch vieles davon ab, wie der Server dahinter konfiguriert ist, wieviel Hauptspeicher vorhanden, ob Disks auf SSH laufen, wie die Datenbank konfiguriert bzw. optimiert ist. Unsere Grundregeln: Ladezeiten von 1-2 Sekunden sind top, Ladezeiten von 3-4 Sekunden gut. Wenn wir Shops haben, die länger benötigen, schauen wir es uns an.

 

Dabei ist eine erste grobe Einschätzung auch möglich, indem man sich erstmal nur anschaut, wieviel Zeit die Auslieferung des plain-text Contents (also nur der Textinhalt ohne CSS, Bilder und JS) benötigt. Ist das nicht wesentlich mehr als 1 Sekunde, dann läuft der Server im Prinzip erst mal gut. Bei top optimierten Servern haben wir hier aber auch Werte von 50 bis 100 ms erreichen können. Wohlgemerkt nur für den Text-Content. Für die vollständige Seite haben wir dann zwischen 500 und 1000 ms, jenachdem ob der Browser Cache schon geladen ist oder nicht.

Edited by Scully (see edit history)

Share this post


Link to post
Share on other sites

Hallo allerseits, danke für die Antworten.

 

Ich benutze Prestashop 1.7.2.0, die Einstellung ist im Backoffice zu finden unter "Optimierung -> Design -> Template und Logo -> rechts auf 'Layout wählen'". Hier steht bei mir als Standard unter dem Eintrag "Index" "Full width, no side columns...". Das ändere ich auf "Two columns, small left..."

 

Ich habe gestern das Ganze unter dem aktuellen Opera mit Windows 10 probiert, jetzt gerade mit Chromium unter Ubuntu, selbes Ergebnis. Smarty Cache ist aktiviert.

Share this post


Link to post
Share on other sites

Da muss ich nun leider passen mangels ausreichender Erfahrungen mit PS 1.7.

Share this post


Link to post
Share on other sites

Ich benutze Prestashop 1.7.2.0, die Einstellung ist im Backoffice zu finden unter "Optimierung -> Design -> Template und Logo -> rechts auf 'Layout wählen'". Hier steht bei mir als Standard unter dem Eintrag "Index" "Full width, no side columns...". Das ändere ich auf "Two columns, small left..."

 

Ich habe gestern das Ganze unter dem aktuellen Opera mit Windows 10 probiert, jetzt gerade mit Chromium unter Ubuntu, selbes Ergebnis. Smarty Cache ist aktiviert.

Wenn ich das richtig sehe, sind Opera und  Chromium nahe verwandt, versuche doch auch noch mal andere Browser. Es gibt teilweise Probleme mit einzelnen Browsern, daß sich im BackOffice getätigte Änderungen nicht abspeichern lassen. Teste auch mal, ob andere Einstellungen gespeichert werden.

 

Generell raten hier die meisten vom produktiven Einsatz von Prestashop 1.7.x ab und kaum jemand verwendet es, 1.7.2.0 ist erst vor kurzem erschienen und ein etwas größeres Zwischenupdate, es kann sich auch um einen Bug handeln, der mit dem nächsten "kleinen" Update behoben wird.

 

Funktioniert die Umstellung denn, wenn du den Cache deaktivierst?

Share this post


Link to post
Share on other sites

Ich glaube nicht, dass der Browser hier eine Rolle spielt, solange mit gleichen Bedingungen (=im Zweifelsfall leerer Cache) getestet wird. Es funktioniert ja - bis zum Löschen des PrestaShop Cache. Evtl. mal im englishsprachigen Teil suchen, ob das Problem dort bekannt ist.

Share this post


Link to post
Share on other sites

Ja, wenn die Beschreibung so stimmt. Daß die Änderung erst übernommen wird und dann beim Löschen des Prestashop-Caches wieder weg sein soll, kann ich mir irgendwie nicht vorstellen ...

Share this post


Link to post
Share on other sites

Danke Scully, ich versuchs mal dort. Bis dahin lasse ich den Cache deaktiviert, hilft ja nix.

 

@rictools: Ich kanns auch nicht verstehen, aber es ist genau so wie ich beschrieben hab. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More