Jump to content
Bertrand57

PS1.6 : souci ajout lien followup dans message shipped

Recommended Posts

Bonjour,

 

Habituellement, deux emails sont envoyés au client lors de l'expédition de sa commande. Le mail Shipped associé au statut Livraison en cours, et le mail In transit avec le lien de suivi.

Je pense que c'est inutile d'envoyer deux emails coup sur coup. Autant envoyer seulement un message avec le numéro de suivi.

 

J'ai donc désactivé l'envoi du mail In transit et ajouter le lien followup dans le message Shipped.

Cela ne pose pas de problème quand j'ajoute manuellement le numéro de suivi. Par contre, quand le numéro de suivi est ajouté automatiquement par un module (par exemple module boxtal ou navettepickup), le lien followup ne fonctionne pas. C'est le texte "followup" qui s'affiche au lieu du lien de suivi.

Il faut que je clique sur Modifier puis Mettre à jour le numéro de suivi pour chaque commande, pour que le lien followup fonctionne. Ca fait beaucoup de manipulations inutiles.

 

Quelqu'un a une solution pour que lien followup fonctionne correctement sans devoir valider à nouveau chaque numéro de suivi?

 

Merci

Share this post


Link to post
Share on other sites

Bonjour, 

J'ai exactement le même problème et je net trouve désespérément pas la solution... L'auriez-vous trouvée la solution @Bertrand57 ? 

Merci

Share this post


Link to post
Share on other sites

Il faut récupérer la valeur, la déclarer dans le code puis l’utiliser dans le template du mail car de mémoire ce n’est déclaré que pour le mail In Transit

Share this post


Link to post
Share on other sites

Merci pour votre réponse @Janett

Pour mon cas, c'est plutôt l'inverse. J'ai désactivé le mail shipped, et utilisé le mail in_transit pour envoyer mon lien de tracking. 
Toutefois, c'est mon logiciel d'expédition qui renseigne le numéro de suivi et change l'état de commande. Quand c'est celui-ci qui renseigne l'information, le lien [followup] ne se met pas à jour. Par contre si j'entre le numéro de suivi manuellement, ou vient simplement le mettre à jour, le mail se renvoie, parfaitement contribué... 

Donc je pense que cela ne provient pas de mon template non? 

Share this post


Link to post
Share on other sites

Effectivement c'est plutôt la façon dont la valeur est envoyé/enregistré par ton logiciel d'expédition sur prestashop, il faut que ce soit fait avant l'envoi du mail par prestashop donc avant le changement du status de la commande

Share this post


Link to post
Share on other sites

Bonjour,

J'avais trouvé un module où les numéros de suivi d'affichaient depuis la liste des commandes et je pouvais valider à nouveau les numéros de suivis manuellement sans entrer dans chaque commande manuellement. En les validant à nouveau, cela entraînait l'envoi du message In Transit avec le lien de suivi qui fonctionnait.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More