Jump to content
Designinfo.in

Blank Screen on Website with Error of Smarty

Recommended Posts

I have an error on my website www.designinfo.in and I am unable to login in the admin pannel as well.

How should I resolve this ?

 

Error:

Fatal error: Uncaught --> Smarty: unable to write file /home/desigssq/public_html/cache/smarty/compile/b2/df/df/wrt5979cf5a6635f9_32617931 <-- thrown in /home/desigssq/public_html/tools/smarty/sysplugins/smarty_internal_write_file.php on line 46

 

Prestashop 1.6.1.7

Edited by Designinfo.in (see edit history)

Share this post


Link to post
Share on other sites

Post an error message, for example. And ps version in use. It seems difficult to give at least some helpful information to helpers...

Share this post


Link to post
Share on other sites

Error:


Fatal error: Uncaught --> Smarty: unable to write file /home/desigssq/public_html/cache/smarty/compile/b2/df/df/wrt5979cf5a6635f9_32617931 <-- thrown in /home/desigssq/public_html/tools/smarty/sysplugins/smarty_internal_write_file.php on line 46


 


Prestashop 1.6.1.7


Share this post


Link to post
Share on other sites

Some changes made on server ? The error says that he cannot write a cache file (your space have restricted size ?) It's a shared space ?

Share this post


Link to post
Share on other sites

Well I'm not for to install new things on a running project. If your site is designinfo.in, so well it is not really speedy, but site is working.

 

Don't think you will have more speed with memcache. You are using opcache ? Which php-version ? php-fpm, ngnix proxied ?

Share this post


Link to post
Share on other sites

Hi site is loading on and off, it is not working properly. Yes I want to install memcache and I dont know why the server response time is so high. Other websites on same vps plan work at lightening speed.

Share this post


Link to post
Share on other sites

Also, in back office anything after the dashboard does not load. Is there a way to disable smarty from the cpanel ?

I think that is causing the problem.

Share this post


Link to post
Share on other sites

More errors from the error log:

 

[27-Jul-2017 05:49:56 America/Denver] PHP Warning: Module 'mbstring' already loaded in Unknown on line 0
[27-Jul-2017 05:50:00 America/Denver] PHP Warning: Module 'mbstring' already loaded in Unknown on line 0
[27-Jul-2017 05:50:03 America/Denver] PHP Warning: Module 'mbstring' already loaded in Unknown on line 0
[27-Jul-2017 05:50:05 America/Denver] PHP Warning: Module 'mbstring' already loaded in Unknown on line 0
[27-Jul-2017 17:20:06 Asia/Kolkata] PHP Notice: Undefined index: productprice in /home/desigssq/public_html/cache/smarty/compile/3e/3d/13/3e3d13839dbe2991552ed9fab2bde2717746d3ec.file.product.tpl.php on line 300
[27-Jul-2017 17:20:06 Asia/Kolkata] PHP Notice: Trying to get property of non-object in /home/desigssq/public_html/cache/smarty/compile/3e/3d/13/3e3d13839dbe2991552ed9fab2bde2717746d3ec.file.product.tpl.php on line 300
[27-Jul-2017 05:50:08 America/Denver] PHP Warning: Module 'mbstring' already loaded in Unknown on line 0
[27-Jul-2017 05:50:09 America/Denver] PHP Warning: Module 'mbstring' already loaded in Unknown on line 0
[27-Jul-2017 05:50:17 America/Denver] PHP Warning: Module 'mbstring' already loaded in Unknown on line 0
[27-Jul-2017 05:50:27 America/Denver] PHP Warning: Module 'mbstring' already loaded in Unknown on line 0

Share this post


Link to post
Share on other sites

Which is your server configuration ?

 

php-version ?

are you using external cache (APC, xCache, Vault?)

 

opchache ? ngnix ?

 

If you are using several different cache options, this will not work and overload the server. Smarty Cache is not the problem, this is a filecache system when files are compiled. This should work on every server.

 

You can disable on back-office compiling on tab: advanced parameters -> performance. Disable also all CCC options. On same tab at the end of the page you have also a cache possibility.  Disable there what you have configured, if there is a external cache choosen,

Share this post


Link to post
Share on other sites

More errors from the error log:

[27-Jul-2017 17:20:06 Asia/Kolkata] PHP Notice: Undefined index: productprice in /home/desigssq/public_html/cache/smarty/compile/3e/3d/13/3e3d13839dbe2991552ed9fab2bde2717746d3ec.file.product.tpl.php on line 300

[27-Jul-2017 17:20:06 Asia/Kolkata] PHP Notice: Trying to get property of non-object in /home/desigssq/public_html/cache/smarty/compile/3e/3d/13/3e3d13839dbe2991552ed9fab2bde2717746d3ec.file.product.tpl.php on line 300

These are errors from your template. In this case ask for support of developer.

Share this post


Link to post
Share on other sites

More errors from the error log:

[27-Jul-2017 05:50:27 America/Denver] PHP Warning: Module 'mbstring' already loaded in Unknown on line 0

This error is a server configuration error. Seems you are loading mbstring file in double in any of the conf/ini-files of your server. This is a case for server administrator.

Share this post


Link to post
Share on other sites

Which is your server configuration ?

 

php-version ?

are you using external cache (APC, xCache, Vault?)

 

opchache ? ngnix ?

 

If you are using several different cache options, this will not work and overload the server. Smarty Cache is not the problem, this is a filecache system when files are compiled. This should work on every server.

 

You can disable on back-office compiling on tab: advanced parameters -> performance. Disable also all CCC options. On same tab at the end of the page you have also a cache possibility.  Disable there what you have configured, if there is a external cache choosen,

I am not loading any external cache. I am unable to load anything except the dashboard and hence cannot disable CCC. What should I do ?

Share this post


Link to post
Share on other sites

I think this can be solved if I am able to disable CCC from back Office, but the problem is that I cannot access the 'performance page' Please help on how I can do this from the cpanel ?

Share this post


Link to post
Share on other sites

You cannot disable this from cPanel. This is a case for to clone your site and move to XAMPP or other server and than configure the page newly there, for to upload it again to original server.

 

You already tried to delete cache manually?

 

Try manually deleting all cache files EXCEPT index.php and last_flush from

 

\cache\smarty\compile
\themes\yourtheme\cache

Share this post


Link to post
Share on other sites

You cannot disable this from cPanel. This is a case for to clone your site and move to XAMPP or other server and than configure the page newly there, for to upload it again to original server.

 

You already tried to delete cache manually?

 

Try manually deleting all cache files EXCEPT index.php and last_flush from

 

\cache\smarty\compile

\themes\yourtheme\cache

 

Hi I already deleted the cache from there but it keeps generating again and again since the website is live and currently average 300 to 450 visitors are actively buying goods.

I dont know how to use XAMP, can you help me out with the methods and the codes ?

 

Also if this is a paid service, we would like to acknowledge the same and accept the charges.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More