Jump to content
Handel-SM

Prestashop 1.7 -nach Hauptmenü-Installation - Fehler 500

Recommended Posts

Ich habe seit einem halben Jahr einen Presta-Online-Shop und gestern das Modul Hauptmenü instaliert, darauf erschien im Backoffice eine weiße Seite.

 

Die Kunden können den Shop weiterhin sehen und bestellen: www.wolle.com.de >>> Probebestellung gemacht.

 

Aber das Backoffice funktioniert nicht mehr. Ich kann mich einloggen und dann erscheint

 

in Mozilla: eine weiße Seite

in Chrome: eine weiße Seite mit dem Text:

"Diese Seite funktioniert nicht www.wolle.com.de kann diese Anfrage momentan nicht verarbeiten. HTTP ERROR 500"

Logfile Error-Logs:

2017 08:58:27 wolle.com.de [client 2003:86:6900::] #4 /mnt/web114/d1/89/57717089/htdocs/Wolle-prest-04.02.17/modules/ps_mainmenu/ps_mainmenu.php(1424): ModuleCore->fetch('module:ps_mainm...')
27.07.2017 08:58:27 wolle.com.de [client 2003:86:6900::] #5 /mnt/web114/d1/89/57717089/htdocs in /mnt/web114/d1/89/57717089/htdocs/Wolle-prest-04.02.17/app/bootstrap.php.cache on line 3216

 

Danke für Eure Hilfe - Ich weiß leider nicht mehr weiter.

 

LG Marga

Share this post


Link to post
Share on other sites

Direkt auf Deinem Server einloggen und das Fehlerlogfile anschauen. Der Error 500 ist ein Hinweis auf eine Fehlkonfiguration.

 

Das Logfile oben ist leider höchst unvollständig oder aufgrund fehlender Formatierung für mich nicht lesbar.

Share this post


Link to post
Share on other sites

Was ist das für ein "Hauptmenu"-Modul?

 

Ich würde einfach den Ordner des neuen Moduls löschen oder umbenennen, wahrscheinlich kommst du dann wieder ins BackOffice rein. Dann kannst du die Modulinstallation noch einmal probieren, vielleicht muß dazu erst einmal ein anderes Menumodul deaktiviert werden (im Moment ist da ein ziemliches Durcheinander, wenn man mit der Maus drüberfährt).

 

Generell der Hinweis, daß hier von Prestashop 1.7.x nach wie vor überwiegend abgeraten wird, kaum jemand verwendet es und deshalb wirst du dafür auch schwer Hilfe erhalten.

Share this post


Link to post
Share on other sites

Beim Logfile-Fehler steht auch ps_mainmenu.php drinnen, ins Deutsche übersetzt: Hauptmenü. Ich bin bereits per Filezilla rein, finde aber dieses Modul nicht. Ist das ein Ünterordner in einem anderen Ordner? Falls ja, in welchem? Es war bei vorinstallierte Module in der Kategorie Templates, in der alle Module zum Gestalten sind, z.B, Textfeld.

 

Server habe ich keinen nur Datenbanken in einem Hostingpaket.

Share this post


Link to post
Share on other sites

Wenn Du keinen Server hast, worauf läuft denn Dein Shop?

Share this post


Link to post
Share on other sites

Oh je, oh je, das ist so, als wenn du denkst, die Erde ist eine Scheibe ...

 

Sorry, aber dir fehlt grundsätzlichstes Wissen, wenn du nicht bereit bist, viel zu lernen, bist du mit einem Open-Source-Shop und auch mit anspruchsvolleren Kaufsystemen hoffnungslos überfordert (und von der neuen Prestashop-Version 1.7 solltest du erst recht die Finger lassen!).

 

Ein Hosting bei einem Provider wie Strato bedeutet, daß du zwar keinen eigenen Server hast, aber auf einem Server wie in einem Hochhaus praktisch eine Mietwohnung, d. h. ein bestimmter Bereich eines Servers beherbergt deine Dateien (über diese hast du per FTP-Programm Zugriff). Außerdem hast du eine Datenbank, in der sich ein Teil der Daten deines Shops wie die Produktdaten, Bestelldaten etc. befinden. Inwieweit du Zugriff auf Logfiles, Servereinstellungen etc. hast ist vom Hostingpaket abhängig, lt. von dir verlinkter Strato-Website hast du bereits im kleinsten Hostingpaket Zugriff auf die Logfiles.

 

Es müßte lt. der von dir geposteten Fehlermeldung den Ordner /modules/ps_mainmenu geben.

Share this post


Link to post
Share on other sites

Danke

hier: "Es müßte lt. der von dir geposteten Fehlermeldung den Ordner /modules/ps_mainmenu geben."

habe ich es gefunden.

 

Es funktioniert wieder.

 

LG

Marga

Share this post


Link to post
Share on other sites

Und was war denn nun die Ursache des Fehlers?

Share this post


Link to post
Share on other sites

Die horizontale Menuleiste ist weg, also hat sie wohl wie von mir vorgeschlagen den gefundenen Ordner umbenannt oder gelöscht, das Modul aber noch nicht versucht neu zu installieren.

Share this post


Link to post
Share on other sites

Ja, ich habe den Ordner gelöscht, aber später gesehen, nur noch die sechs Produkte auf der Startseite erreichbar sind statt ca. 50. Daher habe ich die letzte  Datenbanksicherung wieder über phpmyadmin hochgeladen. jetzt ist wieder alles beim "Alten". Ich muss noch schauen, ob auch die neuen Produkte komplett sind. Bei denen habe ich einiges nachgebessert, mal schauen, ob dies noch da ist. Falls nein, mach ich es eben nochmal.

Share this post


Link to post
Share on other sites

Wenn man einen DB Restore macht, sind Datenänderungen nach dem Zeitpunkt des jeweiligen Backups verloren.

 

Erfahrene User machen deswegen im Notfall auch nur selektive Restores. Muss man aber gut aufpassen.

Share this post


Link to post
Share on other sites

Ja, ich habe den Ordner gelöscht, aber später gesehen, nur noch die sechs Produkte auf der Startseite erreichbar sind statt ca. 50. Daher habe ich die letzte  Datenbanksicherung wieder über phpmyadmin hochgeladen. jetzt ist wieder alles beim "Alten". Ich muss noch schauen, ob auch die neuen Produkte komplett sind. Bei denen habe ich einiges nachgebessert, mal schauen, ob dies noch da ist. Falls nein, mach ich es eben nochmal.

Durch das Löschen eines Modulordners veränderst du nicht die Produkte in der Datenbank. Jetzt sind auch nur 6 Produkte auf der Startseite, diese müßten vom Modul "Featured Products" oder ähnlich festgelegt werden. Die horizontale Menuleiste ist wieder da (allerdings irgendetwas stimmt da nicht, beim MouseOver kommt ein optisch nicht passender und falsch platzierter Kasten mit den Unterkategorien).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More