Jump to content
Mecintosch

Fehlermeldung nach Abschluss Bestellvorgang

Recommended Posts

Bekomme diesen Fehler nachdem ich einen Artikel bestelle:

 

UndefinedMethodException in OrderHistory.php line 406:

Attempted to call an undefined method named "updatePhysicalProductQuantity" of class "PrestaShop\PrestaShop\Adapter\StockManager".

 

  1. in OrderHistory.php line 406
  2. at OrderHistoryCore->changeIdOrderState('10', object(Order), true) in PaymentModule.php line 726
  3. at PaymentModuleCore->validateOrder('29', '10', '25', 'Banküberweisung', null, array('{bankwire_owner}' => '', '{bankwire_details}' => 'IBAN: ', '{bankwire_address}' => ''), '1', false, '7ef8129ae2557257f2a92dbd9e217c02', null) in PaymentModule.php line 44
  4. at PaymentModule->validateOrder('29', '10', '25', 'Banküberweisung', null, array('{bankwire_owner}' => '', '{bankwire_details}' => '', '{bankwire_address}' => ''), '1', false, '7ef8129ae2557257f2a92dbd9e217c02') in validation.php line 64
  5. at Ps_WirepaymentValidationModuleFrontController->postProcess() in Controller.php line 194
  6. at ControllerCore->run() in Dispatcher.php line 379
  7. at DispatcherCore->dispatch() in index.php line 28

 

Die Lagerverwaltung habe ich komplett deaktiviert. Der Fehler tritt sowohl bei virtuellen als auch Standard Artikel auf.

 

Vielen Dank für die Hilfe

 

 

Share this post


Link to post
Share on other sites

Mengen werden meines Wissens auch bei deaktivierter Lagerverwaltung geändert. Beim ersten Verkauf eines Produktes zB von 0 auf-1.

 

Welche PS-Version hast Du im Einsatz?

Share this post


Link to post
Share on other sites

Hab die aktuelle 1.7.2.0 installiert.

Von 1.7.x wird hier nach wie vor überwiegend abgeraten, kaum jemand verwendet es zumindest zu Testzwecken, somit kann bei Problemen kaum jemand helfen. !.7.2.0 ist als etwas größeres Update erst vor ein paar Tagen herausgekommen, so etwas ist immer ein erhöhtes Risiko, ob sich da schon jemand rangetraut hat, keine Ahnung.

 

Tritt das Problem nur bei "Banküberweisung" oder auch bei anderen Zahlungsarten auf? Ggf. mal das Modul resetten oder de- und neu installieren.

Edited by rictools (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More