Jump to content
PrestaDesigner10

[1.7.1.2] - Codice fiscale obbligatorio

Recommended Posts

Buongiorno a tutti, 

ho attivato l'opzione per far comparire il campo "codice fiscale" nel form degli indirizzi ma questo appare come campo opzionale.

 

Qualcuno sa su quale file devo lavorare per renderlo un campo required?

 

Grazie

Share this post


Link to post
Share on other sites

ciao allora, prima di tutto ti consiglio di aggiornare la tua versione di prestashop quella che usi ha diversi bug poi per inserire obbligatorio il cf devi andare 

 

internazionale --> località seleziona la nazione italia clicca su modifica e trovi il campo 

Share this post


Link to post
Share on other sites

Ciao e grazie per il tuo intervento.

In realtà sto lavorando con la 1.7.2, errore mio.

Quanto al codice fiscale, avevo già fatto la procedura che mi hai suggerito. Il campo appare ma non come obbligatorio (è opzionale). Ho modificato alcuni files per renderlo obbligatorio. 

Il problema adesso è che un'azienda si trova obbligata ad inserire obbligatoriamente il C.F. ma non la partita IVA (non è obbligatoria). Non ha molto senso. 

In generale trovo sbagliato trattare alla stessa maniera l'indirizzo di consegna e quello di fatturazione poichè il primo non ha alcun bisogno di codice fiscale e/o P. IVA mentre il secondo si, ma non obbligatoriamente di entrambi.

 

Qualcuno sa se esiste un modulo per gestire questo aspetto?

Share this post


Link to post
Share on other sites

Salve a tutti.

Sto usando la versione 1.7.1.2 e mi trovo ad avere il medesimo problema.

Abilito la richiesta del codice fiscale (obbligatorio), ma nel form di registrazione non appare nemmeno lo spazio.

Ho letto nella risposta precedente che questa versione é piena di bug, sapreste consigliarmi una versione più corretta?

Ringrazio anticipatamente chi mi aiuterá

P.S. sono un neofita, siate clementi

Edited by andmar

Share this post


Link to post
Share on other sites

ciao allora, prima di tutto ti consiglio di aggiornare la tua versione di prestashop quella che usi ha diversi bug poi per inserire obbligatorio il cf devi andare 

 

internazionale --> località seleziona la nazione italia clicca su modifica e trovi il campo 

 

 

effettuando quanto sopra descritto questo lo rende obbligatorio quindi bisogna spuntare su si " richiesto numero di codice fiscale ? " se questo non viene fatto prova ad andare in clienti --> indirizzi clicca su campi obbligatori e metti la spunta su dni

 

alcuni leggo che non appare ma io lo vedo (sul sito di test) con il template classic

Share this post


Link to post
Share on other sites

effettuando quanto sopra descritto questo lo rende obbligatorio quindi bisogna spuntare su si " richiesto numero di codice fiscale ? " se questo non viene fatto prova ad andare in clienti --> indirizzi clicca su campi obbligatori e metti la spunta su dni

 

alcuni leggo che non appare ma io lo vedo (sul sito di test) con il template classic

Ciao, ascolta ho un problema, se faccio come dici tu e imposto il dni obbligatorio su indirizzi, nel momento in cui vado in checkout mi da internal server error 500

Share this post


Link to post
Share on other sites

ok credo di aver capito quale sia la causa del vostro problema, creo un video che faccio prima così lo posto su youtube e spero che vi sia di aiuto a tutti, appena ho fatto vi scrivo qui e vi posto il link (sperando che sia la soluzione)  ;) 

Share this post


Link to post
Share on other sites

Ciao, ascolta ho un problema, se faccio come dici tu e imposto il dni obbligatorio su indirizzi, nel momento in cui vado in checkout mi da internal server error 500

Questo è successo anche a me, e quel giorno sono andato in panico perché non ricordavo fosse collegato al flag su dni. Poi alla fine, dopo qualche ora di ricerche, ho scoperto il problema. 

Oggi ho tentato nuovamente fleggando il campo e non mi da più l`error 500. Che sia perché nel frattempo ho aggiornato la versione a 1.7.2.1?

Comunque, fleggando il campo, adesso il cf diventa obbligatorio.

Grazie

Share this post


Link to post
Share on other sites

Questo è successo anche a me, e quel giorno sono andato in panico perché non ricordavo fosse collegato al flag su dni. Poi alla fine, dopo qualche ora di ricerche, ho scoperto il problema. 

Oggi ho tentato nuovamente fleggando il campo e non mi da più l`error 500. Che sia perché nel frattempo ho aggiornato la versione a 1.7.2.1?

Comunque, fleggando il campo, adesso il cf diventa obbligatorio.

Grazie

Io ho la 1.7.2.2 ma non c’é verso, come lo imposto obbligatorio va in errore :(

Share this post


Link to post
Share on other sites

Ho risolto Ragazzi, bisogna sporcarsi un po' le mani con il codice ma tutto sommato una soluzione c'e'! Lasciate perdere il flag in fondo alla pagina dei clienti non so perche' ma da problemi.

 

Vi allego il file da posizionare nella cartella override/classes/form/ 

 

ATTENZIONE:

  • Solitamente la cartella form non e' presente, createla!
  • La soluzione e' testata per la versione 1.7.2.2 non mi assumo responsabilita' per malfunzionamenti

CustomerAddressFormatter.php

Edited by cristian_ps

Share this post


Link to post
Share on other sites

Caricato il file ma non cambia nulla. Grazie

Che versione hai? Hai controllato che non hai il flag: "Disattiva gli override" attivo? hai provato cancellando il file class_index? Fammi sapere che faccio dei test

Share this post


Link to post
Share on other sites

Prestashop 1.7.2.4

L'errore 500 io l'avevo quando ordinavano dall'estero, poi mi sono accorto che andando in clienti->indirizzi, in fondo c'è un accordion "impostare i campi obbligatori per questa sezione", e li avevo dni obbligatorio per tutti. Non differenziava fra italia o estero, quindi l'ho disattivato.

Cmq per adesso ho disattivato questo override perchè vorrei trovare una soluzione del genere:

> Quando il cliente vuole la fattura, allora il campo CF diventa obbligatorio.

Mi sa che per adesso dovrò disattivare anche la richiesta della fattura, al massimo si farà a mano fino a che non si risolve. Il problema è che così il cms emette fatture senza CF, che, come sappiamo, non sono corrette.

Edited by PerLaVia

Share this post


Link to post
Share on other sites

ciao a tutti, io ho prestashop 1.7.2.2 e con campo codice fiscale obbligatorio nella sezione "nazioni-italia" e con dni obbligatorio nella sezione clienti-indirizzi se un utente straniero effettua un checkout rapido o si registra mi d errore 500. Con modalità debug attiva ho provato e vedo che l'eerore è proprio legato alla validazione del "dni".

Ho provato anche la soluzione proposta da cristia_ps mettendo il file che gentilmente ci ha messo a disposizione ma non ho risolto.

Avete qualche idea per risolvere?

grazie mille

Share this post


Link to post
Share on other sites
On 7/12/2017 at 7:53 PM, AlessandroBTstudio dice:

ciao a tutti, io ho prestashop 1.7.2.2 e con campo codice fiscale obbligatorio nella sezione "nazioni-italia" e con dni obbligatorio nella sezione clienti-indirizzi se un utente straniero effettua un checkout rapido o si registra mi d errore 500. Con modalità debug attiva ho provato e vedo che l'eerore è proprio legato alla validazione del "dni".

Ho provato anche la soluzione proposta da cristia_ps mettendo il file che gentilmente ci ha messo a disposizione ma non ho risolto.

Avete qualche idea per risolvere?

grazie mille

Ciao Alessandro,

da quello che ho capito, l'errore 500, come ho scritto sopra, te lo da poichè hai impostato dni obbligatorio per tutti i clienti ma se uno fa l'ordine con indirizzo estero, nel form dati indirizzo in fase di acquisto, non viene visualizzato il campo dni e di conseguenza non può riempirlo e prestashop va in errore perchè pretende che sia non vuoto.

In pratica, se imposti il dni obbligatorio nella pagina indirizzi cliente, devi dare la possibilità al cliente stesso di compilare quel campo cosa che non viene fatta visto che il campo è nascosto (intendo per i clienti dall'estero).

Share this post


Link to post
Share on other sites

Anche io con la 1.7.1.2 stessa situazione, selezionato la richiesta del Codice Fiscale obbligatorio ma non funziona. Qualcuno ha riscontro che aggiornando alla 1.7.2.4 si risolve? Dato che ho dei moduli esterni per le sincronie clienti e fatturazione vorrei andare sul sicuro.

Share this post


Link to post
Share on other sites

Io ho risolto così (premesso che è veramente assurdo come gestisce certe cose prestashop) oltre a selezionare in

Internazionale - Località (selezionare italia) -  Richiesto numero di codice fiscale?  (mettere si)   poi salvate.

Poi andate in 

Clienti - Indirizzi -  sotto compare  Impostare i campi obbligatori per questa sezione

Qui selezionare dni e salvare.

Viene richiesto in 2 punti diversi il settaggio altrimenti non lo prende.

Funzionante sulla 1.7.1.2

Ciao

 
 
Edited by zorzside

Share this post


Link to post
Share on other sites
30 minuti fa, zorzside dice:

Io ho risolto così (premesso che è veramente assurdo come gestisce certe cose prestashop) oltre a selezionare in

Internazionale - Località (selezionare italia) -  Richiesto numero di codice fiscale?  (mettere si)   poi salvate.

Poi andate in 

Clienti - Indirizzi -  sotto compare  Impostare i campi obbligatori per questa sezione

Qui selezionare dni e salvare.

Viene richiesto in 2 punti diversi il settaggio altrimenti non lo prende.

Funzionante sulla 1.7.1.2

Ciao

 
 

Hai provato a fare un acquisto da un paese straniero? non ti va in errore 500?

Share this post


Link to post
Share on other sites

Ciao a tutti forse ho risolto il problema dopo mesi:

come scritto in primo post se spuntavo dni come campo obbligatorio sotto la voce clienti indirizzi e in internazionale località Italia aver messo rendi obbligatorio cod.fiscale i clienti stranieri che facevano registrazione ottenevano un errore 500. 

Ma se si spegne l’opzione “friendly url” in impostazioni generali tutto funziona. Purtroppo l’opzione friendly url causa molto problemi tra cui anche questo.

 

provate dovrebbe funzionare come descritto sopra

Share this post


Link to post
Share on other sites

Versione Prestashop 1.7.2.4.
Avevo errore 500 come descritto da molti. Ho fatto un pò di prove e risolto in questo modo.

1) Vado in Internazionale > Località > Italia e aggiungo il campo DNI nell'elenco da menu Address
2) Spunto nella sezione Codice fiscale obbligatorio e salvo
3) Vado in Clienti > Indirizzi e imposto come campo obbligatorio dni

A questo punto dovrebbe dare l'errore 500

4) MA cancellando gli indirizzi italiani presenti nella sezione indirizzi prima dell'obbligatorietà del campo dni,
l'errore non si ripresenta. 
Per me ha funzionato.

Ps. non ho provato l'estero essendo focalizzato sull'italiano 

Edited by Ardand
Precisazione

Share this post


Link to post
Share on other sites

purtroppo confermo che il problema persiste quando si decide di vendere in più paesi oltre l'italia, in quanto essendo obbligatorio in italia, e negli altri paesi no, quando un utente cerca di acquistare da un altro paese, la piattaforma non vede il codice fiscale tra i campi obbligatori, essendo nascosto, e da l'errore. Mi auguro che risolvano presto questa situazione, perchè altrimenti diventa un grosso problema.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×