Jump to content
matthias_timajolo

Prestashop V1.6 mit PHP 7.1

Recommended Posts

Hallo,

 

mein Prestashop wird auf Strato betrieben. Ich bin dort am Einrichten eines Shop der Version 1.6

 

Nun wurde von meinem "Lieferanten" der mir Strato verwaltet mitgeteilt, dass er die PHP von 5.6 auf 7.1 ändern musste.

 

Seit dort habe ich keinen Zugriff mehr auf meine SHop . Es kommt nur noch die Fehlermeldung internal server error.

 

Kennt jemand dieses Problem? Gibt es von Presta hier updates dass mein Shop wieder da ist?

 

Wie kann ich diese Update ausführen wenn ich nicht mehr ins Backend komme?
 

Danke für euere Hilfe im Voraus.

 

Matthias

Share this post


Link to post
Share on other sites

stell mal wieder auf 5.6 und teste dann, ob du wieder zugriff hast

Share this post


Link to post
Share on other sites

Oder man schaut mal in das Server Fehlerlogfile. Da steht fast immer, wo der Schuh drückt.

Share this post


Link to post
Share on other sites

"Version 1.6." ist sehr, sehr ungenau ...

 

Die neuesten 1.6.1.x-Versionen sollten mit PHP 7.1 laufen, bei Fehler 500 aktiviere Error Reporting, um eine aussagekräftige Fehlermeldung zu erhalten.

 

Trotzdem verstehe ich nicht, warum dich ein "Lieferant" davon abhält, PHP 5.6 zu nutzen. Bei 1&1 kann ich im normalen Hosting für jede Subdomain separat die PHP-Version einstellen ...

Share this post


Link to post
Share on other sites

das Problem hat sich wohl schon in Luft aufgelöst...

Share this post


Link to post
Share on other sites

Nach 2 Tagen kann man das nicht sicher sagen, der Shop wird ja auch erst eingerichtet, da eilt so etwas nicht so.

Share this post


Link to post
Share on other sites

Leider ist es nicht gelöst.

 

Mein Problem ist, dass ich nicht selbst auf den Hoster zugreifen kann. Die Domanin liegr einem Bekannten der ein größeres Paket hat.

Er hat inzwischen auf php7.0 umgestellt aber immer noch die dieselbe Meldung

 

Ich kann halt auch nicht auf den errorlog nicht zugreifen da ich dazu den Zugang zum Hoster benötige.

 

Ich nutze prestashop1.6.1xx

Share this post


Link to post
Share on other sites

Gibt es irgendeine Möglichkeit über ftp eine neue Version auf die Datenbank zu spielen.

 

Ich weiß die Frage ist vlt dumm aber ich kenn mich da nicht so gut aus

Share this post


Link to post
Share on other sites

Nein, per FTP kann man nichts aufspielen!

Aber der Bekannte könnte Dir wohl aber allenfalls eine andere PHP-Version aufschalten.

 

Jetzt das grosse ABER!

Dein Setup ist spätestens mittelfristig zum Scheitern verurteilt. Als Shopbetreiber muss man direkt und ohne Umwege

 

- Zugriff auf Logfiles

- Zugriff auf die Datenbank

- Zugriff auf relevante Konfig-Files

- Zugriff auf das PHP-Setup haben

 

Alles andere ist am komplett falschen Ort gespart.

Share this post


Link to post
Share on other sites

Wenn man Fehler-Logfiles für den Shop nicht zugreifen kann, ist das wie Autofahren mit einer durch Zeitungspapier abgedeckten Frontscheibe!

  • Like 1

Share this post


Link to post
Share on other sites

Mein Problem ist, dass ich nicht selbst auf den Hoster zugreifen kann. Die Domanin liegr einem Bekannten der ein größeres Paket hat.

Er hat inzwischen auf php7.0 umgestellt aber immer noch die dieselbe Meldung

 

Ich kann halt auch nicht auf den errorlog nicht zugreifen da ich dazu den Zugang zum Hoster benötige.

 

Ich nutze prestashop1.6.1xx

Generell, wenn dein Agreement mit deinem Bekannten nicht einschließt, daß du an Logfiles rankommst (ggf. halt halbwegs kurzfristig über ihn), dann gib ein paar Euro mehr aus für ein eigenes Hosting.

 

Wenn du nicht in der Lage bist, uns deine Prestashop-Version zu nennen, dann solltest du das ganze komplett bleiben lassen, das kann doch nicht so schwer sein. Ich habe 1.6.1.x als übergreifende Bezeichnung für alle 1.6.1-er-Versionen verwendet, dabei aber schon zwischen älteren und neueren Versionen dieser Reihe unterschieden, es ist also ein Unterschied, ob du z. B. wie ich 1.6.1.4 hast (meines Wissens nicht problemlos mit PHP 7 verwendbar) oder das letzte 1.6.1.15!

 

Wenn dein Bekannter auf PHP 7.0 oder 7.1. (du schreibst mal so mal so, es ist wirklich zum Verzweifeln, was bist du, Kaufmann oder Grundschüler der 2. Klasse?) umgestellt hat, heißt das nicht, daß er für deine Domain oder Subdomain nicht weiter PHP 5.6 einstellen kann, hast du das geklärt?

 

Hast du versuchsweise Error Reporting aktiviert (https://www.prestashop.com/forums/topic/235140-hilfe-wenn-ich-das-und-das-mache-ist-eine-leere-seite-zu-sehen/)?

Share this post


Link to post
Share on other sites

Ich schätze mal, du hast den jetzt verschreckt.....

 

Vielleicht wäre es innvoll, mal eine Liste zu erstellen, welche Version mit welchem PHP ohne UMstellungen läuft, eventuell kann man da ja dann dranhängen, welche Versionen umgepatcht werden können, bei Bedarf auch, was dann zu tun wäre.

 

1.6.1.7 läuft mit 5.6x, 7.0.x aber nicht mit 7.1.x

Share this post


Link to post
Share on other sites

Vielleicht wäre es innvoll, mal eine Liste zu erstellen, welche Version mit welchem PHP ohne UMstellungen läuft, eventuell kann man da ja dann dranhängen, welche Versionen umgepatcht werden können, bei Bedarf auch, was dann zu tun wäre.

 

1.6.1.7 läuft mit 5.6x, 7.0.x aber nicht mit 7.1.x

Wenn man das so generell sagen kann, ich fürchte aber, das ist dann auch noch von irgendwelchen Serverkonfigurationen, Datenbankversion, verwendeten Modulen abhängig.

 

Außerdem hilft das wenig, wenn die Leute nicht in der Lage sind, ihre Shop- und PHP-Version festzustellen oder hier fehlerfrei und vollständig zu posten ... Und sorry, wer da so nachlässig ist, dem traue ich auch alle anderen Flüchtigkeitsfehler und Ungenauigkeiten zu.

 

Gibt es bei PHP eigentlich noch Unterversionen von 5.6, 7.1 etc.?

Share this post


Link to post
Share on other sites

Guten morgen allseits,

 

Wer hier fragt, muss halt auch mal etwas reinnehmen können. Und @RIC: ja es gibt natürlich zahlreiche Unterversionen von PHP. Die meisten Versionen schaffen es aber gar nie in einen stable Release, weshalb der normale Endbenutzer auch gar nicht alle Unterversionen zur Verfügung hat.

 

Bei uns ist derzeit PHP 7.0.20 in Produktion am Laufen mit PS 1.6.1.XX.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More