Jump to content
Masteries

Most optimal PHP version for 1.6.1.15?

Recommended Posts

Which PHP version would be the most optimal for the latest 1.6 version? I'm currently using it with PHP 5.6 in my XAMPP environment and I'm getting some PHP Notice errors related to Smarty when I have devmode on. Is this because of a compatibility issue or does this happen to everyone?

Share this post


Link to post
Share on other sites

I would say PHP7.0

 

Lots of people are saying PHP7 will cause compatibility issues with some modules so I'd definitely want to avoid that.

Share this post


Link to post
Share on other sites

Prestashop official tutorials indicate php 5.4.5+

You can use each php 5.6. version. For better performances use 5.6. + php-fpm + opcache + ngnix proxied (over Apache) and optimization on opcache and databse. if you do by this way you will have the same speed as with php 7.0.

 

Optimization on opcache - This tutorial is for root or VPS servers with full root access to server configuration:

opcache.revalidate_freq=0
opcache.validate_timestamps=0 (comment this out in your dev environment)
opcache.max_accelerated_files=7963
opcache.memory_consumption=192
opcache.interned_strings_buffer=16
opcache.fast_shutdown=1
  • Like 1

Share this post


Link to post
Share on other sites

PS: I'm using in production php 5.6.30, and the same server configuration on Prestasho 1.7 latest for test purposes. All running fine.

  • Like 1

Share this post


Link to post
Share on other sites

my two cents (ps 1.6 and <)  php 5.6 with opcache

1.7 php 7

  • Like 1

Share this post


Link to post
Share on other sites

PS: I'm using in production php 5.6.30, and the same server configuration on Prestasho 1.7 latest for test purposes. All running fine.

 

 

my two cents (ps 1.6 and <)  php 5.6 with opcache

1.7 php 7

 

Thanks for your replies! I will stick to PHP 5.6 in that case.

Share this post


Link to post
Share on other sites

I run PS v1.6.1+ on PHP 7.0 with opcache enabled and it works perfectly fine (core, ps-modules and custom modules).  The other things to consider however is other PHP based software that you might have installed (ie.. blog)

 

Consider using PHP 7.0 and just perform testing to ensure compatibility.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More