Jump to content
William K.

1-click update 1.4 => 1.6 problème accueil/homepage

Recommended Posts

Bonjour,

 

je suis actuellement en train de migrer un site en version 1.4 vers 1.6 en locale.

 

Après plusieurs tentatives avec des techniques différentes (1-click update / nouvelle version 1.6 avec import de nombreuses tables en SQL/CVS ...), et la résolution de plusieurs problèmes (principalement liés à la création de la catégorie "Root" au-dessus de la catégorie "home", la perte de lien de certaines tables "product" et "category", l'adoaptation de l’arborescence des dossiers images pour 1.6 ...) me voilà confronté à une nouvelle problématique. 

 

Concrètement, je possède actuellement une version 1.6 qui possède toutes les données (clients / factures / produits ...) dont j'ai besoin et j'ai accès à toutes les pages de produits ou de catégories affichées avec le thème de base (default-boostrap).

 

L'unique page qui ne s'affiche pas correctement est l'accueil. Celle-ci n'affiche que le logo ainsi que la délimitation du header.

La console ne me donne aucune erreur, c'est comme si la page n'essayait pas de charger les modules qu'elle devrait.

 

Le problème semble venir de la base de donné et plus précisément de ps_configuration (mais peut-être pas uniquement.).

Je dis cela car l'échange de cette table avec une table ps_configuration d'une version franchement  installée permet de résoudre une grande partie des problèmes (les éléments sont dans se cas chargés mais il y a de nombreuses choses qui "cassent", certainement à cause du très grand nombre d'information dans ps_configuration qui ne correspondent plus au site actuel)

 

J'ai longuement comparés les deux versions de la table mais elles divergent énormément et je n'arrive pas à localiser l'élément qui bloquerait le bon chargement de la page d'accueil.

 

Si vous avez la moindre idée de la source de ma page d'accueil vide et pouvez me faire part de votre idée, je vous serai grandement reconnaissant.

 

Share this post


Link to post
Share on other sites

Arf, vraiment désolé j'ai posté une explication bien plus succincte de mon problème étant donné l'absence d'attention que se topic avait reçus et je suis actuellement assez proche d'avoir résolu mon problème. Le sujet se trouve ici : https://www.prestashop.com/forums/topic/620686-accueil-cass%C3%A9-apr%C3%A8s-upgrade/ .

 

J'y posterai quand mon soucis sera résolu. Encore vraiment désolé d'avoir dupliqué mon poste, j'avais vraiment besoin d'un coup de pouce et ne sait pas comment fermer ou demander de fermer un poste. Si cela peut-être fait merci de m'en informer, sinon merci de laisser se poste et de suivre sur celui indiqué plus haut.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More