Jump to content
pitchart

[Résolu] Click Upgrade bug pour passer de 1.6.1.14 a 1.6.1.15

Recommended Posts

Bonjour,

 

Etant sous prestashop 1.6.1.14 avec la dernière version de click upgrade 1.6.7 je n'avais jamais rencontré de problème de mise à jour avant là ce passage de 1.6.1.14 à la 1.6.1.15.

 

En lançant la mise à jour via Click Upgrade au bout de 30 sec. une fenêtre pop up s'ouvre avec ce message :

 

" Voulez-vous restaurer V1.6.1.14_20170706-005504-6909320f "

et dans le log error nous avons ces 2 lignes :

" Erreur lors de la copie de /modules/blockadvertising/config.xml "
" Erreur lors de la mise à jour de /modules/blockadvertising/config.xml "

et nous ne pouvons rien faire d'autres que de quitter la page, sans savoir ce que le module à fait dans les fichiers etc...

 

J'ai posté également cela sur la forge mais si vous avez une idée du problème :) merci

 

LA SOLUTION :

"Merci pour l'astuce car cela à résolu le soucis, en détail j'ai fais ce que tu as dit "créer le dossier en question dans /modules" mais après j'ai eut la même chose avec "blockbanner", "blockbestseller" etc.... du coup je me suis dit il va me faire tous les dossiers modules donc j'ai récupéré l'archive de prestashop 1.6.1.15 que j'ai extraite et copié tous les dossiers contenus dans /modules pour ensuite coller dans mon dossier /modules sur le ftp. Si un dossier existait déjà j'ai décider de ne pas copier.

 

Et au final la mise à jour c'est bien passé après cela :)

 

Etrange quand même que j'ai été obligé de faire cela pour cette Maj mais au final elle c'est faite merci de l'aide."

Edited by pitchart (see edit history)

Share this post


Link to post
Share on other sites

Les erreurs lors de la copie sont a 95% des problèmes de droits

Share this post


Link to post
Share on other sites

Des problèmes de droits dans l'archive que click upgrade télécharge pour faire la mise à jour alors ?

Share this post


Link to post
Share on other sites

Non, des problèmes de droits dans ton répertoire modules l'empêchant de copier

Share this post


Link to post
Share on other sites

Ok mais je n'ai pas du tout ce module là blockadvertising qui coince lors de l'upgrade sur mon ftp ni ailleurs pourtant

Share this post


Link to post
Share on other sites

Justement, lorsqu'il essaie de créer le répertoire il n'y arrive pas.

Share this post


Link to post
Share on other sites

LWS serveur dédié VPS

 

Informations sur votre serveur Linux #1 SMP Tue Oct 25 22:31:12 MSK 2016 x86_64

Version du logiciel serveur Apache

Version de PHP 5.5.7

Share this post


Link to post
Share on other sites

Tu as assez d'espace disque? Tu as des quotas de fichiers?

Share this post


Link to post
Share on other sites

A ce niveau là pas de problème rien n'a changé quand j'étais passé de 1.6.1.13 à la 1.6.1.14, là sa coince avec la 1.6.1.15

 

Je viens de renter pour vous montrer une capture (voir pièce jointe)

post-834635-0-42030700-1499465304_thumb.jpg

Edited by pitchart (see edit history)

Share this post


Link to post
Share on other sites

créé le répertoire modules/blockadvertising et voyons si ça aide.

Share this post


Link to post
Share on other sites

Merci pour l'astuce car cela à résolu le soucis, en détail j'ai fais ce que tu as dit "créer le dossier en question dans /modules" mais après j'ai eut la même chose avec "blockbanner", "blockbestseller" etc.... du coup je me suis dit il va me faire tous les dossiers modules donc j'ai récupéré l'archive de prestashop 1.6.1.15 que j'ai extraite et copié tous les dossiers contenus dans /modules pour ensuite coller dans mon dossier /modules sur le ftp. Si un dossier existait déjà j'ai décider de ne pas copier.

 

Et au final la mise à jour c'est bien passé après cela :)

 

Etrange quand même que j'ai été obligé de faire cela pour cette Maj mais au final elle c'est faite merci de l'aide.

Share this post


Link to post
Share on other sites

C'est très bizarre, genre la création de répertoire ne fonctionne pas, j'irais revoir en profondeur, mais n'ayant pas eu ce problème sur mes upgrades, serait-il possible que tu aïs un couche sécurité un peu agressive?

Share this post


Link to post
Share on other sites

J'ai eu un problème similaire (heureusement sur une version de dev locale...):

- utilisation du module "1 click upgrade" qui avait très bien fonctionné pour le passage des versions depuis la 1.6.1.11

- mais là le passage vers la 1.6.1.15 échoue avec un message d'erreur sur le fichier config/defines.inc.php

- le gros problème de l'affaire est que la restauration plante elle aussi et me laisse avec un dossier prestashop dans lequel il manque plein de fichiers (quasiment tous ceux de config/)

 

Résultat: passage en mise à jour manuelle à partir du zip de la version 1.6.1.15 et réinstallation (très) pénible de l'ensemble de la boutique...

 

Moralité: je n'ai *plus du tout* confiance dans ce p*** de module d'autoupgrade que je déconseille absolument !

(j'aime encore mieux gérer une mise à jour à la main que de me retrouver planté avec des fichiers disparus alors que l'outil prétend avoir une possibilité de restauration)

Edited by clem_pro (see edit history)

Share this post


Link to post
Share on other sites

 @clem_pro

moralité je n'ai pas du tout confiance en ta p***n de configuration car j'utilise plusieurs fois par semaine autoupgrade et il possède quelques bugs mais fais le job. En tout cas jamais n'a ton comportement sur une config stable

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More