Jump to content
Sidinei Brito

Após 198 produtos cadastrados, os novos a partir de 199 não carregam na página ( product.tpl )

Recommended Posts

Olá pessoal, preciso de ajuda!

Após 198 produtos cadastrados, os novos a partir de 199 não carregam na página ( product.tpl ) apenas é carregado na lista ( product-list.tpl ). Não consigo descobrir o que está acontecendo. O restantes anteriores carregam normal, sem erros.

 

 

Segue link para análise:

 

Novo produto QB275

https://quadrosabstratosbritto.com/limited-edition/282-quadros-abstratos-limited-edition-britto-qb275.html

 

Novo produto QB274

https://quadrosabstratosbritto.com/home/281-quadros-abstratos-limited-edition-britto-qb274.html

 

Informações da Loja

versão do PrestaShop 1.6.1.4

URL da loja http://quadrosabstratosbritto.com/

Nome do tema utilizado Britto-Default     

 

Informação do servidor

Informação do servidor Linux #1 SMP Tue Jun 20 13:27:00 EDT 2017 x86_64

Versão do Software do Servidor Apache

Versão PHP 5.6.30

Limite de memória 256M

Tempo máximo de execução 30     

 

Agradeço desde já se puderem me ajudar!

Edited by Sidinei Brito (see edit history)

Share this post


Link to post
Share on other sites

Acredito que você está com uma divergência entre a ID do produto e a URL amigável que criou para cada produto.

Provavelmente foi duplicando produtos e acabou deixando a URL amigável de alguns incorreta.

 

Se utilizar o link sem URL amigável, funciona: https://quadrosabstratosbritto.com/index.php?controller=product&id_product=274

 

Recomendo que verifique todas as URLs cadastradas em cada produto, desative e reative as URLs amigáveis para gerar um novo arquivo .htaccess.

Share this post


Link to post
Share on other sites

Daniel,

Acho que fiz algo errado:

Desabilitei (URL amigável) e desabilitei (Forçar URL amigável)

Não carrega mais o Admin e o site, solicitei ajuda ao servidor, quando tiver resposta te informo.

Obrigado pela atenção!

Share this post


Link to post
Share on other sites

Acredito que você está com uma divergência entre a ID do produto e a URL amigável que criou para cada produto.

Provavelmente foi duplicando produtos e acabou deixando a URL amigável de alguns incorreta.

 

Se utilizar o link sem URL amigável, funciona: https://quadrosabstratosbritto.com/index.php?controller=product&id_product=274

 

Recomendo que verifique todas as URLs cadastradas em cada produto, desative e reative as URLs amigáveis para gerar um novo arquivo .htaccess.

Daniel,

Acho que fiz algo errado: 

Desabilitei (URL amigável) e desabilitei (Forçar URL amigável)

Não carrega mais o Admin e o site, solicitei ajuda ao servidor, quando tiver resposta te informo.

Obrigado pela atenção!

Share this post


Link to post
Share on other sites

Ative o modo debug para ver qual o erro: https://www.prestashop.com/forums/topic/282165-ativar-modo-debug/

 

Seu host deve estar mal-configurado. É um VPS ou compartilhado?

Vc tem acesso às configurações?

 

Se tiver, verifique se está tudo OK, comparando com estas: https://www.prestashop.com/forums/topic/236128-tutorial-servidor-configura%C3%A7%C3%A3o-m%C3%ADnima-para-prestashop/

  • Like 1

Share this post


Link to post
Share on other sites

Ative o modo debug para ver qual o erro: https://www.prestashop.com/forums/topic/282165-ativar-modo-debug/

 

Seu host deve estar mal-configurado. É um VPS ou compartilhado?

Vc tem acesso às configurações?

 

Se tiver, verifique se está tudo OK, comparando com estas: https://www.prestashop.com/forums/topic/236128-tutorial-servidor-configura%C3%A7%C3%A3o-m%C3%ADnima-para-prestashop/

Debug para Admin:

URL: https://quadrosabstratosbritto.com/adminBritto/index.php?controller=AdminLogin&token=d142f82c277fe8e0a240fa529071891b

MSN: Fatal error: Uncaught --> Smarty: Invalid compiled template for 'controllers/modules/login_addons.tpl' <-- thrown in /home/quadrosa/public_html/tools/smarty/sysplugins/smarty_internal_templatebase.php on line 182

 

Debug para home:

MSN:  Fatal error: Uncaught --> Smarty: Invalid compiled template for '/home/quadrosa/public_html/themes/javascript.tpl' <-- thrown in /home/quadrosa/public_html/tools/smarty/sysplugins/smarty_internal_templatebase.php on line 182

 

Servidor compartilhado

 

Versão atual do PHP:  5.6
Versão do PHP
                4.4                     5.1                     5.2                     5.3                     5.4                     5.5                     5.6                     7.0                     7.1                     native (5.3)         
Output Buffering Off allow_url_fopen On disable_functions no value display_errors Off error_reporting E_ALL file_uploads On include_path .:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php log_errors On mail.force_extra_parameters no value max_execution_time 300 max_input_time -1 memory_limit 256M open_basedir no value post_max_size 16M session.save_path /tmp short_open_tag On suhosin.session.encrypt On upload_max_filesize 16M

 

 

Apenas desabilitei (URL amigável) e desabilitei (Forçar URL amigável) e não carrega mais o Admin e o site :)

Share this post


Link to post
Share on other sites

Daniel,

Optei por zerar meu servidor e refazer minha loja, assim terei menos dor de cabeça e aproveitarei para utilizar a versão mais recente do Prestashop. Uma vez fiz uma atualização e tive muitos problemas por isso nunca mais vou atualizar, farei uma instalação nova que no máximo 4 dias estarei com a loja nova sem dor de cabeça.

Agradeço pela sua ajuda e atenção! 

Share this post


Link to post
Share on other sites

Daniel,

Optei por zerar meu servidor e refazer minha loja, assim terei menos dor de cabeça e aproveitarei para utilizar a versão mais recente do Prestashop. Uma vez fiz uma atualização e tive muitos problemas por isso nunca mais vou atualizar, farei uma instalação nova que no máximo 4 dias estarei com a loja nova sem dor de cabeça.

Agradeço pela sua ajuda e atenção! 

Aproveite e mude pra um VPS...

Senão vai continuar tendo problema.

 

P.S.: Vide minha assinatura.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More