Jump to content
JeromeLBC

Erreur dans le chemin d'accès à un template

Recommended Posts

Bonjour,
 
J'ai besoin d'intervenir sur le contenu d'une boutique en ligne. J'ai en ma possession l'intégralité du code et un dump de la bdd et voici ce que j'ai fait :
 
- j'ai copié l'intégralité du code dans le répertoire www de wamp
- j'ai mis en place la base de données à partir du dump
 
En allant sur le site en local, j'arrive sur une page blanche. Après avoir activé le mode développement, j'ai l'erreur suivante :
 

Fatal error: Uncaught exception 'SmartyException' with message 'Unable to load template file 'D:\wamp\wwwolist/themes/default-bootstrap/./global.tpl' in 'D:\wamp\www\volist/themes/axome/./footer.tpl'' in D:\wamp\www\volist\tools\smarty\sysplugins\smarty_internal_templatebase.php on line 130
SmartyException: Unable to load template file 'D:\wamp\wwwolist/themes/default-bootstrap/./global.tpl' in 'D:\wamp\www\volist/themes/axome/./footer.tpl' in D:\wamp\www\volist\tools\smarty\sysplugins\smarty_internal_templatebase.php on line 130

J'ai l'impression qu'il y a un problème d'encodage sur le chemin du template.
Là où on trouve :
D:\wamp\wwwolist
il devrait y avoir :
D:\wamp\www\volist
 
Cette exception est générée dans le fichier suivant :
D:\wamp\www\volist\tools\smarty\sysplugins\smarty_internal_templatebase.php

        // checks if template exists
        if (!$_template->source->exists) {
            if ($_template->parent instanceof Smarty_Internal_Template) {
                $parent_resource = " in '{$_template->parent->template_resource}'";
            } else {
                $parent_resource = '';
            }
            throw new SmartyException("Unable to load template {$_template->source->type} '{$_template->source->name}'{$parent_resource}");
        }

et cela correspondrait à cette variable : $_template->source->name
 
Avez-vous une piste pour m'aider ?
La version de prestashop est 1.6.0.8

 

Merci bien

Share this post


Link to post
Share on other sites

Pour information le caractère spécial n'a pas été pris en compte dans le post, il s'agit d'un carré entre "www" et "olist" (cf capture)

post-1415914-0-46283900-1498839466_thumb.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More