Jump to content
Fred Fournier

Links within email templates are messed up - e.g.: admin/{shop_url}

Recommended Posts

Hello everyone,

 

 

I'm dealing with a strange issue on my Prestashop version, which is 1.6.1.14 (almost freshly installed).

 

 

Within email templates each variable which involves a URL, like {shop_url} or {product_link}, looks like this inside the html editor: https://www . myshop . com/admin/{shop_url}.

 

 

According to this setup, the final clickable link embedded into the email body is: https://www . myshop . com/admin/https:/www . myshop . com (we can also notice that there's only one slash after the second "https:" occurrence, which is weird too...)

 

 

All my attempts to delete links before variables have been vain... Whenever I save within the "Localization->Translations->Email template translations" page everything is restored the wrong way.

 

 

What can be the culprit?

 

 

Thanks for any help.

Edited by Fred Fournier (see edit history)

Share this post


Link to post
Share on other sites

im having a similar issue. I have installed on my main domain but all email links are showing another company (test domain). The shop_url is changed in the database and in back office im not sure what else to change

Share this post


Link to post
Share on other sites

Post one corresponding .tpl file here and we'll find the problem. Maybe you have hardcoded links in your mail template files...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More