Jump to content
shacker

[Module] Extra Manufacturer - Manufacturer And Supplier In Product Page V3.0- Ps 1.2/1.7

Recommended Posts

Hello Shacker,


Thanks for this great useful module.


I customize a few thinks.


Thirst I changed in the extramanufacturer.tpl the –medium_default.jpg into –large_default.jpg this will give a better quality of the pic.


And I use a factory and supplier icon, result see picture.


extra-factory-supplier.JPG


 


Thanks


 


Frank


 


www.4campers.nl


Share this post


Link to post
Share on other sites

Hi,

 

This is great module.

 

I am using latest version of presta and v2.4 of your module. I have problem that manufacturer logo is with question mark but have logo in the manufacture description page.

 

Edit: I figured out where is problem. I had to rebuild under images all images and it is working. 

 

Only possibility I am missing is to move it to left not center. I tried to edit mode .tlp file changing from center to left but it did not work. I changed file under modules.

 

 

Thanks,

 

Ints

Edited by freely151081 (see edit history)

Share this post


Link to post
Share on other sites

Hi,

 

This is great module.

 

I am using latest version of presta and v2.4 of your module. I have problem that manufacturer logo is with question mark but have logo in the manufacture description page.

 

Edit: I figured out where is problem. I had to rebuild under images all images and it is working. 

 

Only possibility I am missing is to move it to left not center. I tried to edit mode .tlp file changing from center to left but it did not work. I changed file under modules.

 

 

Thanks,

 

Ints

pleas try the latest version 2.5

Share this post


Link to post
Share on other sites

I try to show more than one supplier on product page.

The products are books and instead suppliers I use it for authors.

 

Maybe some of you have an idea how to realize showing all suppliers of one product.

I found this code in extramanufacturer\extramanufacturer\views\templates\front\extramanufacturer.tpl

{if $psversion > "1.6.0.0" }
<table width="100%" border="0" align="center" class="tem">
  <tr>
    <td align="center" valign="top" class="tem">
    {if $mn eq "1" && $product2->id_manufacturer > 0}<strong>{l s='Manufacturer' mod='extramanufacturer'}</strong><br />
        <a href="{$link->getmanufacturerLink($product2->id_manufacturer, $lrewm)|escape:'htmlall':'UTF-8'}">{$product2->manufacturer_name|escape:'htmlall':'UTF-8'}</a>
    {else}{/if}
    </td>
    <td align="center" valign="top" class="tem">
    {if $sn eq "1" && $product2->id_supplier > 0}<strong>{l s='Supplier' mod='extramanufacturer'}</strong><br />
     <a href="{$link->getsupplierLink($product2->id_supplier, $lrews)|escape:'htmlall':'UTF-8'}">{$product2->supplier_name|escape:'htmlall':'UTF-8'}</a>
        {else}{/if}
    </td>
  </tr>

Thank you.

Edited by sinni1 (see edit history)

Share this post


Link to post
Share on other sites
Hello,

thanks a lot for this module.

 

I have a probleme.. If one manufacturer doesn't have an image I see a ? in front office.

It is normale?

 

Is there a way to resolve this problem?

 

Thank you in advance

Share this post


Link to post
Share on other sites

 

Hello,
thanks a lot for this module.
 
I have a probleme.. If one manufacturer doesn't have an image I see a ? in front office.
It is normale?
 
Is there a way to resolve this problem?
 
Thank you in advance

 

Hi , How can i add phone number for suplier/manufacturer in module block.

thanks

Share this post


Link to post
Share on other sites

Hi everyone, I'm using this module and it's very good. I would like to know if it is possible to move the logo above the product name.
Thank you in advance

Share this post


Link to post
Share on other sites
23 hours ago, leonemoda said:

Hi everyone, I'm using this module and it's very good. I would like to know if it is possible to move the logo above the product name.
Thank you in advance

I think it's only the position hooked,plz check with ur IT staff

Share this post


Link to post
Share on other sites

Hello everyone.

I have installed module and it's pretty much the same what I needed. The only issue is that I'm using Russian language as default for my page and phone numbers for supplier & manufacturers are being displayed in English only. How can I replace the 'phone' word with it's russian analog?

Thnx!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More