Jump to content
Sign in to follow this  
prestamoi

Pas d'update de la table ps_delivery lors de l'ajout d'un transporteur

Recommended Posts

Bonjour à tous !

Bon, encore un petit problème pour vous :D

Ca concerne l'ajout d'un transporteur dans le Back Office. Je sais qu'il y a déjà eu pas mal de topics à ce sujet, mais aucun ne concerne mon problème en particulier. Je décris tout ça :

J'ajoute un transporteur dans le BO, en prenant soin de créer les tranches de prix et de poids. Et là quand je passe une commande sur mon site, il n'apparait pas, bien évidemment. Ca fait un bon petit moment que j'étais sur ce problème.

Et là j'ai remarqué qu'il y avait une table "ps_delivery" dans la base de données, et j'ai donc tenté de créer des enregistrements à la main dans la table, avec les mêmes valeurs que les transporteurs précédents, ET CA MARCHE.


Donc il doit y avoir un bug dans Prestashop (1.3 au fait), parce que ces enregistrements ne sont pas créés automatiquement. Quelqu'un sait comment je pourrais corriger ça ?

Merci à tous, et bonne fin de journée !

Share this post


Link to post
Share on other sites
Bonjour à tous !

Bon, encore un petit problème pour vous :D

Ca concerne l'ajout d'un transporteur dans le Back Office. Je sais qu'il y a déjà eu pas mal de topics à ce sujet, mais aucun ne concerne mon problème en particulier. Je décris tout ça :

J'ajoute un transporteur dans le BO, en prenant soin de créer les tranches de prix et de poids. Et là quand je passe une commande sur mon site, il n'apparait pas, bien évidemment. Ca fait un bon petit moment que j'étais sur ce problème.

Et là j'ai remarqué qu'il y avait une table "ps_delivery" dans la base de données, et j'ai donc tenté de créer des enregistrements à la main dans la table, avec les mêmes valeurs que les transporteurs précédents, ET CA MARCHE.


Donc il doit y avoir un bug dans Prestashop (1.3 au fait), parce que ces enregistrements ne sont pas créés automatiquement. Quelqu'un sait comment je pourrais corriger ça ?

Merci à tous, et bonne fin de journée !

Un petit up :)

Share this post


Link to post
Share on other sites
Bonjour à tous !

Bon, encore un petit problème pour vous :D

Ca concerne l'ajout d'un transporteur dans le Back Office. Je sais qu'il y a déjà eu pas mal de topics à ce sujet, mais aucun ne concerne mon problème en particulier. Je décris tout ça :

J'ajoute un transporteur dans le BO, en prenant soin de créer les tranches de prix et de poids. Et là quand je passe une commande sur mon site, il n'apparait pas, bien évidemment. Ca fait un bon petit moment que j'étais sur ce problème.

Et là j'ai remarqué qu'il y avait une table "ps_delivery" dans la base de données, et j'ai donc tenté de créer des enregistrements à la main dans la table, avec les mêmes valeurs que les transporteurs précédents, ET CA MARCHE.


Donc il doit y avoir un bug dans Prestashop (1.3 au fait), parce que ces enregistrements ne sont pas créés automatiquement. Quelqu'un sait comment je pourrais corriger ça ?

Merci à tous, et bonne fin de journée !

Un petit up :)

Up encore :s

Personne a eu ce problème ? Vous m'étonnez là.

Share this post


Link to post
Share on other sites

as tu réussi à résoudre ton problème ?
moi je n'y arrive pas . Je configure exactement la même chose que dans mon autre boutique v .1.2.4(qui fonctionne )
et sur celle là (version 1.3 ) impossible! .Message : transporteur invalide ou aucun transporteur sélectionné

Share this post


Link to post
Share on other sites

Oui, j'ai réussi à le résoudre, grâce à l'aide d'un autre topic sur ce sujet.

En fait une fois que tu as créé tes tranches, pour les transporteurs, il faut que tu retournes dans l'onglet Transport, et là en bas tu vas voir le fameux tableau (que j'avais raté) où il faut que tu définisses les frais de port, pour chaque tranche que tu as créée, et pour chaque zone géographique.

Tu sauvegardes, et là normalement ça devrait marcher.

Tiens moi au courant !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More