Jump to content
auderef

Bug paiement paypal uniquement sur certains produits PS1.7

Recommended Posts

Bonjour, 

Voici l'histoire :

 

j'ai rempli mon catalogue, pas le même jour mais en quelques semaines, pour chaque produits j'ai suivi la même procédure; de toutes façons il n'y à pas 30 façons de le faire.

 

J'ai ajouté le module paypal et fait les tests en sandbox : tout est ok

 

Hier ma copine me dit je vais te faire un achat  :)

 

Elle choisi le produit, arrive au moment de payer par CB en choisissant l'option proposée par paypal et là boom, chaque fois qu'elle valide la commande (bouton validez votre commande avec obligation de paiement) au lieu de partir sur le site paypal elle reste sur la page et un message d'erreur apparait : veuillez accepter les conditions de vente et choisir un mode de paiement. Elle a beau cocher les cases rien n'y fait elle tourne en boucle.

 

Alors, normal je commence à raler et je part tester sur mon ordi : même plan.

 

Donc j'ai du chercher et voila ce que j'ai trouvé : cela ne se produit que sur certains produits ! 

 

Je dois donc tester tous mes produits un à un, ce que je fais actuellement.

 

J'ai un problème en local quand je rentre certains produits, je fait toute la fiche et quand je la valide boom tout disparait, la fiche produit ne se fait pas ! Je vends des piles, donc les textes sont assez simples et ne contiennent pas de caractères spéciaux. Ca me le fait toujours avec le même produit ! Mystère.

 

Je dois essayer de créer ce produit direct sur le serveur voir si c'est ok ou pas.

 

Quelqu'un aurait une idée sur l'origine du problème ou bien aurait eu le meme genre de soucis?

 

Site : https://www.maxi-piles.fr/

Produit qui bugge : https://www.maxi-piles.fr/piles-aa/11-piles-aa-lr6-varta.html (option payer par carte)

Produit qui fonctionne (arrive jusqu'à paypal) : https://www.maxi-piles.fr/piles-aa/6-piles-aa-lr6-ansmann.html

 

PS: desolé pour le msg d'erreur sur fond rouge, je dois y remedier

Share this post


Link to post
Share on other sites

oui et ben sur 90 produits 18 plantent lors de l'envoi vers paypal, soit 20% des produits du site, balèse prestashop...

 

par contre si je met dans le panier un produit qui bugge et un qui passe, alors l'envoi vers paypal se fait bien. bon je vais fureter dans le code source de la page.

 

si je met 2 produits qui buggent ensemble, ça passe aussi  <_<

 

manipulations effectuées sur chrome, opéra et firefox

Edited by auderef (see edit history)

Share this post


Link to post
Share on other sites

Il faut se rendre à l'évidence, Prestashop est un CMS bourré de bugs.

 

Mon prochain site ne passera pas par lui. Je déconseille....

Share this post


Link to post
Share on other sites

Hé ben je l'ai résolu !

 

Cela venait du prix ! Incompréhensible.

 

Voici quelques exemples :

5.89 - 4.89 - 4.39 - 7.89 - 2.59 - 2.69

 

J'ai réussi en changeant les prix par exemple :

5.89 en 5.99

4.89 en 4.99

4.39 en 4.49

7.89 en 7.99

2.59 en 2.49

2.69 en 2.49

 

Vraiment un bug a la noix qui m'a fait perdre beaucoup de temps ....

(pareil si a la place du point c'est  un virgule comme 2,59)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More