Jump to content
lafronde99

Maj 1.7.1.1 => 1.7.1.2 / Erreur 500 backoffice

Recommended Posts

Bonjour,

 

Nous avons fait une mise a jour de 1.7.1.1 => 1.7.1.2 via 1 Click Upgrade et vers la fin, message suivant:

[Ajax / Server Error for action upgradeModules] textStatus: "error " errorThrown:"Gateway Timeout " jqXHR: "
Gateway Timeout

The gateway did not receive a timely response from the upstream server or application.
Apache Server at dev.fayeprive.com Port 443
but message before was that modules/files were updated
 

----------------------------------------

Après upgrade:

- Nous avons accès au back office en mode debug uniquement et aucun message d'erreur n'apparait sur le serveur (error_log)

- Site web marche correctement

..mais pas d'accès back office debug mode OFF.

 

Merci pour vos suggestions.

Share this post


Link to post
Share on other sites

Bonjour,

 

j'ai exactement le même problème en 1.7.1.1, impossible d'accéder au BO si je ne suis pas en mode debug, et aucun message d'erreur n'apparaît. 

 

Que faire pour comprendre l'origine du problème ? 

 

Merci pour les conseils

Share this post


Link to post
Share on other sites

Impossible de savoir et en l'absence d'un module d'upgrade fiable, nous avons dû refaire une installation complète de la 1.7.1.2 sans le module.

Share this post


Link to post
Share on other sites

Bonjour,

 

Essayez de vider manuellement le cache de Prestashop en supprimant les dossiers "dev" et "prod" dans le dossier app >> cache de votre boutique.

Edited by Divine (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Petite précision, sur la 1.7.5.1

Allez dans /votre_site/var/cache puis supprimer le repertoire ''prod''

Thanks Divi😎

Share this post


Link to post
Share on other sites
On 6/29/2019 at 1:56 AM, Tchedem said:

Petite précision, sur la 1.7.5.1

Allez dans /votre_site/var/cache puis supprimer le repertoire ''prod''

Thanks Divi😎

Bonjour, 

Quand vous écrivez supprimer le repertoir "prod" c'est tout le dossier ? 

 

Share this post


Link to post
Share on other sites
1 hour ago, HugoSPT said:

Bonjour, 

Quand vous écrivez supprimer le repertoir "prod" c'est tout le dossier ? 

 

Oui et dès que vous rechargerai votre page, il sera recréé.

Share this post


Link to post
Share on other sites
On 10/16/2019 at 5:43 PM, Tchedem said:

Oui et dès que vous rechargerai votre page, il sera recréé.

Merci ! Cela à fonctionner. Cependant après l'installation d'un module permettant d'afficher une carte j'ai une de nouveau une erreur 500 et votre méthode n'a pas fonctionné j'ai donc mis en place le mode debug et je ne comprend pas comment corrigé l'erreur ce dernier m'affiche cela

FatalThrowableError

in classes/Dispatcher.php (line 195)

     */

    public static function getInstance()

    {

        if (!self::$instance) {

            

          self::$instance = new Dispatcher();

        }

        return self::$instance;

    }

    /**

DispatcherCore::getInstance()in admin429x4zlfv/index.php (line 99)

    if (!headers_sent()) {

        header('Content-Type: text/html; charset=utf-8');

    }

    // Prepare and trigger LEGACY admin dispatcher

    Dispatcher::getInstance()->dispatch();

}

Je suis sous prestashop 1.7.4.3 que dois je faire ? 

merci pour votre retour

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More