Jump to content

Recommended Posts

Bonjour

Je reçois depuis 2 jours des centaines de mail spam chinois , c'est un robot reglé toute les 2 et 5 minutes.
Je n'arrive pas à stopper le phénomène.

J'ai testé:

 

Suppression du module "Envoyer à un ami", apparemment à une époque il passait par là--> sans résultat

Blocage du fichier contact-form.tpl mais ça continue il ne passe pas par la non plus--> sans résultat

 

C'est des adresses en qq.com ou 1234.com

 

Si vous avez une solution à me proposer ?

D'avance merci

Fred

 

Share this post


Link to post
Share on other sites

Quelle version de Prestashop?

As-tu physiquement supprimé (pas renommé sendtoafreind.old ou _sendtoafriend ou autre) ce module?

Analyse tes logs d'accès serveur pour connaitre la vraie origine dans le code

Share this post


Link to post
Share on other sites

Bonjour,

 

J'ai le même soucis, en analysant les logs je vois ça : 

112.199.65.66 - - [19/May/2017:10:05:07 +0200] "POST /contactez-nous HTTP/1.1" 200 23026 "http://xxx.escapade-petillante-et-gourmande-en-champagne.com/contactez-nous" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.133 Safari/537.36"

 

L'ip en question semble être en chine, j'ai bien sur masqué l'url

 

@Amerigeau : j'ai justement installé hier le module que vous recommandez sur votre site, mais hélas ça continue (1300 mails cette nuit).

Edited by thomascp (see edit history)

Share this post


Link to post
Share on other sites

J'ai testé le lien que vous donnez Frakkas mais cela n'a pas fonctionné j'ai déjà le reCaptcha en question

Share this post


Link to post
Share on other sites

Nous cela à fonctionné sans probleme il faut bien suivre les 4 étapes.

 

J'avais le module reCaptcha de Amerigeau, il faut bien le supprimer avant de suivre le tuto.

Plus de mail depuis 20 minutes pour moi, nikel :)

Share this post


Link to post
Share on other sites

J'ai tout fait oui mais à la dernière étape, dès que j'upload le fichier conctactcontroler, j'ai une erreur 500, le code ne me parrait pourtant pas mauvais...

Share this post


Link to post
Share on other sites

Il faut enlever la dernière accolade... car elle est déjà présente sur la ligne suivante.

Ca fait deux accolades à la suite d'où l'erreur 500.

  • Like 1

Share this post


Link to post
Share on other sites

Haaaa ! effectivement ça fonctionne mieux comme ça ;) Je vais voir mais pour l'instant ça semble se calmer !

Share this post


Link to post
Share on other sites

Bonjour,

 

As-tu un antispam sur ton formulaire de contact ?

Si non, tu peux tester ceci, c'est un tuto gratuit pour ajouter un captcha sur le formulaire de contact : http://arnaud-merigeau.fr/add-recaptcha-to-prestashop/

 

Bon courage :)

 

Il semble qu'il manque la vérification du captcha dans le fichier contactcontroler dans votre tutoriel, vous pourriez le faire évoluer ?

Share this post


Link to post
Share on other sites

Naturellement on fait ça dans un override et pas à la barbare si c'est pour tout recommencer après  :ph34r:

Share this post


Link to post
Share on other sites

Naturellement on fait ça dans un override et pas à la barbare si c'est pour tout recommencer après  :ph34r:

 

+1 évidement !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More