Jump to content
JavierEsK

Problema en formulario Administración

Recommended Posts

Hola a tod@s estoy tratando de hacer algo que debería ser fácil, pero no hay manera de que me salga el siguiente formulario en AdminPPreferences:

 

$optionsol = array();
foreach ($result as $ley => $product)
{
 $optionsol[] = array(
    "id" => (int)$product['id_product'],
    "name" => $product['name']
 );
}
Devolviendo correctamente el array:
Array
(
    [0] => Array
        (
            [id] => 100
            [name] => Ejemplo 1
        )
    [1] => Array
        (
            [id] => 101
            [name] => Ejemplo 2
        )
)

 

Pero cuando supuestamente llama a esta parte:

 

'PS_PRODUCT_LIST_GIFT' => array(
'title' =>  $this->l('List products of gift.'),
'type' => 'checkbox',
'name' => 'gifts',
//'multiple' => true,
'values' => $optionsol,
),
 
Lo que se carga es solamente:
"List products of gift" y no se ve nada más, he probado siguiendo la documentación de prestashop, y nada, también he probado con un select múltiple y nada, lo único que me muestra son solo selects simples :(
 
Se os ocurre que me estoy saltando?
 
Gracias de antemano.

Share this post


Link to post
Share on other sites

Me respondo a mi mismo.

Hacer un select múltiple es imposible:

\administracion\themes\default\template\helpers\options\options.tpl solo viene preparado para select simples.

Checkbox si es posible, cargando los valores con la opción 'choices'.

 

Ahora el problema que tengo es que los checks que se crean tienen el mismo nombre, y por tanto tampoco sirve para nada. :(

 

A alguien se le ocurre como podría hacer esto?

Edited by JavierEsK (see edit history)

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More