Jump to content
orfevre

php 6 ou 7 compatible avec prestashop 1.3 ?

Recommended Posts

Bonjour,

J'ai des sites prestashop 1.3.1.1 qui fonctionnent très bien et dont je suis satisfait.

Le problème c'est que j'ai forcé la version php au 5.4 sur mon hébergement jusqu'à présent.

Je vais bientôt devoir passer aux versions supérieures notamment la version php 7 ou déjà 6 ce serait bien.

Cela va-t-il créer des bugs ? Est-ce que prestashop 1.3 est compatible avec php 7 ou 6 ? Est-ce risqué ?

Merci pour votre aide.

Share this post


Link to post
Share on other sites

Si tu arrive a passer en PHP6, c'est que tu es très fort. Elle n'existe pas.

PHP7 sera incompatible avec les version PS < 1.7 donc, il te faut installer plusieurs version de PHP sur ton serveur pour faire cohabiter tout le monde.

 

En ce qui concerne PS 1.7, appelons un chat un chat, c'est juste de la bouze alors reste en dehors de ça.

 

Pourquoi changer une équipe qui gagne?

Share this post


Link to post
Share on other sites

Ah oui effectivement ! Je suis à php 5.4 et la dernière version avant la 7 c'est php 5.6, j'avais pas regardé désolé !

 

Et si l'hébergeur force le passage de ses hébergements en php 7 ? Mon hébergeur planethoster passe tous ses hébergements en php 7. Je crois qu'au début on pourra forcer la version de php applicable dans son cpanel mais un jour ou l'autre on ne pourra plus et là on n'aura plus le choix.

 

L'autre raison que je vois de changer de version de prestashop ce sont les risques de hacking, je me suis fait hacker les sites avec les failles de sécurité bien connues des vieux presta et je paie maintenant un prestataire externe qui sécurise mon site mais ça a un coût.

Share this post


Link to post
Share on other sites

Il n'y a eu aucun hacking à l'oeuvre qui concernait le coeur de Prestashop. Jamais depuis la 1.4.5.0 et ce n'etait pas a proprement parler un hacking.
Tous les sites hackés à ce jour, sont la suite du déploiement de thèmes/modules ne faisant pas ou prou cas de la sécurité.

 

Si tu connais une faille de vieux Presta en dernière stable de chaque branche, je suis tout ouie.

 

Si ton hébergeur te force à changer de version, changes-en. Prestashop 1.5 et 1.6 fonctionnent parfaitement en PHP5.6 qui est supporté par Zend jusqu'en Décembre 2018. Prestashop 1.4 demande 2/3 modif mineures pour fonctionner en 5.6. Quelques autres modif mineures pour Prestashop 1.3 et 1.2

 

Si tu t'es fait hacker, cela ne peut être que l'oeuvre de mauvaise pratique d'un coté, et de modules boiteux de l'autre. Changer de version t'obligera à analyser le code et le sérieux des nouveaux modules que tu déploiera également.

Share this post


Link to post
Share on other sites

Tu as du temps devant toi avant que PHP 5.6 ne soit plus supporté/proposé par ton hébergeur.

Et même après ça tu pourrais encore migrer les sites sur un VPS ou un dédié sur lequel tu pourrais toi-même installer les versions de PHP que tu souhaites.

Share this post


Link to post
Share on other sites

Je vous remercie pour toutes ces réponses, me voilà rassuré ;-)

Mes sites sont très bien comme ils sont et je ne souhaitais pas en changer donc c'est parfait si j'ai encore le temps.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More