Jump to content
laurentbri

[résolu] Problème d'affichage du prix avec déclinaisons suite installation nouveau template

Recommended Posts

Bonjour à tous,

 

Tout d'abord, merci pour l'énorme travail réalisé sur ce forum, et qui m'a sorti de nombreuses fois de situations désespérées !! :D

 

Je fais face actuellement à un problème que je n'arrive pas à résoudre. J'ai regardé plusieurs sujets qui traitent d'un problème similaire, mais aucune solution proposée n'a pu en venir à bout...

 

J'ai installé un nouveau thème, et suite à son installation, le prix d'un produit avec déclinaison ne se met pas à jour sur la fiche produit lorsque les options sont sélectionnées > en revanche, le prix panier est bon, le problème vient a priori de l'affichage. Je précise également que lorsque je repasse sur le thème précédent, tout marche parfaitement > donc a priori, on est bien au niveau du template.

 

J'ai essayé diverses solutions proposées au niveau des fichiers : product.tpl, ProductController.php (a priori pas concerné ?), et product.js

 

Quand j'ouvre le product.js et que je le compare à celui du template précédent, je vois bien qu'il y a des différences, mais cela ne semble avoir aucun impact.

 

Avez-vous s'il-vous-plaît des pistes :/ ?

 

Encore un grand merci pour votre aide.

Edited by laurentbri (see edit history)

Share this post


Link to post
Share on other sites

surement un thème incompatible.

product.tpl, product.js, ...

 

Quelle est ta version exacte de prestashop? Rapproche toi du développeur du thème pour lui demander si la version est testée/supportée.

 

Il peut également arriver qu'un crash js empèche la mise à jour des prix.

Activer la console du navigateur et pister les éventuelles erreurs

Share this post


Link to post
Share on other sites

Bonjour, merci beaucoup pour votre réponse !

 

J'ai "réussi" à m'en sortir en réinstallant le thème, qui était irréprochable à la base. J'avais un peu mis le bazar dans le product.tpl ^^ Donc tout est rentré dans l'ordre  

Incapable en revanche de vous dire exactement pourquoi, très certainement des balises un peu malmenées  :rolleyes:

 

Merci encore !

Edited by laurentbri (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More