Jump to content
Hervé_Qc

Activez l'option PHP "allow_url_fopen" + Cannot get catalog data...

Recommended Posts

Bonjour,

 

je viens de faire une nouvelle installation de PS 1.7.1.1 et j'ai les deux problèmes suivants:

 

Vérifiez votre configuration

Paramètres requis : ok

Paramètres optionnels : Veuillez consulter la/les erreur(s) suivante(s)

    Activez l'option PHP "allow_url_fopen" sur votre serveur.

 

Cette option est pourtant activée ''On'' dans le fichier php.ini (/home/xxxx/etc/php.ini, et dans la racine du site PS). Ne voyant pas de changement dans le message d'erreur j'ai ajouté un autre fichier php.ini à la racine du site avec l'option. Rien n'y fait de même qu'avec le fichier htaccess : SetEnv ALLOW_URL_FOPEN 1

 

Le deuxième problème est ce message d'erreur lorsque je sélection les Modules:

Cannot get catalog data, please try again later. Reason: Data from PrestaShop Addons is invalid, and cannot fallback on cache

 

J'ai parcouru les messages du forum et les deux sujets semblent être liés, or tant que je n’arrive pas à régler le premier problème, le second existera aussi longtemps.

 

Je me demande alors ce que je manque pour que l'option "allow_url_fopen" soit prise en compte.

 

Quelqu'un a une idée ? Merci !

Edited by Hervé_Qc (see edit history)

Share this post


Link to post
Share on other sites

Re-bonjour,

 

ce problème de ''Activez l'option PHP "allow_url_fopen" sur votre serveur.'' fait que je ne peux me connecter à la Market Place Addons depuis le BO !

 

Suis-je le seul à avoir l'option activée et que PS ne le détecte pas ?

Share this post


Link to post
Share on other sites

Re,

 

je vois que personne n'a encore répondu, sans doute pas de solution viable. Je me suis amusé à refaire une installation 'from scratch' avec les paramètres essentiels, rien n'y fait, PS1.7.1 ne veut rien savoir de cette option!

Je pense que d'ici 24h j'abandonne pour ...

post-1389457-0-70930500-1494366609_thumb.jpg

Share this post


Link to post
Share on other sites

Bonjour,

 

j'avoue que faire le support de la 1.7 est juste inimaginable puisque celle-ci est tellement buggé et comporte tellement de régressions que l'on attend simplement qu'elle soit viable un jour.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More