Jump to content
Weec

Problème de référencement...

Recommended Posts

Bonjour tout le monde,

 

Je suis infographiste print et web, je pratique également et accessoirement le référencement, le plus souvent pour des sites vitrines ou j'obtiens de bon résultats, mais avec Prestashop c'est une autre affaire ! 

 

Malgré le remplissage des balises meta, d'éviter le duplicate content, de travailler l'ergonomie du site (pour les couleurs je tient à préciser que c'est mon client qui à voulu celle-ci :huh: ), d'enregistrer mon site dans Google Tools, dans les principaux moteurs de recherche, de demander des explorations par le robot Google, et malgré les mises à jour incessante de mon client, rien ne prend.

 

J'ai constaté quelques erreurs dont j'aimerais que l'on éclaire ma lanterne...

 

1. J'ai enregistré dans Google Tools deux versions (alors qu'il n'y a qu'un seul domaine) : http://www.cinematograffiche.com et http://cinematograffiche.com/fr/   -   question : laquelle est la bonne pour Google Tools ?

 

2. Pour www.cinematograffiche.com, quand je demande l'indexation, Google m'alerte d'une redirection et je ne parviens pas à savoir laquelle...

 

3. Pour http://cinematograffiche.com/fr/,  quand je demande l'indexation, Google m'alerte d'une indexation partielle.

 

4. Dans Google Tools, Google m'informe que seule la page d'accueil du site est référencée et pas tout le reste... 

 

Je mets quelques captures d'écran de ce que je dis car je pense que le problème se situe la, je sais que tout ça peut paraître confus mais je pars dans tous les sens pour au final ne rien faire de concret, quelqu'un pourrait m'aider un peu ?  :rolleyes:

 

Merci d'avance  B)

post-1298275-0-46095800-1493225683_thumb.jpg

post-1298275-0-41799200-1493225689_thumb.jpg

post-1298275-0-26530000-1493225694_thumb.jpg

Share this post


Link to post
Share on other sites

Si le référencement se limitait à une indexation et inscription aux moteurs de recherche, ça se saurait... ;)

 

Point 1. https://www.google.fr/search?hl=en&safe=off&q=site%3Acinematograffiche.com&btnG=Search&gws_rd=cr > c'est http://cinematograffiche.com/ qui ressort, ça répond aussi au point 2. ( faut le déclarer sans les www), au point 3. (faut demander une indexation sans le /fr) et sans doute au point 4. également.

Share this post


Link to post
Share on other sites

Merci d'avoir pris le temps de répondre  B) Oui c'est sûr que j'ai tellement courut partout qu'à trop vouloir en faire on ne fait pas grand chose de bon...  :rolleyes:

 

J'ai donc ajouter le nom de domaine http://cinematograffiche.com/ dans Google Tools et fait une demande d'indexation pour celui-ci et il me ressort à nouveau un message de redirection. Je sais que les robots Google doivent faire leurs oeuvres mais ne serait-ce pas cette redirection qui me cause problème ?

Share this post


Link to post
Share on other sites

Le temps nous le dira...  -_-

 

C'est quand même pas évident d'apparaître à la page 6 des résultats Google... Au passage une petite astuce auquel je n'aurais pas pensé ?  ^_^

Share this post


Link to post
Share on other sites

Pas une, des dizaines sans doute ! :D

 

Le référencement est un travail de longue haleine qui commence par une optimisation SEO interne irréprochable, je pense que tu as encore du boulot... :)

Share this post


Link to post
Share on other sites

Bon ok j'ai compris... Au boulot !  :D

 

Juste une dernière chose et après j'arrête d'abuser de ton temps, mon client importe beaucoup de produit mais ne change pas le nom des images avant l'import (fichier excel complexe et peu de temps), j'ai par contre acheté un module pour remplir les balises meta de ces image automatiquement (le module reprend le titre produit), cela n'est pas trop grave pour le nom du fichier avant import, les balises meta peuvent suffire à faire le job de référencement pour google images ?

Share this post


Link to post
Share on other sites

ah^^ !

 

Tu parles de la balise Title image donc non, aucun impact sur le référencement/positionnement des images, seule la balise alt rentre en compte.

 

Par contre je vois que ça te fait des urls d'image à rallonge, pas top ça ! :/

http://cinematograffiche.com/140-home_default/-rec-4-rec-quatre-veritable-affiche-de-cinema-pliee-format-120x160-cm-de-jaume-balaguero-avec-manuela-velasco-paco-manzanedo-hec.jpg

Edited by Presta_SEO (see edit history)

Share this post


Link to post
Share on other sites

...  <_<

 

Du coup pour remplir les balises ait ça se passe ou ?

 

J'ai vu cette astuce mais est-ce que ça va prendre en compte les produits déjà crée :

 

Ce que j'ai fait perso et que tu peux faire aussi sur 1.5.6.2, je demande à la balise alt d'utiliser directement le nom du produit, ça évite de le mettre à chaque fois et ça fonctionne à 100%

 

dans le thème/product.tpl, vers la ligne 206, remplacer :

 

<a href="{$link->getImageLink($product->link_rewrite, $imageIds, 'thickbox_default')}" rel="other-views" class="thickbox{if $smarty.foreach.thumbnails.first} shown{/if}" title="{$image.legend|htmlspecialchars}">

 

PAR :

<a href="{$link->getImageLink($product->link_rewrite, $imageIds, 'thickbox_default')}" rel="other-views" class="thickbox{if $smarty.foreach.thumbnails.first} shown{/if}" title="{$product->name|escape:'htmlall':'UTF-8'}">

 

En fait on remplace :

 

{$image.legend|htmlspecialchars}

 

PAR :

 

{$product->name|escape:'htmlall':'UTF-8'}

 

Du coup ça va chercher le titre du produit à la place de la légende "

Share this post


Link to post
Share on other sites

J'ai trouvé la solution sur un autre post, dans Prestashop 1.6.1.6 les balises alt des images sont automatiquement remplies.

 

Mais par contre j'en suis à implorer la pitié car mon site : http://cinematograffiche.com/fr/

 

A volé en éclat dans les résultats de recherche Google, en gros je n'arrive pas ç trouver son positionnement et je ne parle même pas des images qui sont référencées à 1/20 éme (3026 produits pourtant)... 

 

J'ai vraiment l'impression qui a un truc qui colle pas à la normale pour le coup... Un paramètre ou quelque chose dans ce genre non ?   :huh:

Share this post


Link to post
Share on other sites

Quelqu'un à l'horizon ?  ^_^

Share this post


Link to post
Share on other sites

Sur quelles requêtes principalement ?

 

Une chose est sûre, si l'optimisation SEO de ton site est à l'image de la Title de la home (et accessoirement de son contenu), c'est tout à fait normal :

Affiches de cinémas et photos - Cinematograffiche - Vente en ligne - Cinematograffiche   :angry:

 

Et par pitié, change moi ce favicon^^ ! <_<

Edited by Presta_SEO (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Merci pour la réponse  :)

 

Au final les choses ont évolué (bizarrement), mais au moins ça bouge. Donc quand on tape "vente affiches cinémas", le site sort en première page de Google, mais du moment qu'on enlève les "s" (vente affiche cinéma), le site apparaît en cinquième page.

 

Je ne comprend pas cette balise title vu que j'ai mis uniquement "Affiches de cinémas et photos - Cinematograffiche - Vente en ligne" (image jointe) ?  :huh:

http://hpics.li/5652a1d

 

Et oui j'ai changé le favicon  ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More