Jump to content

Problema al conectarse varios usuarios desde la misma IP (Solucionado)


yeremaya
 Share

Recommended Posts

Hola!

Me he encontrado con un problema muy raro. Estoy utilizando Prestashop 1.6.11. Os describo el problema de forma esquemática para que se entienda mejor.

1. Desde Chrome hago login con un usuario con contraseña. Usuario01

2. Desde Firefox hago login con otro usuario con contraseña. Usuario02

3. Lleno dos carritos con productos diferentes en cada usuario.

4. Cuando confirmo la compra con Usuario02 automáticamente se convierte en el Usuario01 y aparece la lista de la compra de este último.

Tiene pinta de ser algo relacionado con las cookies pero no sé por donde comenzar a indagar. ¿Alguna idea?

Edited by yeremaya (see edit history)

Share this post


Link to post
Share on other sites

Hola!

 

 

 

4. Cuando confirmo la compra con Usuario02 automáticamente se convierte en el Usuario01 y aparece la lista de la compra de este último.

 

Tiene pinta de ser algo relacionado con las cookies pero no sé por donde comenzar a indagar. ¿Alguna idea?

Cuando accedes con el usuario 02, y ves los productos del usuario 01 ¿Te ocurre en todos los navegadores?

 

¿Puedes dejar la dirección de la tienda, para ver si a todos nos pasa lo mismo con tu tienda?

 

De cookies puede ser pero habria que ver..

 

¿En el panel de la tienda tienes seleccionado la opción de recuperar los carritos cuando el cliente abandona la compra?

  • Like 1

Share this post


Link to post
Share on other sites

Gracias por las respuestas. Era un problema del alojamiento. Hablé con ellos y desactivaron un sistema de micro-caché que hacía que apareciera esta anomalía. Ahora ya funciona correctamente. Era un gran problema de seguridad ya que podías ver los datos e información de otro usuario si estos se conectaban desde una misma dirección IP.

 

Saludos!

Edited by yeremaya (see edit history)

Share this post


Link to post
Share on other sites

Gracias por las respuestas. Era un problema del alojamiento. Hablé con ellos y desactivaron un sistema de micro caché que hacía que apareciera este problema. Ahora ya funciona con normalidad. Era un gran problema ya que podías ver los datos e información de otro usuario.

 

Saludos!

Bueno, me alegro de que hayas solucionado el problema, he visto que has pulsado el boton Mark Solved, pero no se te olvide añadir la palabra "Solucionado": https://www.prestashop.com/forums/topic/269515-solucionado-%C2%BFcomo-poner-la-palabra-solucionado-en-el-titulo-del-tema/ al titulo del tema.

 

Un saludo y suerte con la tienda.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More