Jump to content

Recommended Posts

  • 3 weeks later...
  • 4 weeks later...
  • 2 months later...
  • 1 month later...

Please help, how to fix this???? it's worthless with this bug, I gues that the problem is with hosting settings

the same problem with PHP 5.4 and PHP 5.6

 

Also during instalation this come out, and I don't know how to fix this (godaddy linux hosting)...

 

Install and enable the intl extension (used for validators).
Install and/or enable a PHP accelerator (highly recommended).
Set short_open_tag to off in php.ini*.

 

 

 

Share this post


Link to post
Share on other sites

You cannot run Prestashop 1.7. with php 5.4 You need at least php 5.6.30. There is no need for accelerators, in contrary, best is the use of fpm-php + opcache + fast-cgi + ngnix proxied.

 

Here the best configuration for Prestashop 1.7.

 

  • magic_quotes_gpc = off
  • memory_limit = 512M
  • max_execution_time = 300
  • max_input_time = 300
  • upload_max_filesize = 20M
  • post_max_size = 20M
  • max_input_vars = 10000
  • allow_url_fopen = on - with that you. can import images and other accesses externally
  • safe_mode = off
  • cURL - installed for you for example. Paypal and other web services work without problems.
  • mod_rewrite = installed and activated
  • mod_security = off
  • at least php 5.6.x + php-fpm + opcache with its own values (see below), or else php 7, it works faster.
  • mySQL 5.5 or higher
  • JSON = ON
  • ctype = ON
  • mySQL = INNODB (myIsam does not work correctly)
  • php.ini from the server must include the date.timezone
  • Open SSL 1.2 or higher
  • (Prestashop is not recommended on Windows servers)
  • cageFS and another FIREWALL technique installed on the server configured correctly so that the back-office is not slow by blocking external services that Prestashop uses. If in doubt, or back-office slow, please ask the provider of your accommodation if there are firewalls installed !!!

 

Opcache optimization:

    opcache.revalidate_freq = 0
    opcache.validate_timestamps = 0 (comment this out in your dev environment)
    opcache.max_accelerated_files = 7963
    opcache.memory_consumption = 192
    opcache.interned_strings_buffer = 16
    opcache.fast_shutdown = 1

In addition, it is important to have automatic permissions to create / change / delete folders and files (mod suExec / suPHP). Thus take care that all internal scripts and users (from inside the server) will have full access to folders and files automatically, while external accesses have read-only access, without the need to change these parameters manually.

  • Like 1

Share this post


Link to post
Share on other sites
  • 5 months later...

I've solved my situation. My problem was php.ini configuration. For some reasons, my configuration was been changed, not by me. Now it's ok. Now, i would solve error http 500, when i try to modify a product or i try to add a new product, but it's another problem.

 

Share this post


Link to post
Share on other sites
  • 1 month later...

hi guys,

I've faced the same problem and was nearly frustrated and was almost to change it into another e-commerce platform.

I host my web on GoDaddy shared hosting.

I've tried to do several suggestions available such as:

Sadly, none of them works, except for the last one BUT especially for the last one, it inconsistently works, at first it works, but when I did click some other menus (back office) and then I revisit to click the product menu, it behaves as before.

 

You know what the real problem is? the Prestashop that I used suckss....

Previously I used prestashop_1.7.3.1

BUT when I upgraded into prestashop_1.7.3.2 It works as smooth as my ass..

 

Good Luck

 

Edited by nasolusi (see edit history)

Share this post


Link to post
Share on other sites
  • 2 months later...

I have exactly the same problem. I just downloaded a new install of Prestashop yesterday, installed onto my godaddy Linux deluxe hosting, created a new database and built it. Cannot add products to the catalogue and cannot view the modules catalogue, and so cannot install the paypal module, which is critical.

The obvious common thread is Godaddy. But that's just a hosting platform that runs millions of commercial web sites. The problem is with prestashop. No one is able to say why this error (and lots of other errors I have encountered in the last 24 hrs) happens with prestashop. It is really dodgy and full of bad coding that requires extensive debuggerising, fiddling and researching just to make it work. The guys who built it may be clever but not at all smart. 

An error message such as "No input file specified" simply SHOULD NOT HAPPEN. It shows that the programmer had no idea what he was doing and had no understanding of how to deal with an inconsistency.

Can anyone say why this error occurs and how, 100%, to fix it?

I also cannot create product categories (or products). I get this error message: "The link_rewrite field is invalid." What the heck does that mean? That is a totally meaningless message.

This is my second attempt to install prestashop and so far it has been a dismal failure. Better to spend $300/year and go to Wix than to spend days and weeks trying to debug someone else's dodgy code.

Edited by Terrysmith56 (see edit history)

Share this post


Link to post
Share on other sites
  • 5 months later...

Приветствую, столкнулся с такой же проблемой "No input file specified", у меня она возникала при скачивании pdf-счета в Истории заказов.

Решил проблему одной строчкой в настройках nginx.conf в параметре location ~ \.php$ { добавил вначале строчку try_files $uri $uri/ /index.php?$args;

Весь код в параметре у меня выглядит так:

Quote

location ~ \.php$ {
    
        try_files $uri $uri/ /index.php?$args;   #Вот эта строка мне помогла избавиться от ошибки
        
        fastcgi_cache_valid 200 60m; # Only cache 200 responses, cache for 60 minutes
        fastcgi_cache_methods GET HEAD; # Only GET and HEAD methods apply
        
        fastcgi_split_path_info ^(.+\.php)(/.+)$;
        fastcgi_pass unix:/run/php/php7.0-fpm.sock;
        fastcgi_index index.php;
        include fastcgi_params;
        
        fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
        fastcgi_intercept_errors off;
        fastcgi_buffer_size 16k;
        fastcgi_buffers 4 16k;
    }

 

Share this post


Link to post
Share on other sites
  • 2 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More