Jump to content
Muscle_Shoals

Funktioniert PrestaShop mit der aktuellsten php Version 7.xx

Recommended Posts

Guten Abend,

ich möchte heute bzw. spätestens Morgen Presta Shop installieren und befasse mich als Anfänger mit der Frage ob PShop mit der aktuellsten php Version auf dem Server harmoniert. Ich hatte neulich ein Dilemma mit meinem Forum, dass ich seit Jahren nicht mehr aktualisiert hatte und auf Grund der aktuellen php Umstellung bei meinem Host nicht mehr richtig funktionierte. Möchte jedenfalls die Pshop installation so anlegen, dass sie möglichst lange funktioniert.

 

Update: Habe Prestashop 6.1.11 installiert und dabei die php Version in meinem Server admin Bereich auf die lezte 6er php Version gestellt. Der Mitarbeiter beim Hosting Service meinte, dass php 7,0 und 7,1 für Presta Shop nicht empfohlen ist.

Edited by Muscle_Shoals (see edit history)

Share this post


Link to post
Share on other sites

Also.... PHP6 wäre mir neu.... :)

 

Der Presta 1.6.1.x läuft mit der PHP 7.0.xx stabil und gut. Für den Betrieb mit 7.1.xx müssten kleine Änderungen gemacht werden, das Problem dabei ist aber, dass unter Umständen da auch diverse Module nicht damit laufen und geändert werden müssten.

Share this post


Link to post
Share on other sites

Aha, interessant. Ich habe heute Morgen auf  1.6.1.10 installiert nachdem mir diese Version als stabiler als  xx.11 empfohlen wurde. Gut zu wissen, dass es mit 7.0 auch gut läuft. dann  hat man etwas Zeit nach hinten bis es wieder angepasst werden muss.

Share this post


Link to post
Share on other sites

Jo, eventuell kommt ja noch ein Workaround für 1.6, der dann die letzte kleinen 7.1-Inkompatibilitäten beseitigt. Es sind im Prinzip nur ein paar kleinere Codeänderungen nötig, dann läuft der Default-Shop. Allerdings ist es eben nicht sicher, dass alle Module damit klarkommen.

Share this post


Link to post
Share on other sites

Bessern die Module Entwickler diesbezgl. nach oder muss man aktuellere Versionen extra bezahlen? Hängt vermutlich vom Entwickler ab und wie so oft gibt es den einen oderanderen Entwickler gar nicht mehr. Wie ist da die Tendenz bei den Modulen?

Share this post


Link to post
Share on other sites

Das ist ganz verschieden. Viele Modulhersteller werden versuchen, den Code "zukunftsfähig" zu halten, die Inkompatibilität entsteht ja nicht so ganz plötzlich, beim Release neuerer Versionen werden auch Infos gegeben, welche Änderungen bei künftigen Releases kommen werden, dann haben die Coder Zeit, ihre Sachen anzupassen.

Share this post


Link to post
Share on other sites

Hier habe ich bisher überwiegend die Empfehlung gelesen, bei PHP 5.6 zu bleiben. Zumindest wenn eine einfache Rückkehr zur alten PHP-Version nicht möglich ist, wäre ich mit PHP 7 vorsichtig, vom Provider ist nach dessen Aussage sicher auch keine Unterstützung zu erwarten.

Share this post


Link to post
Share on other sites

Hallo Claudiodool,

 

welche Codeänderungen sind notwendig? Ich hoste meinem Shop bei einem Bekannten udnd er hat auf php 7.1 geändert. Nun habe ich keinen zugriff mehr.

 

Kann ich die Codes manuell an einer Datei per ftp ändern?

 

In welcher Datei muss ich was ändern?

 

Danke

Share this post


Link to post
Share on other sites

welche Codeänderungen sind notwendig? Ich hoste meinem Shop bei einem Bekannten udnd er hat auf php 7.1 geändert. Nun habe ich keinen zugriff mehr.

Du hängst dich an einen alten Thread an, verrätst mit keinem Wort, welche Shopversion du hast (ggf. wäre die Frage, ob du updaten kannst) und auch nicht, ob du PHP-Profi bist (nur würdest du dann diese Frage wohl nicht stellen) ... Es gibt einzelne Probleme mit PHP 7, zu denen du hier eine Lösung findest, dazu müßtest du aber mehr schreiben als "kein Zugriff" (Fehlermeldung bei aktiviertem Error Reporting? ...).

Share this post


Link to post
Share on other sites

Wir haben jeweils zwei bis drei major PHP-Versionen parallel installiert. Bei unerwarteten Schwierigkeiten können wir so schnell auf den Vorgängerzustand zurückwechseln.

 

Problem hier evtl. mycrypt in den Performance- Settings. Nur eine Vermutung, da Details zum Problem fehlen.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More