Jump to content

Friendly URL:


nonu
 Share

Recommended Posts

Hi this is nonu,

I have done every thing what i can do more i don't know, i want to chage simple url's to friendly urls ii have changed thessess file and permsion to 777 but after this chage urls, working on my local but not working online

waiting for your response.

Share this post


Link to post
Share on other sites

You shouldn't use chmod 777. You should use chmod 755 for directories and chmod 644 for files (except .htaccess and robots.txt, which should be chmod 666). Then you should be able to go to the Preferences tab and change "Friendly URL" to "Yes", then go to Tools > Generators and click "Generate .htaccess file".

Share this post


Link to post
Share on other sites

Hi,

Thanks for your response i have changed the file permission to 755 for directories and 644 for .htaccess and reobts.txt and also changed Friendly URL” to “Yes” in admin section under Preferences but the seo friendly urls not working please check this link "" and this is the path where we can check the php settings "

the code for .htaccess is


code for .htacess
----------------------------------------------------------

# .htaccess automaticaly generated by PrestaShop e-commerce open-source solution
# http://www.prestashop.com - http://www.prestashop.com/forums

# URL rewriting module activation
RewriteEngine on

# URL rewriting rules
RewriteRule ^([a-z0-9]+)\-([a-z0-9]+)(\-[_a-zA-Z0-9-]*)/([_a-zA-Z0-9-]*)\.jpg$ /img/p/$1-$2$3.jpg [L,E]
RewriteRule ^([0-9]+)(\-[_a-zA-Z0-9-]*)/([_a-zA-Z0-9-]*)\.jpg$ /img/c/$1$2.jpg [L,E]
RewriteRule ^lang-([a-z]{2})/([a-zA-Z0-9-]*)/([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ /product.php?id_product=$3&isolang;=$1$5 [L,E]
RewriteRule ^lang-([a-z]{2})/([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ /product.php?id_product=$2&isolang;=$1$4 [L,E]
RewriteRule ^lang-([a-z]{2})/([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ /category.php?id_category=$2&isolang;=$1 [QSA,L,E]
RewriteRule ^([a-zA-Z0-9-]*)/([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ /product.php?id_product=$2$4 [L,E]
RewriteRule ^([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ /product.php?id_product=$1$3 [L,E]
RewriteRule ^([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ /category.php?id_category=$1 [QSA,L,E]
RewriteRule ^content/([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ /cms.php?id_cms=$1 [QSA,L,E]
RewriteRule ^([0-9]+)__([a-zA-Z0-9-]*)(.*)$ /supplier.php?id_supplier=$1$3 [QSA,L,E]
RewriteRule ^([0-9]+)_([a-zA-Z0-9-]*)(.*)$ /manufacturer.php?id_manufacturer=$1$3 [QSA,L,E]
RewriteRule ^lang-([a-z]{2})/(.*)$ /$2?isolang=$1 [QSA,L,E]

# Catch 404 errors
ErrorDocument 404 /404.php

-------------------------------------------------------------------

Keenly waiting for your response.

Share this post


Link to post
Share on other sites

Your website looks fine now. I tried entering http://undershirtsmonthly.com/content/4-about-us'>http://undershirtsmonthly.com/content/4-about-us and it works fine. Your website is only going to http://undershirtsmonthly.com/cms.php?id_cms=4'>http://undershirtsmonthly.com/cms.php?id_cms=4 by default though, so it seems as though friendly URL is turned off. You should go to the Preferences tab and change 'Friendly URL' to 'on'.

Also, it seems you have an index.html file that is preventing http://undershirtsmonthly.com/ from working. Unless you have intentionally put the file there to prevent access to your website, you should delete index.html.

Share this post


Link to post
Share on other sites

I have deleted index.html and Friendly URL is on from the back-end, yes entering it works thanks for help so far if you help me more it will solve my problem,

Waiting for your response.

Share this post


Link to post
Share on other sites

Friendly URLs are working on your website. When I check the URLs of the product images, they are friendly URLs. I think the problem is that you have non-friendly URLs hard-coded in some of your modules like the menu module and editorial module. You'll need to manually change those non-friendly URLs to the equivalent friendly URLs.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More