Jump to content
dannylee11

GoDaddy Support fail

Recommended Posts

First off, I just want to say that if anyone here is able to assist me in getting to the root of the problem, I will be greatly appreciative!

​So here goes...

 

We bought our hosting (shared hosting) from godaddy, and used their cpanel to install wordpress on our domain.  They have a built in app on cpanel called "Installatron" that automatically installs the software for you, and configures it. We put up our old site there for now, until I'm able to build our new site.

 

www.redleafasset.com

 

Then I used the same godaddy/cpanel tool to install PrestaShop on our subdomain.  Which is in the sub-folder "shop" under the root/public_html folder.

 

shop.redleafasset.com

 

I have not done much with PrestaShop aside from changing some of the photos and information around.  I like PrestaShop and it integrates well with our Multi-Channel marketing software.  So we are going to keep it!

​So with that decision, we decided to go ahead and get the SSL certificate installed, before I continue development.

​I called godaddy and after being sold the wrong kind of SSL initially, we were instructed to get the correct SSL that would cover our main domain "www." and also our sub-domain "shop."

 

Godaddy told me that since the apps were all done through their cpanel tool "Installatron" that everything is integrated and would be a seamless install, and work right out of the box after the initial setup of the SSL.... No code needed, everything is integrated to their hosting cpanel, and we just need to buy and set it up.

 

I should have known better...

 

Whenever you go to "shop.redleafasset.com", it will not auto-redirect to the "https" url, just stays on "http".

 

Whenever you type in "https://shop.redleafasset.com", it redirects back to the "http" site and is unsecured.

 

So after talking to another person, I was told "Well it should have worked." but here, you may need to copy and paste this code into your .htaccess file, and THEN it will work.  So not a big deal, I copied and pasted this code into the .htaccess file found in the root directory, right underneath the "RewriteEngine On" line:
 

RewriteCond %{HTTPS} off
R e w r I t e R u l e   ^ ( . * ) $   h t t p s : / / % { H T T P _ H O S T } % { R E Q U E S T _ U R I }  [ L , R = 3 0 1 ]   (I added spaces because it kept removing this line from my post for some reason)

 

This did not fix the problem at all... the store will still ALWAYS redirect back to the "http" site and not stay on the "https" site.

 

So I realized that there is another .htaccess file in the "shop" folder under root.  This .htaccess is for prestashop.  So I tried inserting this code into that .htaccess file.... this also failed, but in a different way.  I get an error message talking about too many redirects happening, cannot load the page.  So I removed the code and i'm back at square one.
 

I called godaddy again, and talked to some JA that was rude and short, and refused to help me.  He even went as far as saying he knows what the problem is (even though he was getting help from his "tech specialist") and wouldn't tell me what the problem is because it's outside his scope of support.... wait wasn't I sold this SSL with idea that it would automatically work with everything?  So now that it doesn't they want to wash their hands of it?  Now this godaddy rep wants to shrugs his shoulders and tell me I'm SOL?

​So anyways, here I am, looking for someone to, at the very least, point me in the right direction as to why this will not work.

​I figured maybe I could show you what I currently have in my .htaccess files. and maybe that will help?

​So in our root directory (wordpress install) we have an .htaccess file with the following:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress
 
**One note here, we are not that concerned about securing our main site, there is nothing sensitive that will be transmitted.  We are really only concerned with our shop site, that's at shop.redleafasset.com.

​And the second .htaccess file that is located in the sub-folder "Shop" that's was designated by the PrestaShop install, that reads:
# ~~start~~ Do not remove this comment, Prestashop will keep automatically the code outside this comment when .htaccess will be generated again
# .htaccess automaticaly generated by PrestaShop e-commerce open-source solution
# http://www.prestashop.com - http://www.prestashop.com/forums
<IfModule mod_rewrite.c>
<IfModule mod_env.c>
SetEnv HTTP_MOD_REWRITE On
</IfModule>
RewriteEngine on

#Domain: https://shop.redleafasset.com
RewriteRule . - [E=REWRITEBASE:/]
RewriteRule ^api$ api/ [L]
RewriteRule ^api/(.*)$ %{ENV:REWRITEBASE}webservice/dispatcher.php?url=$1 [QSA,L]
# AlphaImageLoader for IE and fancybox
RewriteRule ^images_ie/?([^/]+)\.(jpe?g|png|gif)$ js/jquery/plugins/fancybox/images/$1.$2 [L]
</IfModule>
AddType application/vnd.ms-fontobject .eot
AddType font/ttf .ttf
AddType font/otf .otf
AddType application/x-font-woff .woff
<IfModule mod_headers.c>
 <FilesMatch "\.(ttf|ttc|otf|eot|woff|svg)$">
  Header set Access-Control-Allow-Origin "*"
 </FilesMatch>
</IfModule>
#If rewrite mod isn't enabled
ErrorDocument 404 /index.php?controller=404
# ~~end~~ Do not remove this comment, Prestashop will keep automatically the code outside this comment when .htaccess will be generated again.
 
So again, this appears to be some sort of redirect issue, and I can't get to the bottom of it, and most of the GoDaddy reps do not seem to know what the issue is as the only thing they have suggested was inserting their code into the htaccess file, that cause a redirect error.
 
Any assistance would be greatly appreciated, and I'm confident there is someone on here that has more smarts and know how than that JA I just spoke to at godaddy
 
Thanks!
 
Edited by dannylee11 (see edit history)

Share this post


Link to post
Share on other sites

I am confused

 

Prestacart is not prestashop

 

So I will assume you do mean prestashop seeing as this is the prestashop forum

 

In the prestashop back office go to Preferences > General and make sure you have enabled SSL

 

Then clear the cache (Advanced Preferences > Performance)

 

And try again (if you are using Google Chrome you will probably need to clearer browser cache as it does tend to hold on to stuff)

 

That should sort out the htaccess file automatically

 

If it does not work try Preferences > SEO

 

Switch on friendly URL and save

 

Then clear cache and try again

Share this post


Link to post
Share on other sites

And yes, this is exactly what it was.... super easy fix for something i've been dealing with all day.  I suppose it's my fault for not diggining into it on this side of things, and just thinking it was some sort of hosting issue.  In my defense they made it sound like everything was just going to magically work once I setup the SSL, and the last rep telling me it was a root htaccess issue...  Thanks a million, haylau!

Edited by dannylee11 (see edit history)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More