Jump to content

Error upgrading to v1.7.1


gray
 Share

Recommended Posts

[Ajax / Server Error for action upgradeDb] textStatus: "error " errorThrown:"Internal Server Error " jqXHR: " "

 

It seems to have downloaded all the files, but gets stuck when upgrading the database.

 

Any ideas plz

Share this post


Link to post
Share on other sites

happened to me from 1.7.0.5 to 1.7.0.6

 

Mucked my database right up thankfully my host backs up the database now and again so rolled back

and didnt have that much work to do.

 

ill stick to 1.7.0.5 for now until people have luck upgrading

Share this post


Link to post
Share on other sites

Done a roll back and that finally crashed with a blank screen. So i now cannot get into admin

you will have to go on your hosts website and see if you got a back up of the database and files im guessing :(

again same happened to me its like wrecking peoples websites

come on prestashop your mucking with peoples livelihood here !

Edited by delboy01 (see edit history)

Share this post


Link to post
Share on other sites

last time that happened - when upgrading from 1.7.0.4 to 0.5

it was then caused by 1 click upgrade

 

i did not upgrade from 1.7.0 to 1.7.1 yet, but make sure you use the latest version of 1 click upgrade.

Share this post


Link to post
Share on other sites

I had succeded upgrade on one of our developing shops, from 1.7.0.6 to 1.7.1.0.

 

90% of the customisation we made on homepage are gone, and the custom theme was reseted on demo state.

 

The theme developers said that they will have to update the theme first, and only after that we shoud make the upgrade.

Share this post


Link to post
Share on other sites

Template related?

 

They said if we make the update to Presta core, before doing the update to template, problems will appear,

because of the fact that 1.7.1.0 has significant modifications from 1.7.0.5.

Share this post


Link to post
Share on other sites

This error is caused by PHP execution time limit.

 

Increase the time limit

 

On php.ini (sample)

max_execution_time = 600

(10 minutes)

 

I also recommend to change others settings:
 

max_input_time = 180
memory_limit = 300M
max_input_vars = 20000

Of course, adjust the values according to your environment.

 

If you are running under FCGI, checkout this topic: https://www.prestashop.com/forums/topic/498947-backoffice-displays-php-code/

Edited by omine (see edit history)

Share this post


Link to post
Share on other sites

I got the same error after upgrading from 1.7.0.6. Then i had to manually delete the cache folder because BO was giving error 500. As it seems the rest is OK but the database is not upgraded. In this state if you try to add new product you will be redirected to dashboard. You also can't edit existing products.

 

I managed to fix it by going to admin folder autoupgrade/latest/install/upgrade/sql/

Then open 1.7.1.0.sql . Then search and replace PREFIX_ with your prefix. Then copy the sql and execute it with phpmyadmin. 

Share this post


Link to post
Share on other sites

Hello

I tried to upgrade from version 1.7.0.5 to 1.7.1 and give me that error.


and I tried uploading files via ftp and enabling in "clik-upgrade" channel "local directory." The files have been updated but then there is error: "error during database upgrade. You may need to restore your database."

Share this post


Link to post
Share on other sites

It does not look like there is any urgent upgrade for this problem, or way of solving this.

 

So I have installed  1.7.1 with no problems.

 

The problem now is how do I best go about exporting data (products and categories) from v1.7.0.5 into v1.7.1

 

I have something like 500 products and v1.7.0.5 does not have an export facility direct from admin, only Advanced Parameters / Database / SQL Manager

Share this post


Link to post
Share on other sites

 

The same problem... But I downloaded the new version of 1-Click from the site and MANUALLY install it.
Successfuly upgraded from 1.7.0.5 to 1.7.1 ))

 

 

Hi APhilipp

Can you give any info on how to you manually upgraded? I see where I can download the files, but what next?

I tried the latest version of 1 click and its not working.

thanks,

Breda

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More