Jump to content
kurtspirit

Problème à la création de compte

Recommended Posts

Bonjour,

 

j'ai un soucis que je ne comprend pas étant débutant dans le domaine...

A la création de compte client sur le site, j'ai un retour d'erreur :

Error - The following e-mail template is missing: account

Si on revient à l'accueil, le login est possible, le compte est bien créé mais cette erreur est agaçante.

 

Avez-vous une idée pour corriger ça? J'ai vachement de problèmes avec la version 1.7, je ne peux ajouter la langue Anglaise par exemple mais bon,on peut dire que c'est secondaire sur le coup...

Là c'est problématique.

Merci à vous par avance.

Share this post


Link to post
Share on other sites

Si tu es en langue fr alors il te manque le fichier mails/fr/account.html

  • Like 1

Share this post


Link to post
Share on other sites

Merci pour le retour rapide.

C'est bizarre l'installation est toute propre, j'ai juste ajouter un thème que j'ai acheté sur presta.

Je vais tout recommencer , c'est peut-être plus judicieux qu'en pensez-vous?

 

Merci !

Share this post


Link to post
Share on other sites

va dans International > Traductions et met à jour la langue Fr, ça va télécharger les mails que tu n'as pas, à mon avis le dossier mails/fr/ doit être totalement vide chez toi

Share this post


Link to post
Share on other sites

Alors pour faire une retour, le problème d'enregistrement de compte est réglé par la réinstallation par contre le soucis de langue persiste.

Il est impossible d'ajouter une langue, lors de l'ajout j'ai droit à une page blanche et idem si le client sélectionne une langue.

Je n'ai aucune idée du pourquoi, je ne suis pas caler pour ça...

Avez-vous une idée?

Merci !

Share this post


Link to post
Share on other sites

De base ou pas. En passant la boutique en debug j'ai ce message d'erreur à la sélection de langue :

Whoops, looks like something went wrong.
1/1 ContextErrorException in FrontController.php line 1559: Notice: Undefined offset: 4in FrontController.php line 1559
at ErrorHandler->handleError('8', 'Undefined offset: 4', '/homepages/38/d562708948/htdocs/test/classes/controller/FrontController.php', '1559', array('address' => object(Address))) in FrontController.php line 1559
at FrontControllerCore->getTemplateVarShop() in FrontController.php line 500
at FrontControllerCore->assignGeneralPurposeVariables() in FrontController.php line 520at FrontControllerCore->initContent() in IndexController.php line 37at IndexControllerCore->initContent() in Controller.php line 201at ControllerCore->run() in Dispatcher.php line 366at DispatcherCore->dispatch() in index.php line 28

Je ne vois absolument pas comment résoudre ça :/ merci pour tout !

 

Idem si je supprime la langue Anglaise admettons dans le BO et que je souhaite l'ajouter :

 

Whoops, looks like something went wrong.
1/1 UndefinedMethodException in atchconfigurator.php line 194: Attempted to call an undefined method named "installFixtures" of class "AtchConfigurator".in atchconfigurator.php line 194at AtchConfigurator->hookActionObjectLanguageAddAfter(array('object' => object(Language), 'cookie' => object(Cookie), 'cart' => null, 'altern' => '2')) in Hook.php line 758at HookCore::coreCallHook(object(AtchConfigurator), 'hookactionObjectLanguageAddAfter', array('object' => object(Language), 'cookie' => object(Cookie), 'cart' => null, 'altern' => '2')) in Hook.php line 723at HookCore::exec('actionObjectLanguageAddAfter', array('object' => object(Language), 'cookie' => object(Cookie), 'cart' => null, 'altern' => '2')) in ObjectModel.php line 539at ObjectModelCore->add(true, false) in Language.php line 172at LanguageCore->add(true, false, false) in Language.php line 843
at LanguageCore::checkAndAddLanguage('en', array('name' => 'English (English)', 'iso_code' => 'en', 'date_format_lite' => 'm/d/Y', 'date_format_full' => 'm/d/Y H:i:s', 'is_rtl' => '0', 'language_code' => 'en-us', 'locale' => 'en-US'), false, null) in Language.php line 1057
at LanguageCore::installLanguagePack('en', null, array()) in Language.php line 942at LanguageCore::downloadAndInstallLanguagePack('en', '1.7.0.6', null, true) in AdminTranslationsController.php line 908at AdminTranslationsControllerCore->submitAddLang() in AdminTranslationsController.php line 1502at AdminTranslationsControllerCore->postProcess() in Controller.php line 190at ControllerCore->run() in Dispatcher.php line 366
at DispatcherCore->dispatch() in index.php line 95

Merci.

Edited by kurtspirit (see edit history)

Share this post


Link to post
Share on other sites

je ne vois pas de solutions...

 

charge la 1.7.0.6, vide la bdd, ré-installe prestashop en FR, vérifie si mails/fr/ est vide, si oui met à jour la langue dans le back office et ensuite inscrit toi

Share this post


Link to post
Share on other sites

Ah mais en appliquant la mise à jour de la langue FR, j'ai plus d'erreur à l'inscription mais par contre je ne peux pas ajouter de langue à la boutique. J'ai des erreurs cités ci-dessus si j'ajoute une langue :/

Share this post


Link to post
Share on other sites

Moui c'est une solution mais le thème que j'ai acheté est compatible 1.7 et je peux pas me permettre de perdre 100€ comme ça dans le vent...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More