Jump to content

Un point d'interrogation à la place du Favicon sur Safari IOS 10.2.1


 Share

Recommended Posts

Bonjour,

 

Impossible d'afficher le Favicon d'un site dans les favoris du navigateur Safari sur Iphone (copie d'écran en PJ) alors qu'avec Firefox ou Chrome pas de souci.

 

J'ai donc essayé sur d'autres sites qui utilisent la même version de Prestashop à savoir 1.6 et même constat un ? s'affiche au lieu du Favicon du site.

 

Le problème viendrait de la compatibilité de Safari IOS et de la version de Prestashop 1.6 car avec les versions antérieures c'est OK.

 

J'ai même rajouté des lignes dans le code source de mon site: www.paruresdebureau.com, mais rien n'y fait:

 

<link rel="apple-touch-icon" href="/img/icone.png"/>
<link rel="apple-touch-icon" sizes="16x16" href="/img/icone.png"/>
<link rel="apple-touch-icon" sizes="57x57" href="/img/apple-touch-icon-57x57.png"/>
<link rel="apple-touch-icon" sizes="57x57" href="/img/icone.png"/>
<link rel="apple-touch-icon" sizes="72x72" href="/img/icone.png"/>
<link rel="apple-touch-icon" sizes="114x114" href="/img/icone.png"/>

 

Merci de votre aide.

 

 

 

 

post-998476-0-32845500-1489774021_thumb.jpg

Share this post


Link to post
Share on other sites

Bonjour,

Non, ce problème n'est pas encore solutionné,

Je m'en remets aux développeurs de Prestashop qui s'ils lisent mon message pourront apporter une solution que nous sommes nombreux à attendre.

Share this post


Link to post
Share on other sites

  • 1 year later...

Hello :)

Je relance ce sujet car je rencontre le même problème.

L'outil Realfavicon ne détecte aucune anomalie pour iOS et pourtant : point d'interrogation sur safari sur iOS en signet/favoris (je précise que l'icône d'ajout à l'écran d'accueil fonctionne correctement) :

https://realfavicongenerator.net/favicon_checker?protocol=https&site=www.decome-store.fr%2F#.W1g5jdUzaUm

De ce que je comprends, s'il n'y a pas de favicon, safari iOS affiche la première lettre du title en carré sur un fond de couleur. Or, s'il affiche le point d'interrogation, c'est qu'il trouve l'image/l'icône mais ne parvient à l'afficher. J'ai beau chercher, je n'en trouve pas la raison, quelqu'un aurait une idée ?

Image-1.jpg

Edited by decome2013 (see edit history)

Share this post


Link to post
Share on other sites

  • 4 months later...

Bonjour à tous,

Je viens de passer des heures à chercher d'où peut provenir le problème sans trouver de solution... C'est dingue quand même, j'utilise les mêmes syntaxes sur tous nos thèmes sur différents CMS et je n'ai absolument aucun problème ! Le souci n'est que présent sur Prestashop (testé sur 1.6.1.13) et en plus uniquement pour l'ajout en favoris sur Safari iOS, si on veut ajouter le site à l'accueil sur iPhone/iPad l'icône apparaît bien. Je n'arrive pas à comprendre qu'elle est la chose qui peut générer ce genre de réaction dans Prestashop et faire comme si l'image retournait une erreur 404 alors qu'elle est bien présente sur le serveur et quand on l’appelle en direct elle s'affiche bien...
Après une journée de tests complets, vérification des htaccess, réécriture, chemins etc. je confirme que le problème n'est donc pas lié aux thèmes mais vient bien de Prestashop.

A l'aide messieurs les développeurs de Presta ! Vous n'avez aucune piste à nous fournir sur cette réaction vraiment spécifique a Presta ?

Merci d'avance.

 

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Hello,

En fait Prestashop a prévu tout ça en vous suggérant de créer un child theme sur la version 1.7. Pour info, le souci se présentera sur n'importe quel CMS gérant mal ses favicons. Cela ne dépend en fait pas du CMS mais du thème utilisé (bah ouais, en fait c'est votre thème qui affiche le favicon)

Solution Prestashop 1.7 via un child ici =>

Après, avec le nombre d'appareils utilisés, à vous de trouver le meilleur "favicon generator" pour cela.

Concernant Prestashop 1.6, vous avez à disposition des variables pour ajouter peu ou prou tout ce que vous désirez, donc ajouter des favicons, c'est pas la folie non plus... Il faut que vous ajoutiez à la mano dans votre thème les liens vers les bons favicons, avec la bonne syntaxe, tout bêtement.

Liste des variables smarty Prestashop 1.6 :

https://www.team-ever.com/les-variables-smarty-de-prestashop/

Ah, et pensez à vider vos caches, celui de Prestashop comme vos navigateurs 🙂 

Share this post


Link to post
Share on other sites

  • 1 year later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More