Jump to content

Recommended Posts

Интересует вопрос, озвученный на на другом форуме:

 

 

 

 

 

 

 

 

В модуле smartblog столкнулся с интересной проблемой. На локальной машине все работает отлично, а на хосте получаю ошибку: 
Цитата:
PHP Fatal error: Uncaught Error: Class 'BlogCategory' not found in /home/users/xxxxxxxxx/classes/controller/AdminController.php:1626\nStack trace:\n#0 /home/users/xxxx/modules/smartblog/controllers/admin/AdminBlogCategoryController.php(300): AdminControllerCore->loadObject(true)\n#1 /home/users/xxxxx/classes/controller/Controller.php(178): AdminBlogCategoryController->postProcess()\n#2 /home/users/xxxx/classes/Dispatcher.php(367): ControllerCore->run()\n#3 /home/users/xxxxx/adm791/index.html(58): DispatcherCore->dispatch()\n#4 {main}\n thrown in /home/users/xxxxxxx/classes/controller/AdminController.php on line 1626, referer: http://xxxxxxx/adm791/index.html?controller=AdminDashboard&token=e5ac9958e5e5bb85f9a862449c94a573

Не очень понимаю откуда ноги растут. Файл BlogCategory.php на месте, контент в нем на месте, права на файл выставлены нормально (644) а до загрузки файла дело не доходит. Остальные файлы работают корректно и находятся без проблем. Посты редактируются ,комментарии к постам открываются. Проблема только с категориями и именно на хосте.

 

 

 

Тоже столкнулся с тем же самым. В результате конечно изголился и подправил loadObject в AdminController таким образом

elseif ($opt) {
  if (!$this->object) {
	if ($this->identifier == 'id_smart_blog_category') {
	 require_once _PS_MODULE_DIR_ . '/smartblog/classes/BlogCategory.php';
	 $this->object = new BlogCategory();
	} else {
	 $this->object = new $this->className();
	}
   }
   return $this->object;
}

и все работает. Но это ведь не по фэншуй. В чем может быть проблема? Преста 1.6.1.9, smartblog свеженький c github, хостин jino.ru, PHP7.0.

Edited by Евгений Медведев (see edit history)

Share this post


Link to post
Share on other sites

  • 4 months later...

у меня такая же беда.

пытаюсь установить 2.1.4 скачаный с гихаба.

например:

не выводит картинки

пытаюсь загрузить в бэкофисе, выдает ошибки админкотролера.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More