Jump to content
Loe-

Vertalingen worden niet weergeven

Recommended Posts

Na 3 dagen proberen is mijn geduld een beetje op..

 

Dit heb ik gedaan :

 

- Alle vertalingen handmatig nagekeken en ingevuld

- Alle modules extra handmatig nagelopen en ingevuld

- Alle vertalingen gecontroleerd, deze zijn correct ingevuld

- De .tpl bestanden nagelopen en handmatig aangepast ( FTP : modules - blockcart - tpl.

(Modules - blockcart - translations - index.php en nl.php geven zeer weinig aan, de benodigde vertalingen staan hier niet bij)

 

ook nagelopen : themes-my themes-modules- blockcart - blockcart.tpl

ook nagelopen : themes - my themes - js - modules - blockcart

 

In de BO staat alles goed.

 

Wie kan mij vertellen hoe ik dit opgelost kan krijgen?

 

Ik heb dit bv ook bij de referral module, 1 gedeelte wel vertaald, de andere helft weigert te vertalen.

Staat goed in de BO.

Ook aangepast in alle .tpl bestanden behorend bij die module.

Module al een paar keer opnieuw geinstalleerd, geen resultaat.

 

 

Bijgevoegd ook een screenshot van public html/url/translations.

post-1334076-0-53817000-1487589885_thumb.png

post-1334076-0-50063400-1487590701_thumb.png

Edited by loetje88 (see edit history)

Share this post


Link to post
Share on other sites

in de map nl heb je daat nl.php instaan ?met alle vertalingen ?

 

eh TPL bestanden staan normaal geen vertalingen in tenzij het hardcoded is 

 

ook vind je vertalingen in je theme ,, kloppen deze ?

 

in je screenshot zie je wel een nl.gzip in de map translations staan dat klopt niet ,

deze kan prestashop niet uitlezen ,,,

dat is een installatie bestand oftewel dat bestand moet je uploaden via je BO

 

indien je wel een nl.php hebt en deze is volledig ,, dan moet je eens je cache en compile legen

Share this post


Link to post
Share on other sites

Heb je wel een Nederlandse versie van prestashop geïnstalleerd?
Heb je in de backoffice bij smarty (Hercompileer templates als de files zijn bijgewerkt) wel aanstaan?

Share this post


Link to post
Share on other sites

in de map nl heb je daat nl.php instaan ?met alle vertalingen ?

 

eh TPL bestanden staan normaal geen vertalingen in tenzij het hardcoded is 

 

ook vind je vertalingen in je theme ,, kloppen deze ?

 

in je screenshot zie je wel een nl.gzip in de map translations staan dat klopt niet ,

deze kan prestashop niet uitlezen ,,,

dat is een installatie bestand oftewel dat bestand moet je uploaden via je BO

 

indien je wel een nl.php hebt en deze is volledig ,, dan moet je eens je cache en compile legen

 

 

Maconl, als ik de goede heb( theme/translations/nl) zie ik nl.php daar niet tussen staan.

De nl.php die ik wel kan vinden zoals in het 1ste bericht,is bij lange na niet compleet, staan misschien 30 dingen in.

 

Wat de GZIP er doet durf ik niet te zeggen, ik ben alleen bang dat als ik deze uitpak en weer op de server zet dat ik weer opnieuw kan beginnen (dat is zo ongeveer de 5de keer dat ik dan alles handmatig doe dus sta niet te springen)..

 

 

Heb je wel een Nederlandse versie van prestashop geïnstalleerd?

Heb je in de backoffice bij smarty (Hercompileer templates als de files zijn bijgewerkt) wel aanstaan?

 

Ja het is een nederlandse versie.

 

Forceer compilatie en cache legen, allemaal al een keer of 10 gedaan.

Staat inderdaad standaard aan, dus tussendoor geswitcht voor alle zekerheid met tussendoor opslaan, staat nu weer aan.

 

Browser ook geleegd, gereset, opnieuw opgestart enz enz.

post-1334076-0-07594600-1487619923_thumb.png

Edited by loetje88 (see edit history)

Share this post


Link to post
Share on other sites

Gelijk in themes gekeken, daar staat inderdaad ook een nl.php bestand, deze is helemaal correct vertaald.

 

 

post-1334076-0-69923000-1487620077_thumb.png

Share this post


Link to post
Share on other sites

de vertaling moet je niet naar je server uploaden maar het bestand moet je via je BO installeren

daarom heb je juist ook overal nog engels

de gzip moet je dus niet via je server installeren !! maar via je BO taal importeren ,,,

 

heb je de originiele template of een ander geinstalleerd ?

indien het laatste dan kan je via je BO de taal van je originele template overzetten naar de ander ,,

 

je geeft aan dat de nl.php compleet is , is dit van de default theme of een ander theme ?

 

indien het cache legen via je bo niet werkt kan je middels ftp je cache legen

hoe je dat doet volg even het linkje in mijn Footer 

Share this post


Link to post
Share on other sites

tussen haakjes vaak kan je ook middels je hosting admin goede backups maken dan hoef je , als het mis gaat niet steeds opnieuw te beginnen

Share this post


Link to post
Share on other sites

de vertaling moet je niet naar je server uploaden maar het bestand moet je via je BO installeren

daarom heb je juist ook overal nog engels

de gzip moet je dus niet via je server installeren !! maar via je BO taal importeren ,,,

 

heb je de originiele template of een ander geinstalleerd ?

indien het laatste dan kan je via je BO de taal van je originele template overzetten naar de ander ,,

 

je geeft aan dat de nl.php compleet is , is dit van de default theme of een ander theme ?

 

indien het cache legen via je bo niet werkt kan je middels ftp je cache legen

hoe je dat doet volg even het linkje in mijn Footer 

 

Maconl,

 

ik heb de GZIP juist via de BO geimporteerd, dan blijven er nog ruim 1100 vertalingen over die ik nu inmiddels zelf vertaald heb en inderdaad allemaal kloppen.

Beide nl.php bestanden zijn INcompleet, er staat maar heel weinig. Heb de nl.php  van default gekopieerd naar mijn eigen thema.

 

Ik gebruik de prestashop theme maker, dus gebasseerd op het default thema, maar met extra dingen zoals eigen kleurtjes,lettertypes, achtergronden enz enz kunnen kiezen.

Overkopieeren van default al een paar keer gedaan, daar vandaan ontbreken er 1100 vertalingen, die dus inmiddels ook aangepast zijn.

In de default staat niks anders dan de originele ps versie 1.6.1.8 en bijbehorend taalpakket (gzip) van hun site(PS) die ik dan geimporteerd heb in default thema, en vanuit de BO dus inderdaad van default naar eigen thema ook nog over gezet.

 

Echter, zoals je ziet blijft een gedeelte gewoon in het engels, terwijl hij in de BO wel nederlands is....

 

** edit : linkje gevonden, bedankt! even proberen **** daarnaast ben ik een beetje dom denk ik.. ik zie je linkje niet....

Edited by loetje88 (see edit history)

Share this post


Link to post
Share on other sites

hmmm..

 

 

Inmiddels via en.php maar even het eea in het nederlands gezet aangezien hij het engelse bestand blijkbaar wel op pakt.. dit lijkt te helpen, 8 van de 10 zijn nu vertaald.

Heb ook even de ache geleegd via ftp, maar..

 

krijg nu in stap 3/4 van bestel proces bijgevoegde foutmelding (zie screenshot)

post-1334076-0-56931500-1487626302_thumb.png

Share this post


Link to post
Share on other sites

je hebt foutmelding aangezet ,, denk ik :-)

 

heb je alleen de cache leeg gemaakt of ook compile ? je moet ze namelijk beide leegmaken ,, behalve index.php die moet blijven staan

Share this post


Link to post
Share on other sites

Zo, even een paar dagen niks kunnen doen wegens een offline server..

 

Maconl, bedankt voor de link, gevonden, en gedaan.

 

Helaas geen oplossing.

 

Uiteindelijk ben ik de engelse bestanden (zoals engels.php) maar gaan vertalen, aangezien hij die wel leek te pakken.

Her en der wat nieuwe bestanden mijn bestanden laten overschrijven van een gedownloade presta, en daar ook in de engelse bestanden maar een nl vertaling gezet.

 

Vooralsnog is het opgelost... maar waarom is mij nog steeds niet duidelijk...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More