Jump to content

[RESOLU]Gros PROBLEME avec PHPmyADMIN !!! MERCI


Recommended Posts

bonjour les amis, voila je voulais protéger mon accès à la base car en bas de la fenetre php my admin il me disait que je pouvais avoir des intrusions car l'utilisateur root n'avait pas de mot de passe.

Du coup j'ai crée un autre utilisateur avec un mot de passe, et j'ai supprimé l'utilisateur root.... et depuis voila ce que ça me fait !!!! j'aurais pas du mettre mon nez la dedans... merci pour votre aide ,ma boutique est presque terminée en plus je dois la mettre en ligne dans moins de 15 jours...

voir pièce jointe.

Alex

25511_rITKAlXVa3J7TMTRPce4_t

Share this post


Link to post
Share on other sites

Bonjour,
Tu travail en local? il faut modifier le fichier c:\tonserver\apps\phpmyadmin\config.inc.php
en mettant les variables suivantes :
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['AllowNoPassword'] = true;

Share this post


Link to post
Share on other sites

les variables sont déjà comme tu me l'a indiquée, voila le fichier config.inc.php:

<?php
/*
* This is needed for cookie based authentication to encrypt password in
* cookie
*/
$cfg['blowfish_secret'] = 'xampp'; /* YOU SHOULD CHANGE THIS FOR A MORE SECURE COOKIE AUTH! */

/*
* Servers configuration
*/
$i = 0;

/*
* First server
*/
$i++;

/* Authentication type and info */
$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['AllowNoPassword'] = true;

/* Server parameters */
$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['compress'] = false;

/* Select mysqli if your server has it */
$cfg['Servers'][$i]['extension'] = 'mysqli';

/* User for advanced features */
$cfg['Servers'][$i]['controluser'] = 'pma';
$cfg['Servers'][$i]['controlpass'] = '';

/* Advanced phpMyAdmin features */
$cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
$cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
$cfg['Servers'][$i]['relation'] = 'pma_relation';
$cfg['Servers'][$i]['table_info'] = 'pma_table_info';
$cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
$cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
$cfg['Servers'][$i]['column_info'] = 'pma_column_info';
$cfg['Servers'][$i]['history'] = 'pma_history';
$cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';

/*
* End of servers configuration
*/

/*
* Directories for saving/loading files from server
*/
$cfg['UploadDir'] = '';
$cfg['SaveDir'] = '';

$cfg['AllowAnywhereRecoding'] = true;
$cfg['DefaultCharset'] = 'utf-8';
$cfg['DefaultLang'] = 'en-utf-8';
$cfg['DefaultConnectionCollation'] = 'utf8_general_ci';

$cfg['MySQLManualBase'] = 'http://dev.mysql.com/doc/refman/5.1/en';
$cfg['MySQLManualType'] = 'searchable';

?>


en fait j'ai supprimé le compte root car j'en ai crée un autre...et c'est suite a cette suppression que j'ai ce message d'erreur

Share this post


Link to post
Share on other sites
accorde tous les privileges a ta nouvelle user et ca doit marcher:
GRANT ALL PRIVILEGES ON *.* TO user@localhost  IDENTIFIED BY ' monmotdepasse ' WITH GRANT OPTION;



excuse moi mais je suis pas super doué, je fais ça comment? merci

Share this post


Link to post
Share on other sites

Pour info je n'arrive plus a rentrer dans phpmyadmin, je bloque sur la page d'erreur (voir tout en haut en piece jointe)

merci pour votre aide !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More