Jump to content
doekia

ATTENTION: module packlink pro NE PAS METTRE A JOUR en 1.6.3

Recommended Posts

Attention addons à encore une fois validé un module sans l'ombre d'un test. ici packlink.

Le couplet gagnant encore une fois réuni addons+202ecommerce

 

Si vous effectuez la mise à jour, Votre BO crash lamentablement sur la page commande (page blanche)

  • Like 3

Share this post


Link to post
Share on other sites

Bonjour,

 

Nous sommes désolés que le module installé pose problème sur votre boutique. Sauf erreur, je n'ai pas reçu de demande de support de votre part via Addons ?

Quel est le message que vous avez eu en activant le mode debug ?

Pouvez-vous m'envoyer un mail de support via la fiche produit de Packlink ?

 

Merci d'avance. 

 

202 ecommerce

Share this post


Link to post
Share on other sites

Pourriez-vous faire un test minimal de vos livrable?

Le message d'erreur page blanche == erreur 500 == php fatal

Appel d'un fonction absente de votre module  dans votre controlleur Admin.

Autrement dit, le minimun de test fonctionnel non réalisé.

 

Merci d'avance

  • Like 1

Share this post


Link to post
Share on other sites

Bonjour, 

 

Nous avons bien évidemment effectué des tests sur le module Packlink que ce soit du coté 202 ou Packlink. 

De nouveaux tests ont été réalisés suite à votre message mais nous n'arrivons pas à reproduire. 

Jusqu'à ce jour, aucune demande de support n'a été remonté à par vous pour ce problème.

Pouvez-vous m'envoyer un mail via le support avec plus de détail sur la ligne impactée ? 

Pour cela il faut simplement activer le mode debug. 

Aussi, pouvez-vous me donner votre version PrestaShop ? S'agit-il d'un upgrade à partir de la version 1.6.2 ou d'une nouvelle installation ? 

 

Merci d'avance.

 

202 ecommerce

Share this post


Link to post
Share on other sites

1/ Bien sûr que nous parlons d'une mise à jour, d'ailleurs c'est précisé dans le titre non?

Pourquoi prétendre faire des tests mais pas ce cas?

 

2/ Le module version 1.6.0 contient une override, override/controllers/admin/AdminOrdersController.php

Pour le code complet il vous sufit de consulter vos propres archives

 

3/ Dans cet override, on lit des appel $module->setTranslation(x), le module version 1.6.3 ne contient pas cette fonction

Alors si vous n'avez pas reproduit l'erreur, c'est soit que vous vivez dans un autre univers où les ordinateurs fonctionnent différemment, soit plus probablement vous vous êtes contenté d'écrire la phrase "on ne reproduit pas", afin que quelqu'un d'autre fasse votre debug. votre boulot

 

4/ Vous constatez maintenant que cela démontre de l'absence du plus simple test, et la méconnaissance complète du fonctionnement des override dans prestashop.

 

5/ Oui le module peut fonctionner, a coup de quelques acrobaties hors de portée du gérant d'une boutique.

 

6/ M'ayant forcé avec vos réponses à faire votre travail de recherche de panne, vous me devez une heure de support. Vous pouvez procéder au règlement en prenant un ticket support ici: https://store.enter-solutions.com/fr/53-support-basic-pour-prestashop.html

 

 

----

La version que nous avons  Auteur: Expéditions Packlink PRO v1.6.0 - par 202-ecommerce

La version présentée sur le flux addons (modules_native_addons.xml) 1.6.3

[Fri Feb 10 12:17:20 2017] [warn] [client 77.141.55.82] mod_fcgid: stderr: PHP Fatal error:  Call to undefined method Packlink::setTranslation() in /var/www/clients/client27/web162/web/override/controllers/admin/AdminOrdersController.php on line 51, ...

 

 

PS: Puisque espérons le vous allez vraiment faire votre travail, profitez-en pour corriger le bug reporté de longue date sur le module paypal, qui lui aussi si vous le testiez, vous auriez constaté le problème de paypal/express_checkout/ajax.php

include_once _PS_ROOT_DIR_.'/init.php';

et oui surprise il manque un /

Share this post


Link to post
Share on other sites

Merci pour votre retour. 

 

Le problème était donc bien connu pour une montée de version de la 1.6.0 à la 1.6.3, nous avons bien répondu au support pour les clients ayant eu le problème avec l'ancienne version. Rien ne permettait de corriger le problème de la 1.6.0 à la 1.6.3 c'est pour cela qu'en passant par le support, une solution vous aurait été apporté.

Il a été recommandé de revenir à la version précédente (1.5.0) et un correctif a été réalisé avec la 1.6.3. 

N'hésitez pas à passer par le support plutôt que par les forums afin qu'on puisse vous donner tous les consignes comme il se doit.

Ainsi la majorité des marchands n'ont pas rencontré les soucis que vous avez eu.  

Pour le 6/, si vous nous aviez simplement contacté comme le recommande PrestaShop (via le support), vous auriez eu la solution en deux minutes.  :)

 

A bientôt via le support. 

 

202 ecommerce

Share this post


Link to post
Share on other sites

J'ai des doutes qu'un client puisse obtenir du support en 2mn à 22:30

 

Mais bon vous avez raison, vous êtes les meilleurs, c'est tout a fait normal que le flux officiel rende les boutiques inutilisables et je comprend qu'il soit très difficile de coder dans Upgrade_1.6.3.php la réécriture de l'override. Veuillez me pardonner d'avoir mis en doute votre volonté de mettre en péril sciemment les boutiques utilisant la solution de votre partenaire packlink.

 

Sur ce, bonjour chez-vous

 

EDIT: Un truc m'échappe, vous êtes parfaitement au courant du problème, alors pourquoi pendant 4 jours me dites vous que vous ne reproduisez pas?

Edited by doekia (see edit history)

Share this post


Link to post
Share on other sites

C'est surement comme la maj du module Paypal en 3.11.2 qui a planté plusieurs BO à cause d'un nom de config trop long (33 caractères au lieu de 32)

 

Curieusement le module a été retiré du flux mais les utilisateurs ayant déjà chargé celui-ci ce sont retrouvés coincés avec une version à moitié mise à jour et aucun moyen de s'en sortir à part détruire le flux et le fichier sql contenu dans le  répertoire upgrade^^

  • Like 1

Share this post


Link to post
Share on other sites

En même temps avec 300000 boutiques installées, ça permet de dire nous allons faire 300000 tests. Si un commerçant perd tout son shop, OSEF

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More