Jump to content
carbar

Admin Login Blank Page

Recommended Posts

Hi,

 

I have migrated my Prestashop 1.6 to an upgraded server. The shop seems to be working OK but I can not access the back-office. Instead of sign-in page, I'm directed to:
 

I've tried turning on debugging, checked permissions, cleared cache and smarty directory, disabled overrides and non-native modules, and deleted /cache/class_index.php and read almost all of related topics but there are no indication of errors!

 

So, any idea what to do next?

Thanks

 

Share this post


Link to post
Share on other sites

The url is correct, is there any htaccess in the admin folder? Are you totally sure that's the correct folder (admin123)?

Or

Do you mean you are sent to "mydomain.tld"?

Share this post


Link to post
Share on other sites

The url is correct, is there any htaccess in the admin folder? Are you totally sure that's the correct folder (admin123)?

 

Or

 

Do you mean you are sent to "mydomain.tld"?

There's no htaccess in admin123 but search suggests they are under import, export, backup, autoupgrade, and tabs directories and the domain is correct.

The domain name in the url is correct tho (not mydomain.tld)

Share this post


Link to post
Share on other sites

Still stuck in here! Also tried from this link:

http://stackoverflow.com/questions/11335073/prestashop-cant-login-in-admin

 

Here is some things you can try :

1/ Clear your browser cache and your cookies

2/ Try using Firefox instead of Chrome (which seems have some unexpected problems)

3/ Check PS_SHOP_DOMAIN and PS_SHOP_DOMAIN_SSL in ps_configuration table

4/ Manually clear smarty cache : remove all files from tools/smarty/compile and tools/smarty/cache

5/ Disable the IP check in classes/Cookie.php (this can causes many issues with dynamics IP) : in isLoggedBack(), remove or comment the fourth condition :

AND (!isset($this->_content['remote_addr']) OR $this->_content['remote_addr'] == ip2long(Tools::getRemoteAddr()) OR !Configuration::get('PS_COOKIE_CHECKIP'))

6/ Make the expire time shorter for cookies (IE can have issues with longest time cookies) : in classes/Cookie.php constructor,

set : $this->_expire = isset($expire) ? (int)($expire) : (time() + 3600);

instead of $this->_expire = isset($expire) ? (int)($expire) : (time() + 1728000);

Strange thing is that Prestashop displays no errors!

Share this post


Link to post
Share on other sites

Hi

I have the same pb, I have no access to the login page.

Instead I get a white page and have the extension url modified after I type the url with this added automatically:

index.php?controller=AdminLogin&token=31987e27fa51842bd707a41767fc6a49

Share this post


Link to post
Share on other sites

Hi,

 

I have the same problem, in a admin login,

login form only disable, backoffice not display.

Also website is 404 error

I am using the prestashop version : 1.6.1.12

 

it is worked fine in local system

 

I done following but not get result

clear cache

files permission

shop_url table changes

configuration table PS_SHOP_DOMAIN & PS_SHOP_DOMAIN_SSL changes

 

Please Help Me, sorry for my poor English

 

Thanks

Share this post


Link to post
Share on other sites

Have you tried turning on dev mode and seeing if you get any additional error?
I guess you changed the database connection info in settings.inc.php after moving the site?

Share this post


Link to post
Share on other sites

I've looked at setting.inc.php

I haven't changed the database connections.

What else do you suggest to check :)

When using google chrome to load the website it is said I have a virus

Share this post


Link to post
Share on other sites

You mean the database creds are still the local ones?
As for the virus, you might want to have your hosting company check your space, you might really have one

Share this post


Link to post
Share on other sites

I found the solution

1) may be htaccess file not uploaded

2) set folders and files permission

3) htaccess site url not changed for live site

 

these will check to solve that problem

Share this post


Link to post
Share on other sites

In my case the admin page was blank, but after I check the PHP Version and changed from 7.2 to 7.0 it works.

  • Thanks 1

Share this post


Link to post
Share on other sites

I had same issue, and i have solved it by doing - all errors to false

 

If your code in - public_html/config/defines.inc.php is true, so put it to false.  becoz in production use it's not necessary.

 

/* Debug only */
if (!defined('_PS_MODE_DEV_')) {
define('_PS_MODE_DEV_', false);
}
/* Compatibility warning */
define('_PS_DISPLAY_COMPATIBILITY_WARNING_', fasle);
if (_PS_MODE_DEV_ === true) {
    @ini_set('display_errors', 'off');
    @error_reporting(E_ALL | E_STRICT);
    define('_PS_DEBUG_SQL_', false);
} else {
    @ini_set('display_errors', 'off');
    define('_PS_DEBUG_SQL_', false);
}

define('_PS_DEBUG_PROFILING_', false);
define('_PS_MODE_DEMO_', false);

 

Hope it will help.

 

Thanks

Grapyhost

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More